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1. About this document

1.1 Version information
This document provides information for system managers about installing and upgrading
IRIS and RDA software.

Familiarity with operating system concepts is required.

Table 1 Document versions (English)

Document code Date Description

M211315EN-L April 2023 Tenth version. IRIS 10.0.0.

Updates include:
• Support for RVP10
• New file system hierarchy
• New installation process
• New upgrade process

M211315EN-K June 2022 Ninth version. IRIS 9.2.0

M211315EN-J April 2021 Eighth version. IRIS 9.1.0

1.2 Related documents
Table 2 Vaisala Weather Radar documentation

Document code Name

M211315EN IRIS and RDA Software Installation Guide

M211316EN IRIS and RDA Utilities Guide

M211317EN IRIS Radar User Guide

M211318EN IRIS Programming Guide

M211319EN IRIS Product and Display Guide

DOC236879 IRIS RDA Release Notes

M212604EN RVP10 Digital Receiver and Signal Processor User Guide

M211320EN Radar Control Processor RCP8 User Guide

M211849EN IRIS Focus User Guide

M211850EN IRIS Focus Administrator Guide

M211904EN IRIS Focus Release Notes

Vaisala encourages you to send your comments or corrections to helpdesk@vaisala.com.

Chapter 1 – About this document
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1.3 Documentation conventions

Warning alerts you to a serious hazard. If you do not read and follow
instructions carefully at this point, there is a risk of injury or even death.
WARNING!

Caution warns you of a potential hazard. If you do not read and follow
instructions carefully at this point, the product could be damaged or important data
could be lost.

CAUTION!

Note highlights important information on using the product.

Tip gives information for using the product more efficiently.

Lists tools needed to perform the task.

Indicates that you need to take some notes during the task.

1.4 Trademarks
IRIS™ is a trademark of Vaisala Oyj.

AlmaLinux™ is a trademark of AlmaLinux OS Foundation.

Linuxâ is a registered trademark of Linus Torvalds.

All other product or company names that may be mentioned in this publication are trade
names, trademarks, or registered trademarks of their respective owners.
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2. File system hierarchy tree
├── etc
│   ├── vaisala
│       └── irisrda
│           ├── images
│           ├── init
|           ├── listings
|           ├── menu
|           └── overlay
│       └── irisrda_templates
│   ├── systemd /* service files */
│   ├── profile.d /* shell script files */
│   ├── rc.d
│       └── init.d /* rc files */
│   └── logrotate.d /* logrotate conf files */
├── srv
│   └── iris_data
│       ├── ingest       /* IRIS ingest files */
│       ├── product      /* IRIS derived product files */
│       ├── product_raw  /* IRIS RAW (packed ingest) files */
│       ├── tsarchive    /* saved IQ data */
│       ├── tape_inv     /* tape backup metadata */
│       ├── ascope     /* Data saved from ascope utility */
│       ├── suncal     /* Sun based calibration utility data */
|       ├── temp       /* temp storage */
│       └── zdrcal     /* ZDR calibration utility data */
├── usr
│   ├── libexec
|       └── vaisala    
|           ├── pipes /* pipes from data_converters */
|           └── irisrda /* scripts for irisrda */
│   ├── bin /* executables for irisrda */
│   ├── share
│        ├── X11 /* app defaults resorce files */
│        ├── nls /* po files */
│        ├── vaisala
│            └── irisrda
│                ├── icons /* icon files */
│                ├── sounds /* sound files */
│                └── keys /* key files */
│        └── doc /* user documentation, release notes and lisence files */
│   ├── lib64 /* all libraries */
│   └── include
│        └── vaisala/* all header files */

Chapter 2 – File system hierarchy tree
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└── var     
    ├── log
        └── irisrda /* all log files */
    └── spool
        └── vaisala-io
            ├── input      /* Default IRIS input directory */
            ├── output     /* Default IRIS output directory */
            ├── raw
            ├── volume
            └── temp       /* Conversion pipes temp storage */
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3. Installation image options
IRIS/RDA 10.0.0 requires the AlmaLinux 8.7 operation system.

Vaisala provides customized ISO images for AlmaLinux 8.7 and IRIS/RDA software on the
Vaisala FTP website:

https://ftp.sigmet.vaisala.com/files/releases

ISO Image Notes Instructions

Combined AlmaLinux OS and
IRIS/RDA sw ISO image

Automatically installs both the
AlmaLinux 8.7 operating system
and the IRIS/RDA software.

Available on USB drive and FTP
site.

You can also use this image to only
install the IRIS/RDA software.

Installing OS together with IRIS/
RDA: Chapter Installing IRIS/RDA
and AlmaLinux with Kickstart

Installing only IRIS/RDA: Chapter
Installing IRIS/RDA software

IRIS/RDA software as standalone
ISO image

This image is smaller than the
combined ISO image, so it is faster
to download.

Available on the FTP site.

Chapter Installing IRIS/RDA
software

AlmaLinux operating system as
standalone ISO image

This image is smaller than the
combined ISO image, so it is faster
to download.

Available on the FTP site.

Appendix Installing AlmaLinux 8.7

Online and offline installation of IRIS/RDA standalone ISO

When installing the IRIS/RDA standalone ISO, you can select either online or offline
installation. The online option enables access to RPMs from remote repositories that are
needed if the host system does not contain dependencies that come from AppStream and
BaseOS repositories. These repositories are automatically included when the combined OS
and software ISO image used. The online installation requires Internet connection.

If you select the offline installation option, the installation only uses the repositories
provided by ISO image and does not try to access remote repositories. In this case, for
example, devel packages cannot be installed, because they require a specific version of
base packages and this requires to access to remote repositories.

Chapter 3 – Installation image options
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4. Installing IRIS/RDA and
AlmaLinux with Kickstart

4.1 Creating Installation Media
After creating and initializing the installation media, you can run the installation process.

4.1.1 Creating USB Installation Media on Windows
These instructions apply to Windows 10 and Windows 11.

When creating USB installation media on Windows, use a standalone program such as
rufus (available at http://rufus.akeo.ie/). Follow the on-screen instructions.

1. Launch rufus by double-clicking the program icon.

2. Insert a USB drive in the USB port.

3. Select the drop-down list to the right of the Create a bootable disk using, and select
ISO Image.

4. Select the Disc icon and then select the iso image.
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5. Select Write in DD Image mode if a warning for the hybrid ISO image is displayed.

6. Select Close.

4.1.2 Creating USB installation media on Linux (AlmaLinux)

This operation destroys data on the device you operate on.CAUTION!

1. Run $ lsblk to list block devices on your system. Take note of the output.

2. Insert a USB drive in the USB port.

3. Run $ lsblk.

Compare the output to the previous step. The additional block device from this output
is your USB drive.

4. Run $ dd if=path/toAlmalinux.iso of=/dev/xxx
Where /dev/xxx is the path to the USB drive. Do not use the partition number for the
USB drive.
For example: /dev/sdc.

Chapter 4 – Installing IRIS/RDA and AlmaLinux with Kickstart
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4.2 Running the installation with Kickstart
1. In the AlmaLinux 8.7 window, select Test this media & install AlmaLinux 8.7, and press

ENTER.

The Installation Summary page opens.

2. When prompted, configure the hostname and IP address.
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3. Select Software Selection.
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4. Select Server with GUI and the software you want to install, such as IRIS Analysis, RCP8
Utility, and RVP10 Utility.

For more information on the options, see Running the installation script (page 24).
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5. In the Installation Summary page, select Begin Installation.

The installation process begins.

6. When the installation is complete, the system will reboot automatically.

4.3 Enabling login as root for using IRIS
Focus

If you are installing IRIS Analysis and IRIS Focus on the same server, you need to enable
logging in as root.

1. Log in as admin user.

2. Type:

$sudo passwd root

3. Follow the prompts.

4. Log out, and log in as root.

Chapter 4 – Installing IRIS/RDA and AlmaLinux with Kickstart
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4.4 Logging in as radarop
The IRIS / RDA software installation creates two additional default user accounts: radarop
and observer.

1. Select the radarop login icon.

2. Enter the default password (xxxxxx).

3. On the first login, change your password.

4.5 Verifying that the services are
running

1. If you have not done so already, log in as radarop.

2. In the terminal window, list the services currently running by typing:

# ps_iris

The COMMAND column lists the running services.

Option Running services

-rvp10 rvp10

-rcp8 rcp8

You may also see the that antenna (ant_*) and receive (rtd_*) processes have
started.

IRIS does not start until you have installed the IRIS license.

More information

‣ ps_iris command (page 78)
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4.6 Configuring IRIS license setups

Figure 1 License setup example

Before you can use IRIS/RDA software, you must request and set up a license.

1. Open the Setup utility by typing:

setup&

Chapter 4 – Installing IRIS/RDA and AlmaLinux with Kickstart
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2. In the Setup utility, select License.

a. Delete the default texts in the License fields.

b. Depending on your setup, for IRIS Style, select either Radar or Analysis.

c. In Site name, type a name for the machine (typically the host name of the machine).

For example: hel-radar
d. In Site code, type a code name for the radar site.

For example: HEL
e. In the IRIS License Setups window, select File > Close

f. Select File > Save and File > Exit.

3. In the terminal window, type: show_machine_code
The terminal prints the licensing information about this machine. For example:

--------------------------------------------------- 
Licensing Information for IRIS Version 10.0.0
---------------------------------------------------

Machine Code: EMNTRK
Site Name: hel-radar 
Check Code: WPEFXE
OS Name: Linux
OS Release: 3.10.0-229.el7.x86_64
Host Name: localhost.localdomain
Locking To: host

4. Copy all the information under Licensing Information for IRIS Version
<version number>

5. Contact your Vaisala representative and request an IRIS license.

Provide the information you copied in the previous step.

6. When you receive the license from Vaisala, return to Setup > License and type the
License 1, License 2, ... license codes in the order listed in the license.

Depending on your configuration, you may have codes such as:
• IRIS Features Code
• IRIS Product Code
• RDA Features Code

7. Select File > Save and File > Exit.
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8. To confirm that your license is correctly setup, start IRIS by typing:

siris

Check that the IRIS Quick Look Window starts.
If the IRIS Quick Look Window does not start, see Making Quick Look Windows (QLW)
appear (page 49).
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5. Installing IRIS/RDA software
(standalone)

5.1 IRIS/RDA installation overview
Installing the IRIS/RDA software from the installation media with a script involves the
following steps. The steps are described in detail in the following chapters.

1. Install the AlmaLinux operating system according to Appendix Installing AlmaLinux.

2. Log in as root.

See Logging in as root (page 22).

3. Install the IRIS / RDA installation media, and verify that it mounts.

See Mounting the installation media and verifying the mount point (page 23).

4. Open the CLI terminal.

5. Run the installation script.

6. Verify that the expected services have started.

See Verifying that the services are running (page 18).

7. Configure your licenses.

See Configuring IRIS license setups (page 19).

8. Check and update your firmware as needed:

• Installing IO-62 firmware (page 40)
• Installing RVP10 (RDA) firmware (page 42)

5.2 Logging in as root
1. In the login screen displaying your user accounts, select Not Listed? below the user

account login box.

2. Enter root as the user name and your root password.

The system displays a welcome message after the first time you log in and a blank
screen after other logins.
If prompted, select your language and input settings.

You can now continue with the IRIS/RDA software installation.
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5.3 Mounting the installation media and
verifying the mount point

The IRIS/RDA installation media can be either a USB drive or a DVD disc.

1. Install the USB drive in the USB port of the server, or install the DVD disc in the DVD
drive.

2. If you are using a DVD drive, a small black window indicates that the DVD disc has been
recognized.

Select X in the upper right corner to close the window.

3. Verify that the installation media is recognized with the mount point by typing:

df

The installation media should be listed with the mount point in /run/media/root/
irisrda_X.XX.X, where X.XX.X is the version of software you are installing.

4. If you do not see the installation media listed, try the following:

• Insert the USB drive to a different port
• Run the lsblk command to see if the installation media shows on the list. If it

shows, mount it manually with the command:

 mount -o loop dev/<usbdevice> /mnt

, where usbdevice is the name of the USB drive from the lsblk list.
In the case of a DVD, replace <usbdevice> with the the DVD from the lsblk list.

5.4 Opening a terminal window
1. In the upper left corner, left-click Applications.
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2. Move your cursor to highlight the terminal and select it.

A terminal window with a prompt opens.

3. Remove the user you created during the operating system installation.

For example, if you created the user service, type:

# userdel -r service

5.5 Running the installation script
The vaisala-iris-rda-install.sh script automatically performs all the processes
the make the system ready to run. For example, the script installs the requested products
with their dependencies, creates directories, and configures paths and users.

The script also sets up a local repository that is required for installing upgrade packages via
DNF.
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1. Change to the directory where the IRIS/RDA installation media is mounted.

For example, if the mounting point is /run/media/root/irisrda, type:

# cd /run/media/root/irisrda

2. Run the installation script with desired parameters by typing:

./vaisala-iris-rda-install.sh <parameter>

, where <parameter> can be any of the following:
• --help: Prints out the applicable parameters.
• --iris: Installs IRIS on a running system (with all dependencies, including common

package).
• --rcp8: Installs RCP8 on a running system (with all dependencies, including
common and rda packages).

• --rvp9: Installs RVP9 on running system (with all dependencies, including common
and rda packages).

• --rvp10: Installs RVP10 on a running system (with all dependencies, including
common and rda packages).

• --rvp9 and --rvp10 options cannot be used at the same machine.

• --converter "<converter_name> <converter_name>
<converter_name> ...": Installs data-converters-
<converter_name> on running system (with all dependencies, including common
package). Accepts converter list inside quotes as argument.
The option --help shows all converter names that can be installed with the script.

• --online: provides access to remote repositories that is set up on system.
• --offline: forces the script to use the repositories provided by the ISO image. No

access to remote repositories.
• --with-os: If you want to point the external DVD ISO for dependencies that come

from AppStream and BaseOS, provide the mount path of the Almalinux DVD.
Providing --os-media may be useful if third party dependencies are not already
installed on your system and installation image does not include those
dependencies when you are running the offline installation.

3. Reboot the system to apply changes and to run enabled services:

reboot

Chapter 5 – Installing IRIS/RDA software (standalone)

RESTRICTED 25



5.6 Logging in as radarop
The IRIS / RDA software installation creates two additional default user accounts: radarop
and observer.

1. Select the radarop login icon.

2. Enter the default password (xxxxxx).

3. On the first login, change your password.

5.7 Verifying that the services are running
1. If you have not done so already, log in as radarop.

2. In the terminal window, list the services currently running by typing:

# ps_iris

The COMMAND column lists the running services.

Option Running services

-rvp10 rvp10

-rcp8 rcp8

You may also see the that antenna (ant_*) and receive (rtd_*) processes have
started.

IRIS does not start until you have installed the IRIS license.

More information

‣ ps_iris command (page 78)
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5.8 Configuring IRIS license setups

Figure 2 License setup example

Before you can use IRIS/RDA software, you must request and set up a license.

1. Open the Setup utility by typing:

setup&
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2. In the Setup utility, select License.

a. Delete the default texts in the License fields.

b. Depending on your setup, for IRIS Style, select either Radar or Analysis.

c. In Site name, type a name for the machine (typically the host name of the machine).

For example: hel-radar
d. In Site code, type a code name for the radar site.

For example: HEL
e. In the IRIS License Setups window, select File > Close

f. Select File > Save and File > Exit.

3. In the terminal window, type: show_machine_code
The terminal prints the licensing information about this machine. For example:

--------------------------------------------------- 
Licensing Information for IRIS Version 10.0.0
---------------------------------------------------

Machine Code: EMNTRK
Site Name: hel-radar 
Check Code: WPEFXE
OS Name: Linux
OS Release: 3.10.0-229.el7.x86_64
Host Name: localhost.localdomain
Locking To: host

4. Copy all the information under Licensing Information for IRIS Version
<version number>

5. Contact your Vaisala representative and request an IRIS license.

Provide the information you copied in the previous step.

6. When you receive the license from Vaisala, return to Setup > License and type the
License 1, License 2, ... license codes in the order listed in the license.

Depending on your configuration, you may have codes such as:
• IRIS Features Code
• IRIS Product Code
• RDA Features Code

7. Select File > Save and File > Exit.

IRIS and RDA Software Installation Guide M211315EN-L

28 RESTRICTED



8. To confirm that your license is correctly setup, start IRIS by typing:

siris

Check that the IRIS Quick Look Window starts.
If the IRIS Quick Look Window does not start, see Making Quick Look Windows (QLW)
appear (page 49).

5.9 Configuring SSH
You must set up an ssh connection from one computer ( the host) to another (target) so
that users can login from host to target without a password, and IRIS can send data from
the host to the target.

1. Login to the host computer as root.

2. Check if .ssh directory exists.

If not, then create the directory by typing:

ssh-keygen -t dsa

When prompted with questions, press ENTER without typing anything.

3. Type:

ssh-copy-id -i id_rsa.pub radarop@remotehost

4. When prompted for login, enter the readarop password.

5. After a successful login, log out again.

6. On the host computer, test the SSH connection as root with the command:

ssh radarop@remotehost date

You should get the date and time display from the remote host without a password
prompt.

You can now send data from the host computer to the target through the IRIS product
output menu.
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6. Upgrading IRIS and RDA
Software

6.1 IRIS RDA upgrade overview
This chapter describes how to upgrade from IRIS/RDA 10.0.0 to later releases.

The upgrade is handled by the DNF package manager installed by the IRIS 10.0.0 installation
script. In the upgrade process, the DNF replaces existing RPMs with new RPMs.

The upgrade process includes the following steps:

1. Back up your configuration files. See Preparing for the upgrade (page 30).

2. Get the latest software release ISO image and Release Notes at https://
ftp.sigmet.com/files/releases/. See Getting upgrade software (page 32).

3. Run the install script. DNF identifies new versions of RPMs included in the installation
image, and automatically triggers the upgrade process to higher versions. See Running
the installation script (page 24).

4. Run the Setup utility. See Running Setup after upgrade (page 34).

6.2 Preparing for the upgrade
1. Login as root.

The default password is xxxxxxxx.
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2. Back up and save important configuration files.

As part of the upgrade, many files are erased and replaced. However, the upgrade
procedure preserves everything in ${IRIS_CONFIG}.

a. Back up and save customized configuration files.

b. Even though this file is not overwritten during the upgrade, create a backup
of /etc/vaisala/irisrda:

# cd /etc/vaisala/
# tar cfz <config_nodename_date.tgz> irisrda/

c. To back up the whole installation (for example, to support rollback), back up /etc/
vaisala:

# cd /etc/
# cp -R vaisala/ sigmet_versionNumber/

3. Print the current setup.

Run the Setup utility on the old system, and generate an ASCII listing file with the
File/List command.
The format of these files can change between software versions, so you may need to
re-enter some information.
A date coded listing file is generated in the ${IRIS_LISTING} directory, typically in
etc/vaisala/irisrda/listings.
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4. Make sure all applications are stopped by exiting any IRIS/RDA utilities that you are
running and executing the following commands.

• For IRIS:

$ qiris

• For RDA:

$ su
service rvp10 stop (and/or service rcp8 stop) 
service dspexport stop 
qant

• For IRIS and RDA:

qiris
service rcp8 stop
service rvp10 stop
service dspexport stop 

//if dspexport is running
qant

5. Verify that all processes have stopped by typing:

ps_iris

6. Stop any running processes as root with the kill <process ID number>
command.

The process ID number is the first column of numbers from the ps_iris output.

6.3 Getting upgrade software
New features and updates are provided as software upgrades from the following sources:

• FTP download
Connect to the Vaisala Sigmet server in ftp.sigmet.vaisala.com.
• If using a web browser, navigate to /files/releases/<latest version>
• If using an FTP client, navigate to /outgoing/releases/latest version>

These public releases are free of charge, but do not include support services unless you
are under warranty or have purchased a support contract from Vaisala. Contact your
Vaisala representative to arrange a support contract.
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• USB drive or DVD disc
Provided as part of a support contract or upon request.

6.3.1 Downloading upgrade files
If your radar server does not have Internet access, download the upgrade files first to
another computer, and then transfer the files as instructed in step 10.

The examples in this procedure use release 10.0.0 as an example. In most cases, you install
the most recent version, labelled below as X.XX.

1. Create a directory named /tmp/iris-X.XX.

2. If you are downloading RDA software, create a directory named /tmp/rda-X.XX.

You should make a separate directory for each version and type (IRIS/RDA) of software
that you download.

3. Login as radarop.

$ cd /
$ mkdir /tmp/rda–10.0.0

4. Change to the /tmp directory by typing:

$ cd /tmp/rda-10.0.0

On Windows machines, you can type the commands in the command prompt
(remember to use the "\" backslash for DOS).

5. Start the FTP browser.

6. In the directory listing of available releases, find your release.

7. Download the irisrda_image.iso.

8. Change to the root account using the su command and password.
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9. Go to the directory where the files were downloaded and change the mode on two of
the files that require execute privilege:

# cd /tmp/rda-10.0.0
# chmod +x install
# chmod +x instiris

10. If you need to transfer the files from a separate computer to the server computer, follow
these steps:

a. Use FTP transfer, a USB drive, or a DVD disc to transfer the files from the other
computer to the server computer.

b. On the server computer, change to the root account using the su command and
password.

c. Go to the directory where the files were downloaded, and change the mode on two
of the files that require execute privilege:

# cd /tmp/rda-10.0.0
# chmod +x install
# chmod +x instiris

6.4 Running Setup after upgrade
After upgrading, the Setup utility fills in default values for any new settings that were added.
It is recommended that you read the Release notes document, then check the new settings
to make sure they are right for your system.

1. Login as radarop.

2. Launch the Setup utility.

At startup for an upgrade, Setup checks the parameters to verify that they are within
reasonable bounds and lists any problems.
The listing gives the name of the variable in question and prompts the user to consider
the repair command. Errors are usually related to new features that have not been
addressed or outdated features that do not conform to the current upgrade.

3. In the list dialog, select Repair to replace any mismatches with the appropriate default.

4. If you receive errors related to customized fields that are important to your operation,
see Invoking setup and built-in error checking (page 34).

6.4.1 Invoking setup and built-in error checking
When IRIS starts, it performs configuration and bounds checks.
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For new users, the Setup parameters are typically correctly set and do not cause any
configuration errors. If an error does occur, follow these steps.

1. In the terminal window, type: setup&
The Setup utility launches.

There are 2 variants of the Setup utility: one for IRIS and one for the RDA (RVP
signal processor or an RCP8 antenna controller).
The RDA variant does not show the IRIS setup features.

2. Select the part of the system setup you want to check or configure.

3. Make your changes and close the window for the selected part of the system.

4. Select File > Save.

The configuration files are now updated.

5. To create a listing file of the Setup configuration:

a. Select File > List.

A listing file called YYYYMMDDHHMM.setup is created in the ${IRIS_LISTINGS}
directory.
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6. To take the configuration changes into effect, restart the application:

a. For changes made to the Setup > IRIS section, restart the IRIS daemons by typing:

qiris
siris

b. For changes to the Setup > RVP section, stop any running utilities with the
command service <services> stop , for example:

service iris rvp10 rcp8 stop

c. Restart the utilities with the command service <services> start, for
example:

service iris rvp10 rcp8 start

RVP has a configuration state accessible through dspx. Part of that state is local to
the processor and part of it is also visible in Setup > RVP.

d. For changes to the Setup > RCP section, in addition to the above, you must stop
RCP8 (if you have one), and stop the antenna daemons, by typing:

$ qiris
$ sudo service rvp10 stop
$ sudo service rcp8 stop 
$ qant
$ sudo service rcp8 start 
$ sudo service rvp10 start 
$ siris

RCP8 has a configuration state accessible through Antx. These changes take effect
when you return to the top level prompt. You must save your changes.

License changes can affect RVP and IRIS.
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7. If an error list is displayed,

a. Check the error list for parameters that you have customized and correct these
customizations.

b. Select Repair to make corrections that are necessary for the software but do not
need to be customized for your operation.

c. Select File > Save.

6.5 Checking the kernel module status
After installation or upgrade, check that the RDA kernel module has been installed and
loaded. If the kernel module has not been loaded, the rvp10 process will not start.

To check this, type:

lsmod | grep rda

If no data is displayed, the kernel module has not been loaded or installed properly.

To check the status of the kernel module, type:

systemctl status systemd-modules-load.service

If the kernel module is not running, start the module by typing:

systemctl start systemd-modules-load.service
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7. Configuring RDA software
After the receiving your unit from the factory, or after software re–installation, you must
configure the software to customize your system for your environment and application.

Table 3 RDA configuration tools

Configuration tool RDA device Description

setup/RVP utility

setup_dsp.conf
See IRIS and RDA Utilities Guide
(M211316EN).

RVP10 Configures the local environment required to
run RVP support utilities such as Ascope and
dspx.

Examples: radar equation parameters that are
required for calibration, pulse width definitions,
and PRF request limits.

setup/RCP utility

setup_ant.conf
See RVP10 User Guide
(M212604EN).

RCP8 Configures the local environment required to
run the RCP8 support utilities that such as
Antenna or Bitex.

Examples: max allowed AZ/EL velocity request,
MIN and MAX elevation angles that can be
requested, and LAT/LON of radar for sun
tracking.

RVP10 NV setups

rvp10.conf
See RVP10 User Guide
(M212604EN).

RVP10 Defines the details of the sampling and
processing algorithms, as well as the
operational configuration of the system.

Examples: IF filter design and selection, PRF
limits, relative trigger timing, dual-polarization
features.

RCP8 NV setups

rcp8.conf
See RCP8 User Guide (M211320EN).

RCP8 Configures which status and control bits are
available and define the antenna servo control
parameters.

Examples: physical or virtual tachometer
selection, shutdown safety criteria and internal
antenna simulator on/off.

softplane.conf RVP10

RCP8

Defines the I/O signals on the I/O-62 connector
panel, pin-by-pin.

Examples: whether a line is an input or output,
electrical specification such as RS422 or TTL,
what local variable name is associated with
each line.

During installation, you must configure the Setup utility and the TTY setups for your
system.

The configuration results are stored as ASCII text .conf files, typically in the /etc/
vaisala/irisrda directory. Each file has a factory default configuration file that is stored
in the template directory. The default is:
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/etc/vaisala/irisrda/templates/init/

For a radar network with identical hardware, you can perform configuration maintenance
by copying pre-tested files over the network.

Chapter 7 – Configuring RDA software

RESTRICTED 39



8. Installing IO-62 firmware
If you have installed or upgraded the RDA software, and your system includes an IO-62 card
and connector panel, you must update the firmware running on RCP8 to be compatible with
the installed RDA software.

1. Login as root
2. Check for running processes by typing: ps-iris
3. Stop any running processes by typing:

# qiris
# quant

4. Log in as radarop (with password xxxxxx)

You enter X–Windows.

5. Right-click and start a terminal window.

6. For each Vaisala component, type the appropriate command. For example:

Vaisala component Command

Standard I/O-62 card io62-0

Standard connector panel io62cp-0

7. Shut down the system by typing: poweroff
8. When Power down is displayed, turn power off with power switch on lower right of

front panel.

The FPGA software installation is complete.

9. Reboot the unit.

Follow the progress of the reboot on the monitor. The front panel LED display shows
the time of the reboot and display diagnostic messages.
The reboot takes about 1 minute.

10. Stop the RCP process by typing:

$ killall rcp8
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11. Run the following diagnostics and observe the results:

$ rdadiags io62–0 
 $ rdadiags io62cp-0 

12. Restart the RCP8 process by typing:

rcp8 &

13. Verify that the restart messages show no faults.

14. Configure RCP.

See RCP8 User Guide (M211320EN).
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9. Installing RVP10 (RDA)
firmware

Before installing RVP10 (RDA) firmware, make sure that:
• The second Ethernet port has been configured. See Configuring the system and

network (page 62).
• IFDR10 is physically connected to the port.

If you have installed or upgraded the RDA software, you must update the firmware running
on IFDR10 to be compatible with the installed RDA software.

1. Reboot the computer.

2. Login as radarop.

3. If IRIS / RDA services are running, turn them off.

a. Check what is running.

# ps_iris

b. If any services are running, stop them.

# service iris stop
 # service rvp10 stop
 # service rcp8 stop 
 # service dspexport stop
 # service antennad stop

4. Verify that all services have stopped:

# ps_iris

If there are services running, stop them using the service or systemctl commands
or manually kill them.
You must be logged in as root to use the kill command:

# su
 # kill <process ID number>

5. If not powered, power on IFDR10, and wait for it to boot.
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6. If the network cable is not attached, attach IFDR10 to the second Ethernet connection
configured for the 10.0.3.x network.

7. Verify that IFDR10 is accessible over Ethernet.

Run ping letting at least 4 packets transmit, and press CTRL+C to exit program.
Verify that there is 0% packet loss.

# ping 10.0.3.254

10.0.3.254 is the default IP address of IFDR10.

8. Change to the repository where the image is installed (be default /usr/bin):

cd /usr/bin
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9. Use the rdaflash utility to update the IFDR10 firmware:

rdaflash -ifdr10

This takes several minutes. Do not interrupt programming.

When programming starts, do not power cycle or reboot IFDR10 until
rdaflash is successfully completed.
CAUTION!

When the programming is complete, IFDR10 reboots.

10. Reboot the computer and login as radarop.

11. Verify that the expected process are running with the command:

# ps_iris
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12. Configure RVP.

See RVP10 User Guide (M212604EN).

13. If the upgrade is interrupted or not completed successfully, the unit stays in diagnostic
mode on the next reboot so you can recover from the failure.

14. For RVP upgrades, if the RDA software boots, but is unresponsive, you can force the
RVP into diagnostic mode by sticking a paper clip in the inner most hole on the side of
the enclosure.

After entering the diagnostic boot mode, you can re-flash the IFDR10 software from the
signal processor to recover from a corrupted image.

If the IFDR10 firmware upgrade is part of a software upgrade process, see Running Setup
after upgrade (page 34).

Chapter 9 – Installing RVP10 (RDA) firmware

RESTRICTED 45



10. Login, logout, and
shutdown

10.1 Powering up
When you power-up the computer, the system goes through an automatic startup of the
operating system at the end of which the software starts and performs power–up self tests.

If you are not doing any diagnostic or software maintenance work on the system, there is no
need to log-in after power-up. When you turn the unit on, your application software takes
over.

10.2 Local and remote login
You can login either locally or remotely.

• Login locally using the local workstation or through a KVM.
• You can login remotely if ssh is enabled. Check with your network administrator.

Here, we assume a local login is used.

10.3 Default operator and root user login
passwords

The standard software installation defines three standard users:
• root (password: xxxxxxxx)— for operating system maintenance functions.
• radarop (password: xxxxxx)— for application software maintenance functions.
• observer (password: xxxxxx)

The system administrator can change either of these passwords using the standard Linux
password support.

10.4 Logging in

10.4.1 Local login as operator after powerup

1. At the power-up login prompt, type radarop and press ENTER.

When prompted, provide the password (factory default is xxxxxx).
An X-Window screen appears.
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2. Right-click and select New Window to get a terminal window.

The top of the terminal window shows your user name, the node name of the system,
and the current directory path.

10.4.2 Switching from radarop to root user

1. Type the super user command: su -
2. Type the root password (factory default is xxxxxxxx)

The prompt changes from $ to #, indicating that you are root.

10.4.3 Switching from su root user to radarop
In the terminal where you are the super user (su), type: exit
The prompt changes from # to $.

10.4.4 Logging in as root
You can login as root after a power–up or after exiting X–Windows.

1. Type: root
2. In the login prompt, press ENTER and type the root password.

You are now in a full screen terminal. This is not as convenient as X–Windows since only one
terminal can be displayed on the screen.

If you need a second full screen terminal, type ALT+F2. You can return to your original
terminal by typing ALT+F1. The other function keys can provide additional terminals.

10.5 Powering off
1. Type poweroff.

The system goes through a shutdown sequence. When it is done, Power down is
displayed.
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11. Troubleshooting

11.1 Correcting File Ownership and
Protection

Sometimes, when starting or program or trying to access calibration files, users cannot
access some files or receive an error message saying they do not have privileges to do an
operation.

This is because the file ownership and protection settings are incorrect.

Do not change the file protection manually. Always use instiris –setown to fix the
protection of your files.

1. To correct the file ownership and protection, type:

# instiris –setown

The script goes through the /etc/vaisala directory tree, changing the ownership of
the files to operator and setting the protection as follows:
• Directories—rwxrwxr–x
• All files, except executable files—rwrw–r--
• Executable files—rwsrwsr–x

11.2 Authorizing remote X–Windows on
your node

1. To enable IRIS systems running on other nodes to send output to your screen, enter
the command:

$ xhost  +<host>

Where <host> is the remote hostname, or IP address.

2. Check that this works as you intend.
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3. Add the appropriate command at the end of one of the following files:

• To authorize the windows as soon an anyone logs in: /etc/profile.d/
sigmet.sh

• To support just one user authorizing the windows: home
directory .bash_profile

11.3 Making Quick Look Windows (QLW)
appear

For any problem that prevents the window from starting, IRIS prints:

OUTPUT, Error in open_display call.

The Radar Status menu also indicates Error and Exit next to the window process.

If you cannot identify the problem from the error message:

1. Check that the workstation is turned on and the network is up and running.

2. Login as radarop.

3. Open the Radar Status menu and toggle the Product Output process off/on.

4. In the command prompt of the workstation where the window should appear, check
the user rights by typing:

xhost+

5. Restart IRIS on your workstation by typing:

sudo service iris restart

This command restarts all IRIS processes.CAUTION!

IRIS tests each process and restarts any that have stopped.
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6. If the IRIS Quick Look Window (QLW) does not appear after typing siris in a terminal
window:

a. Log in as root.

b. In the first line of the /etc/hosts file, add the host name to the first line of the file:

127.0.0.1 <host-name> local host... 

11.4 Replacing failed OS RAID disks
RAID1 is automatically configured on the server. However, in some cases, you may need to
remove, recover, and add new devices to RAID.

In most cases, this requires removing the failing disk and installing a new one.

While you can do this while powered up, if the system allows you to power down, do so.

1. To check the status of the RAID1 disk, type:

cat /proc/mdstat

When RAID1 is working correctly, the terminal prints, for example:

Personalities : [raid1]

md126 : active raid1 sda[1] sdb[0]

      125032448 blocks super external:/md127/0 [2/2] [UU]

md127 : inactive sdb[1](S) sda[0](S)

      4520 blocks super external:imsm

• [UU] indicates that both disks are operational.
• If there is a problem with one of the disks, the [UU] string is [_U] or [U_].

2. Check if disk sda or sdb has failed.
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3. To remove the disk from RAID configuration, type:

Take care when removing the failing disk.
Remove only the disk identified as failing. In the following example, it is sdb.

mdadm --manage /dev/md/imsm0 --remove /dev/sdb

The terminal prints:

mdadm: hot removed /dev/sdb from /dev/md/imsm0

4. Power down computer, replace the failing disk, and reboot

5. To create the partition on the replacement disk, type:

sfdisk -d /dev/sda | sfdisk /dev/sdb

6. To verify the partition, type:

fdisk –l

7. To add a new disk to the raid array, type:

mdadm --manage /dev/md/imsm0 --add /dev/sdb
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8. To check the recovery process, type:

cat /proc/mdstat

The terminal prints:

[root@wes-install ~]# cat /proc/mdstat

Personalities : [raid1]

md126 : active raid1 sdb[2] sda[1]

      125032448 blocks super external:/md127/0 [2/2] [UU]

md127 : inactive sdb[1](S) sda[0](S)

      4520 blocks super external:imsm

 unused devices: <none>
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Appendix A. Installing
AlmaLinux 8.7

A.1 Overview to installing AlmaLinux 8.7

IRIS software release 10.0.0 requires the AlmaLinux 8.7 operation system.

Vaisala provides a customized ISO image for AlmaLinux 8.7 on the Vaisala FTP website at:

https://ftp.sigmet.vaisala.com/files/releases/AlmaLinux/

Vaisala supports two installation methods from the Vaisala spin version of the ISO image:
• Automatic - unattended installation
• Manual - interactive installation

For both installation methods you can use the local USB device as your installation media.

We recommend that you use the automatic process unless you have special system
configuration needs or if your custom configuration fails the automatic installation process.

Installing Linux requires a Linux software installation tree and a boot device. You must
transfer the AlmaLinux 8.4 distributions ISO images to the media that you are going to use
in the installation.

You need the following to create installation media:
• PC running Windows 10/11, or AlmaLinux
• USB port and USB Flash Drive 64 GB

Vaisala recommends a USB 3.0 drive because data transfer is much faster than USB 2.0.

A.2 Creating Installation Media
After creating and initializing the installation media, you can run the installation process.

A.2.1 Creating USB Installation Media on Windows
These instructions apply to Windows 10 and Windows 11.

When creating USB installation media on Windows, use a standalone program such as
rufus (available at http://rufus.akeo.ie/). Follow the on-screen instructions.

1. Launch rufus by double-clicking the program icon.

2. Insert a USB drive in the USB port.
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3. Select the drop-down list to the right of the Create a bootable disk using, and select
ISO Image.

4. Select the Disc icon and then select the iso image.

5. Select Write in DD Image mode if a warning for the hybrid ISO image is displayed.

6. Select Close.

A.2.2 Creating USB installation media on Linux (AlmaLinux)

This operation destroys data on the device you operate on.CAUTION!
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1. Run $ lsblk to list block devices on your system. Take note of the output.

2. Insert a USB drive in the USB port.

3. Run $ lsblk.

Compare the output to the previous step. The additional block device from this output
is your USB drive.

4. Run $ dd if=path/toAlmalinux.iso of=/dev/xxx
Where /dev/xxx is the path to the USB drive. Do not use the partition number for the
USB drive.
For example: /dev/sdc.

A.3 Installing AlmaLinux automatically
The automated installation uses KICKSTART to run an unattended installation.

The instructions in this section are for the Vaisala-provided server. If you are using a different
system, consult your systems manual for instructions.

1. Power up the system by pressing the power button on the server.

2. Insert the USB drive into the USB port. If you are using the USB port for the first time,
this also enables the port.

3. In the AlmaLinux 8.7 window, select Test this media & install AlmaLinux 8.7, and press
ENTER.
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4. The installation starts. When prompted, configure the hostname and IP address.

• For one port, configure the internal network: Select Configure as static (default is 
DHCP)?: Y, and enter the IP address 10.0.2.1.

• Configure a second port as DHCP by selecting Configure as static (default is 
DHCP)?: N.

Then the installation will continue.

a. In the Installation Summary window, select Installation Destination.

b. Create new partitions: /, /boot, swap, /srv, and boot/efi.

See chapters Partitioning the destination disk (page 67) and Recommended
partitioning settings (page 67).

c. In the Installation Summary window, select Begin Installation.

5. When the installation is complete, the system will reboot automatically.

6. Login as root.

The default password is xxxxxxxx.

7. The default root password is insecure. To change the password, see Setting the root
password (page 77).

8. Select Application > System Tools > Settings GUI.

9. In Region & Language, configure your language settings.

IRIS and RDA Software Installation Guide M211315EN-L

56 RESTRICTED



10. Depending on your configuration, you may need to configure the ports.

• If you are using Dell PowerEdge R440 server, use ports em1 and em2.
• If you have an American Megatrend server, your enp9s0 port is automatically

set to communicate with the IFDR10 on a 10.0.1.x network.

Do not reconfigure the network port to IFDR10.CAUTION!

• If you have a SuperMicro server, your network settings for IFDR10 are not pre-
initialized. The IFDR10 10.0.1.x network is usually configured on the enp9s0,
enp1s0f1, or eth1 ports but is not limited to these ports.
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This example uses the enp1s0f1 port.

a. Select System Tools > Settings > Network.

b. In the Network window, select the gear icon in the lower right corner.

c. Select the Identity tab.

In MTU, type 8192.

d. Select the Details tab.

Select Connect automatically and Make available to other users.

IRIS and RDA Software Installation Guide M211315EN-L

58 RESTRICTED



e. In the right pane, select IPv4.
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Change Addressing to Manual.
In the Address, Netmask, and Gateway fields, type enter the test shown in the
figure.
Select Apply.

More information

‣ Recommended partitioning settings (page 67)

A.4 Installing AlmaLinux manually
(interactive)

A.4.1 Booting the system for manual installation
You must configure the system to boot from the media device that you have created.

The instructions in this section are for the Vaisala-provided server. If you are using a different
system, consult your systems manual for instructions.
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1. Power up the system by pressing the power button on the server.

2. Insert the USB drive into the USB port. If you are using the USB port for the first time,
this also enables the port.

3. In the AlmaLinux 8.7 window, select Test this media & install AlmaLinux 8.7, and press
ENTER.

4. Select a language.

(This instruction assumes that English (United States) is selected.)

5. Select Continue.

6. Select the keyboard icon to select the keyboard type (default is English).

7. Select Language Support to select the language.

8. Select Time & Date to set up the time and date.

• Region: Etc
• City: Coordinated Universal Time

9. Select USER CREATION.

The User creation window opens.

a. In the user name text box, enter user account name or if you wish to have the user
account name generated from the full name, enter the user's full name in the Full 
name text box.

b. In the password text box, enter the user account's password.

c. In the confirm text box, re-enter the user account's password.

d. Select Done.

If your password is weak, you are prompted to select Done a second time.
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10. Select Root Password to set up the root password.

For details, see Setting the root password (page 77).

11. For Installation Source, select the default value (Local media).

12. Select Software Selection (Server with GUI), and for additional software, select
Development Tools.

13. Click on Installation Destination

14. Select local Standard Disks, and check the Custom button.

15. Select Done.

16. Select LVM for the partition scheme from the drop-down menu.

Select the + icon to add a partition. For more information about the partitioning, see
Partitioning the destination disk (page 67).

A.4.2 Configuring the system and network

1. In the Installation summary window, select Network & Host Name.

2. Enter the host name in the Host name text box in the lower left corner.

a. Select the network device you wish to configure listed in the panel on the left hand
side. The selected device is highlighted.

b. In some interfaces, to enable the network interface, select the blank button next to
OFF in the upper right-hand corner.

If the button exists, slide the button to the ON position.

c. Select Configure at the bottom right-hand corner to display the Editing window.
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3. Select the General tab to set the connectivity options.

a. Select Automatically connect to this network when it is available.

b. Select All users may connect to this network.
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4. Select the IPv4 Settings tab.

a. In the Method drop-down menu, select Manual.

b. Select Add.

c. Enter the IP address, netmask, and gateway in the text entry boxes under the
headers.

d. If configuring your eth0 interface, type your DNS server address in the DNS server
field.

If configuring your eth1 interface, leave this blank.

e. If configuring your eth0 interface, type your domain name in the Search domains
field.

If configuring your eth1 interface, leave this blank.

f. Check the Require IPv4 addressing for this connection box near the bottom of the
page.

5. Optional: If you are configuring the computer to run RDA software and connect to
IFDR10, you need to configure Ethernet ports. See Configuring the system and network
for RDA and IFDR10 (page 64).

6. Select Save in the lower right corner to finish network configuration.

7. Select Done in the upper left corner of the Network and Host Name tab to return to the
Installation summary window.

A.4.2.1 Configuring the system and network for RDA and IFDR10

If you plan to run RDA software on this computer and connect to IFDR10, two Ethernet ports
are required.
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1. In the installation summary page, select Network and Host Name.

The required Ethernet ports should appear in the panel on the left hand side of the
Network and Host Name window.

2. Select the Ethernet tab. In the MTU field, type 8192.
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3. Select the IPv4 Settings tab.

a. In the Method drop-down menu, select Manual.

b. Select Add.

c. Enter the IP address, netmask, and gateway in the text entry boxes under the
headers.

• If you are configuring the Ethernet port connected to the Internet or your
corporate network: The settings in this window are specific to your network
configuration. If you are unsure what to enter in these fields, contact your IT
support.

• If you are configuring the Ethernet interface for direct connection to the IFDR10,
use the following settings:

Setting Value

Address 10.0.3.1

Netmask 24

Gateway 0.0.0.0

d. Type your DNS server address in the DNS server field.

e. Type your domain name in the Search domains field.

f. Check the Require IPv4 addressing for this connection box near the bottom of the
page.

4. Select Save in the lower right corner to finish network configuration.
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5. Select Done in the upper left corner of the Network and Host Name window to return
to the installation summary page.

A.4.3 Partitioning the destination disk

A.4.3.1 Recommended partitioning settings

Vaisala recommends the following disk partitioning.

You need the /boot/efi partition if you computer uses the UEFI boot.

Table 4 Recommended disk partitioning

Partition File system type Size

/home  50 GB

/boot EXT4 500 MB

/boot/efi EXT4 600 MB

/var  50 GB

/ EXT4 50 GB

swap SWAP size of RAM + 2 GB

/srv EXT4 All of of the remaining disk space

Use the xfs file system for partitioning.

Partition /srv is a data partition.

If there is only a little disk space, you can decrease the size of the /home, /var, and /
partitions by 10-20 GB.
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A.4.3.2 Partitioning the destination disk automatically

1. In INSTALLATION DESTINATION, start manual partitioning:

a. Select the hard disk.

b. Select Select Storage Configuration, Custom.

c. Select Done.
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2. Select Click here to create them automatically.

After creating the automatic partitions, you need to modify the partition manually in
the next steps.

3. Modify the /home partition.

a. Select the /home partition.

b. Under Desired Capacity, set the size of the home partition (/home) to 50 GiB.

c. Set the File System to ext4.

d. Select Update Settings.
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4. Create the /var partition:

a. Select the plus (+) icon.

The ADD A NEW MOUNT POINT dialog appears.

b. In Mount Point, type /var
c. Under Desired Capacity, set the size of the /var partition by typing 50 GiB.

d. Select Add mount point.

5. Select /boot.

a. Under Desired Capacity, set the size of the /boot partition by typing 500 MiB.

b. Select Update Settings.

6. Select /.

a. Under Desired Capacity, set the size of the root partition (/) by typing 50 GiB.

b. Select Update Settings.

7. Select swap.

a. Under Desired Capacity, set the size of the swap to the size that corresponds to
RAM + 2 GB.

b. Select Update Settings.
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8. Create the /srv partition:

a. Select the plus (+) icon.

The ADD A NEW MOUNT POINT dialog appears.

b. In Mount Point, type /srv
c. Under Desired Capacity, use nearly all the available server space (indicated in the

pink box) for the /srv partition by typing, for example, 284 GiB.

Figure 3 Example of available disk space

d. Select Add mount point.

9. Select Done.

10. In the window listing the partitions, check that the partitions are defined as described
in Recommended partitioning settings (page 67).

11. Select Done > Accept Changes.

A.4.3.3 Partitioning the destination disk manually

1. On the installation summary page, select Destination Installation.

2. To select the destination disk for the AlmaLinux installation, select the Disk icon.

Once selected, a check mark appears on the icon.

3. Select Storage configuration > Custom.

For recommended settings, see Recommended partitioning settings (page 67).

4. Follow the instructions to create new partitions, or, if needed, to re-use or delete
existing partitions.
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A.4.3.3.1 Deleting existing partitions

If you do not want to use the existing partitions, you must delete them to provide disk space
for your installation.

1. Select the arrow to the left of the drive name you want to modify to expand the
partitioning scheme.

2. Select a partition to delete.

3. Select a minus sign (-) icon to delete the partition.

4. On the pop-up window, check Delete all other filesystems…. and select Delete it.

A.4.3.3.2 Creating new partitions

Vaisala recommends the LVM partition scheme.

1. If the /home partition exists, delete it by selecting the minus (-) icon.

2. Select the plus (+) icon to add partitions.

Do this 4 times, once for each partition.
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3. For each new directory, do the following:

a. From the Mount Point menu, select the directory.

b. Go to ADD A NEW MOUNT POINT > Desired Capacity, and type the value
recommended in Recommended partitioning settings (page 67).

c. Select Add mount point.

4. Create the /srv partition:

a. In the Mount Point field, type /srv.

Type a number larger than the remaining data size. For example: 99999999999.

b. Select Add mount point.

5. One at a time, select each partition, and modify the value in the Desired Capacity field
with recommended values.

For File System Type, you can select either EXT4 or xfs.

6. Select Done > Accept changes to finish partitioning.

When you have completed partitioning, do one of the following:
• If you are doing a manual installation, go to Starting the installation (page 74).
• If you are doing an automatic installation, go back to Installing AlmaLinux automatically

(page 55).

A.4.3.3.3 Re-using existing partitions

If your disk has an operating system installed, the partitioning scheme list is displayed.

1. To expand the partitioning scheme, select the arrow to the left of the drive name you
want to re-use.

2. In the partition window, for each partition shown in the left pane, select the partition,
and enter the name shown in the Mount Point field.

For the swap partition, you do not need to enter the mount point name, but you still
need to perform steps 3 and 4.

3. Check the Reformat check box next to the File System drop-down list.

4. Select Update Settings.
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5. When you have updated the settings for all the partitions, select Done.

6. Select Accept Changes to return to the installation summary page.

A.4.4 Starting the installation
Before starting the installation, make sure you have your root password and user account
information.

1. In the lower right corner of the installation summary page, select Begin installation.

The user settings configuration page appears.

2. While the installation process is in progress and before the end of the installation,
configure the root password.

3. When installation status shows complete, select Reboot and remove the installation
media.

The installation takes 20 ... 30 minutes.

4. If the server does not reboot automatically, use the power button to power cycle the
system.

5. If on the first boot you see the prompt window Accept the License Information, in the
initial setup window:

a. Select License Information.

b. Check the I accept the license agreement box.

c. Select Done.

d. Select Finish configuration.

Login screen is displayed.

6. Disable monitor negotiation.

7. The first time you login to each new account, follow the series of windows to verify your
keyboard and localization settings.

a. Select Next until you get to the thank you screen.

b. Select Start using.

8. Log out of the user account to continue with the installation.

More information

‣ Setting the root password (page 77)
‣ Disabling monitor negotiation (page 74)

A.4.5 Disabling monitor negotiation
During manual operating system installations, Vaisala recommends disabling monitor
negotiation to ensure that the server recognizes the monitors.
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1. Login as root.

The default password is xxxxxxxx.

2. In the /etc/default/grub file, after the quiet in GRUB_CMDLINE_LINUX add:

nomodeset

3. Save your changes.

4. To update the configuration file, run the following script:

cd /boot/grub2/
grub2-mkconfig -o grub.cfg

A.4.6 Configuring time sync with chronyd
You can configure your machine to time sync with another machine using chronyd.

1. In the /etc/crony.conf file, update the lines that start with the word server by
removing the default server lines and adding your own. For example:

 # configure the servers for synchronization using ip address or name
     server 198.102.75.10 iburst
     server 0.centos.pool.ntp.org iburst 

2. If chronyd is already running and you would like changes to take effect, use the
following command:

#systemctl restart chronyd.service
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3. If you would like NTP to start automatically on restart, type:

#systemctl enable chronyd.service 

This takes effect after the next reboot. To start without rebooting, type:

#systemctl start chronyd.service

The system takes 15 minutes to sync the time. If the times are more than 10 minutes
apart, NTP assumes there is an error and does not change the time.

4. To check on the status of chronyd, type:

# chronyd sources -v

The first character before the server host is * when it is time synced.

A.4.7 Rebooting the system

1. When the installation is complete, select Reboot to reboot the system.

2. Depending on your system bios boot sequence setting, you may need to remove the
installation media right after you see the system shutdown complete window flash by in
order to boot using the hard drive.

A.4.8 Logging in with your user account
After rebooting, the login window shows the user account you created.

1. Select your user account, and enter your password in the text box.

2. Select Sign in.

The first time you log in to each new user account, you are asked to set some
initialization settings. The default settings are normally properly set during the
installation process, and no setting changes should be required.

3. In the Welcome window, select your language, and select Next.

4. In the Input Sources window, verify your source, and select Next.

5. In the On-line Accounts window, select Next.

6. In the Thank you window, select Start using AlmaLinux.

7. Read the GNOME Help window and press X in the upper right corner to close the
window.

The installation and initialization process for AlmaLinux is complete.
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A.5 Setting the root password
If your system was pre-installed in Vaisala, the default password is xxxxxxxx.

1. Select ROOT PASSWORD.

The Root Password window opens.

2. Enter your root password.

Check the password strength meter. While Vaisala recommends a strong password, the
software does not stop you from entering a weak one.

3. In the confirm text box, re-enter your root password.

4. In the upper left hand corner, select Done to return to the main configuration page.

If your password is weak, you are prompted to select Done a second time.
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Appendix B. IRIS Diagnostic
Utilities

B.1 ps_iris command
Use the ps_iris command to list currently active IRIS, antenna, and utility processes,
including information about their owner UID, PID, time start time, and total CPU time.

To stop a process, use the PID as an argument to the kill command.

For example:

Detached Processes:
   USER     GROUP PID  PPID  NI PRI %CPU TIME %MEM    VSZ COMMAND
   operator users 3353   1   0  19  0.0  0:02  0.0 168216 server IRIS_SERVER
   operator users 3355   1   4  15  0.0  0:00  0.0 142236 sserver IRIS_SSERVER
   operator users 3399   1  -8  27  0.0  0:49  0.0 136788 ingfio IRIS_INGFIO
   operator users 3407   1   4  15  0.0  0:00  0.0 136768 network IRIS_NETWORK
   operator users 3411   1   8  11  0.4  7:17  0.0 143124 product IRIS_PRODUCT
   operator users 3413   1   8  11  0.0  0:00  0.0 157800 reingest 
IRIS_REINGEST
   operator users 3415   1   4  15  0.0  0:00  0.1 180620 output IRIS_OUTPUT001
   operator users 3418   1   4  15  0.0  0:01  0.0 156556 output IRIS_OUTPUT002
   operator users 3420   1   0  19  0.0  0:02  0.0 136776 input IRIS_INPUT01
   operator users 3423   1   0  19  0.0  0:09  0.0 138996 watchdog 
IRIS_WATCHDOG
   operator users 23970  1  -8  27  0.0  0:08  0.0 142164 ingest IRIS_INGEST

Antenna Processes:
   USER     GROUP  PID  PPID  NI PRI %CPU   TIME %MEM    VSZ COMMAND
   operator users  1756   1    0   19  0.0  0:04  0.0 115676 ant_logd ANT_LOGD
   operator users  1789   1   -15  34  0.0  0:51  0.0 115684 ant_rcvd ANT_RCVD
   operator users  1793  1789 -15  34  0.0  1:10  0.0 115684 ant_rcvd ANT_RCVD
   operator users  1823   1   -15  34  0.0  1:08  0.0 115680 ant_xmtd ANT_XMTD

IRIS and RDA Software Installation Guide M211315EN-L

78 RESTRICTED



Stand-alone Utilities:
   USER     GROUP      PID  PPID  NI PRI %CPU   TIME %MEM    VSZ COMMAND
   radarop  radarop  23933 23923   0  19  0.0   0:00  0.0 116244 audio 
iris_audio 
   operator users     4321  4319   4  15  0.0   0:00  0.0  12636 clntRecv 
CLNT_RECV_WINDOW -pipe 8 
   radarop  radarop  23923  4163   0  19  0.0   0:04  0.0 189464 iris 
   radarop  radarop  23934 23923   0  19  0.0   0:00  0.0 116236 iris_clnt_rcv 
7 1073741826 
   operator users     3330     1   0  19  4.6  67:30  0.0 699324 /rcp8 -
console /dev/null 
   operator users     2021     1   0  19  9.4 138:57  0.4 796880 /rvp10 -
daemon 
   operator users     2297  2021   -  50 12.0 176:43  0.3 275560 rvp10proc 
RVP10_PROC-0 
   operator users     2347  2021   -  50 11.8 172:44  0.3 275556 rvp10proc 
RVP10_PROC-1

B.2 show_iris command
Use the show_iris command to show information about the IRIS process: When it started,
the present state of semaphores and event flags, and the current inventory of in-use
products.

The show_iris command also provides command line options for in–use bits. For more
information, type show_iris –help.

$ show_iris
IRIS Activity on 'hot' at: 09:52:52 17 SEP 1999
IRIS V7.11 was started at 16:19:38 16 SEP 1999 by 'joe'.
Manual startup from TTY:'/dev/tty' ; Restarts:1
Features License: 00004001-000101-WAHRMA-01-Y9ANHF
Products License: 000007FF-000101-WAHRMA-03-WFW4KR
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Present states of Semaphores...

PROCESS CONTROL: FREE (ID: 5833)    PROCESS MODES: FREE (ID: 5826)
TASK SCHEDULE: FREE (ID: 5834)    PRODUCT SCHEDULE: FREE (ID: 5831)
INGEST DIRECTORY: FREE (ID: 5831)    PRODUCT DIRECTORY: FREE (ID: 5849)
DEVICE TABLE: FREE (ID: 5852)    MODE SWITCH TABLE: FREE (ID: 5834)
ARCHIVE DIRECTORY: FREE (ID: 5834)    ERROR LOG: FREE (ID: 5834)

Present states of Event Flags...
RTDISP: CLEAR    INGEST: CLEAR
INGFIO: CLEAR    INGFIO MAPPING: SET
INGFIO WAITING: SET    WATCHDOG: CLEAR
PRODUCT: CLEAR    REINGEST: CLEAR
NETWORK: CLEAR    NORDRAD: CLEAR
GLOBAL MAPPED: SET

Event Flags SET for Output Processes: 7 8
Event Flags SET for Network Child Processes: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 
15 16
Checking INGEST inventory for in-use files:
Total files checked: 92, total in use: 0.
Checking PRODUCT inventory for in-use files:
Total files checked: 260, total in use: 0.
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======= Product Inventory Contents =======
Prod Type        Count        Size(Mb)        Kept Count        Kept Size
PPI              0             0.00              0             0.00
RHI              0             0.00              0             0.00
CAPPI          159            92.06             21            60.92
Cross Section    0             0.00              0             0.00
Echo Tops        0             0.00              0             0.00
Tracking         0             0.00              0             0.00
Hourly Rainfall  0             0.00              0             0.00
N Hours Rainfall 0             0.00              0             0.00
Vol. Vel. Proc.  0             0.00              0             0.00
Vert.Int. Liquid 0             0.00              0             0.00
Wind Shear       0             0.00              0             0.00
Warning          1             0.01              0             0.01
Real Time PPI    0             0.00              0             0.00
Real Time RHI    0             0.00              0             0.00
Raw Data        73            52.35             73           52.35
Max with panels  0             0.00              0             0.00
User Map         0             0.00              0             0.00
User Section     0             0.00              0             0.00
User Other       0             0.00              0             0.00
Status          25             0.06              0             0.00
Shear Line       0             0.00              0             0.00
Horizontal Wind  0             0.00              0             0.00
Beam Pattern     0             0.00              0             0.00
Text             0             0.00              0             0.00
Forecast         0             0.00              0             0.00
Multi-Doppler    2            15.36              2            15.36
Image            0             0.00              0             0.00
Composite        0             0.00              0             0.00
LLWAS            0             0.00              0             0.00
               260           159.84 Mb          97           128.65 Mb

B.3 sigmet_env Command
Use sigmet_env to test or troubleshoot items associated with an IRIS installation.

To sue the command, log in as a normal IRIS user, run sigmet_env. The sigmet_env
command checks the following:

• That all the IRIS operators and observers are in the /etc/users file.
• That all IRIS environment variables that point to directories are defined and the

directory exists, and the directory can be read and written as required.
• For obvious bad file names in the saved menu directory.
• That IRIS executable files which require the set–UID–on–execute bit set are set

with the correct UID.
• The RDA (RVP/RCP) environment.

The following example shows a case with a bad file name of .TSC.
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$ sigmet_env
Checking IRIS_OPERATORS list...
Checking IRIS_OBSERVERS list...
Checking installation directories...
Checking configuration directories...
Checking data directories...
Checking file names in IRIS_MENU...
Bad menu filename: '/etc/vaisala/irisrda/menu/.TSC'
Checking root file ownerships...

Errors Detected -- Please Check Printout

B.4 structmap command
Use the structmap command to display the format of IRIS structures. This is useful when
writing applications that access IRIS data.

To make structmap available on your system, install IRIS with the –headers option .

structmap options

To show a list of structmap options, enter the command without options or parameters:

$ structmap
Command Line Options:
<struct name> :   Display internal contents of IRIS structure(s)
–include <dir> :  Override default 'include' directory name
–nopack :         Force no packing of structure elements
–scan :           Produce list of all defined structures
–scanlocal :      Like 'scan', but do local directory only
–noflags :        Suppress error flags in output
–recursive :      Descend into substructures
–data :           Show numeric data read from std.input
–dimension N :    Use with '-data' for N-dimensional printout

For example structmap 'structmap –scan' displays everything.

structmap <structure name> option

Invoke structmap with the name of a structure to display the name of the include file
where the structure is defined and a description of each element in the structure.

It offsets from the beginning of the structure, its size, the number of times it occurs, its data
type, and name.

For example, to display information about the tape_header_record structure:
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$ structmap tape_header_record

tape_header_record /usr/include/irisrda/output.h
0       12        1    struct structure_header hdr
12      16       16    char stape_id[]
28      16       16    char sitename[]
44      12        1    struct ymds_time init_time
56       2        1    SINT2 idrive
58       2        2    char ipad58x2[]
60       8        8    char sversion[]
68     252      252    char ipad_end[]
320    

The example shows that the structure is defined in /include/irisrda/output.h and
contains:

• hdr, a structure of type structure_header, taking up the first 12 bytes.
• stape_id and sitename, arrays of 16 characters each, at offsets 12 and 28.
• init_time is a ymds_time, structures taking up 12 bytes starting at offset 44.
• idrive, a long integer at offset 56.
• ipad58x2, sversion, and ipad_end, arrays of 2, 8, and 252 characters, at offsets

58, 60, and 68, respectively.

The total size of the structure is 320 bytes.

–scan Option

The –scan option lists the names of the structure defined by IRIS.

You can use the –scan option to recursively call structmap and display the format of all
the structures in the system.

$ structmap -scan
ant_manual_setup
bitex_field_def
bitex_top_def
cappi_psi_struct
.
.
.

To redirect the output to a file, type:

$ structmap 'structmap –scan' > allstructs.out
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Appendix C. Alternative
Configurations

C.1 Installing IRIS 3DView
It is not necessary for IRIS software to be installed on the system to use 3DView.

If you chose to have the IRIS software on the same system, it is recommended that you
install the IRIS software before installing the IRIS 3D View.

IRIS 3DView software is a separately licensed software package that renders 3D
visualizations of IRIS format radar data.

You can install the IRIS 3DView either on an IRIS Analysis machine, or a machine without
IRIS.

1. Obtain the following RPMs:

• libogg-devel-1.1.4-2.1.el6.i686.rpm
• libtheora-devel-1.1.0-2.el6.i686.rpm
• qtwebkit-2.1.1-1.el6.i686.rpm
• qt-mobility-1.1.3-2.el6.i686.rpm
• gl2ps-1.3.5-1.el6.i686.rpm
• gl2ps-devel-1.3.5-1.el6.i686.rpm
• compat-expat1-1.95.8-8.el6.i686.rpm
• expat-2.0.1-9.1.el6.i686.rpm
• expat-devel-2.0.1-9.1.el6.i686.rpm
• xorg-x11-apps-7.4-10.el6.i686.rpm
• xorg-x11-server-common.1.7.7-29.el6.i686.rpm
• xorg-x11-server-Xvfb-1.7.7-29.el6.i686.rpm
• vtk-5.8.0-6.el6.i686.rpm
• vtk-devel-5.8.0-6.el6.i686.rpm
• vtk-java-5.8.0-6.el6.i686.rpm
• vtk-python-5.8.0-6.el6.i686.rpm
• vtk-qt-5.8.0-6.el6.i686.rpm
• vtk-tcl-5.8.0-6.el6.i686.rpm
• acroread-9.4.0-1.el6.i686.rpm
• acroread-plugin-9.4.0-1.el6.i686.rpm
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2. Install the RPMs in the following order:

a. #rpm -Uvh libogg-devel-1.1.4-2.1.el6.i686.rpm
b. #rpm -Uvh libtheora-devel-1.1.0-2.el6.i686.rpm
c. #rpm -Uvh qtwebkit-2.1.1-1.el6.i686.rpm
d. #rpm -Uvh qt-mobility-1.1.3-2.el6.i686.rpm
e. #rpm -Uvh gl2ps-1.3*
f. #rpm -Uvh compat-expat1-1.95.8-8.el6.i686.rpm

g. #rpm -Uvh expat-2*
h. #rpm -Uvh xorg-x11*
i. #rpm -Uvh vtk*
j. #rpm -Uvh acroread-9*

3. Log in as root.

4. The IRIS 3D View application is in the rpm package called iris3dview-
1.0.2-1.i686.rpm. Install it using the rpm installation tool

# rpm -Uvh iris3dview-1.0.2-1.i686.rpm

It is recommended that you do not run the IRIS 3D View application while logged in
as a root user.
If you have IRIS software installed on your system, log in as radarop user.
If IRIS software is not installed, create a user on your system.

5. In the GNOME window, create a user by selecting System > Administration > Users 
and Groups and follow the online instructions.

6. Log in as normal user and check .config/Vaisala directory for the following files:

• IRIS3D.conf
• IRIS3DColors.conf
• IRIS3DLandmarks.conf
• IRIS3DVisStyles.conf
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7. Do one of the following:

a. If you have the IRIS software installed, create the following directories:

/usr/iris_data/data/geo     # for geo data
/usr/iris_data/data/2d      # for 2d data
/usr/iris_data/data/3d      # for 3d data
/usr/iris_data/data/background_output 
# for background images processing results

The permissions and ownership for these directories are:

drwxrwsr-x
2 operator users 4096 Dec 11 13:14 2d drwxrwsr-x
2 operator users 4096 Dec 11 13:15 3d drwxrwsrwx
2 operator users 4096 Dec 11 13:15 background_output drwxrwsr-x
2 operator users 4096 Dec 11 13:14 geo

b. If you do not have the IRIS software installed, you can put your data directory
anywhere you want, but you must set the directory permissions to read/write
access.

8. Run IRIS 3DView visualization:

/usr/bin/iris3dview &

When you first start IRIS 3DView, it runs a license wizard. Follow the online instructions.
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9. If your system has an IRIS or RDA system already installed, the IRIS 3D View License
dialog box displays the Sitename for your system.

In that case, leave it unchanged.
If not, enter a unique Sitename (16 characters or less) and select Next.

The IRIS 3D View License dialog displays the site code and check code.

10. Send the information shown in previous figure to Vaisala and request a license string.

11. Enter the license string in the License field and click Finish.
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12. Once the IRIS 3D View window opens, click the setup icon in the upper right hand
corner to open the Settings Window dialog box.

Configure the data directory to point to the directories created earlier, according to
your data type.
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13. Configure background processing.

Background processing is run by the iris3d user; however, the user who runs the
iris3d visualization must copy the configuration files to the .config directory of
the iris3d user:

a. Set permissions for everybody to be able to read and write by running:

#chmod -R 777 /home/iris3d/ as root user

b. From the visualization window, select File > Export tool.

c. From the export window, select the Background output tab and follow the online
instructions to finish the setup.
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After installing the IRIS 3D View, the background processing daemon starts
automatically.

14. Check the daemon by running the ps -ef command:

ps -ef | grep iris

and you should get the printout similar to:

iris3d   3432    1  0 13:24 ?      00:00:00 dbus -launch -- autolaunch 
841d3b9bca80c846219d29fc00000022 --binary-syntax --close- stderr
iris3d   3433    1  0 13:24 ?      00:00:00 /bin/ dbus - daemon --fork --
print- pid 5 --print-address 7 --session
iris3d   3435    1  0 13:24 ?      00:00:00 /usr/bin/ iris3dviewd -- 
loglevel =2 --daemon

If you need to restart the daemon, change to the root user by typing:

su root

You are prompted for the password.
Stop and start the daemon by typing the following:

#/sbin/service iris3dviewd stop
#/sbin/service iris3dviewd start

15. Test background processing:

a. Copy 3D data to the 3D directory that you configured.

b. Wait for a second and check the output file in output directory that you configured.

16. If needed, modify the logging level.

a. To check the logging, go to /home/iris3d/ and open the iris3dviewd.log
file.

b. To view real-time logging messages while you are running background processing,
run tail -f iris3dviewd.log.

c. To set logging level to more details, like level 6, editing the /etc/sysconfig/
iris3dviewd and change loglevel=2 to OPTIONS="-- loglevel=6 --
daemon".

d. Restart the processing daemon.

IRIS and RDA Software Installation Guide M211315EN-L

90 RESTRICTED



C.2 Defining the Operator List in the
Startup File

Most environments can function with radarop and observer users without any further
definitions. If you wish to manage named users, follow the instructions below.

The /etc/sigmet/profile.conf file defines some of the base configuration, including
the lists of users who can operate IRIS fully, and who can observe its operation but not make
any changes.

Every IRIS user must share group access to files owned by the operator by being a
member of the users group.

1. Edit the file and change these as needed.

operators='radarop operator john george mary root' 
observers='observer'

2. Check your environment by typing:

$ env | grep IRIS
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Warranty
For standard warranty terms and conditions, see www.vaisala.com/warranty.

Please observe that any such warranty may not be valid in case of damage due to normal wear and tear,
exceptional operating conditions, negligent handling or installation, or unauthorized modifications. Please
see the applicable supply contract or Conditions of Sale for details of the warranty for each product.

Technical support

Contact Vaisala technical support at helpdesk@vaisala.com. Provide at least the following
supporting information as applicable:

• Product name, model, and serial number
• Software/Firmware version
• Name and location of the installation site
• Name and contact information of a technical person who can provide further

information on the problem

For more information, see www.vaisala.com/support.

Recycling

Recycle all applicable material according to local regulations.
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