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1. About This Document

1.1 Version information
This manual provides information about using IRIS Radar software.

Table 1 Document versions (English)

Document code  Description

M211317EN-K April 2023 Tenth version.
Release 10.0.0

M211317EN-J June 2022 Ninth version.
Release 9.2.0.

M211317EN-H April 2021 Eighth version.
Release 9.1.0.

1.2 Related documents
Table 2 Vaisala Weather Radar documentation

Document code Name

M211315EN IRIS and RDA Software Installation Guide

M211316EN IRIS and RDA Utilities Guide

M211317EN IRIS Radar User Guide

M211318EN IRIS Programming Guide

M211319EN IRIS Product and Display Guide

DOC236879 IRIS RDA Release Notes

M212604EN RVP10 Digital Receiver and Signal Processor User Guide

M211320EN Radar Control Processor RCP8 User Guide

M211849EN IRIS Focus User Guide

M211850EN IRIS Focus Administrator Guide

M211904EN IRIS Focus Release Notes

Vaisala encourages you to send your comments or corrections to helpdesk@vaisala.com.
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1.3 Documentation conventions

Warning alerts you to a serious hazard. If you do not read and follow
instructions carefully at this point, there is a risk of injury or even death.
WARNING!

Caution warns you of a potential hazard. If you do not read and follow
instructions carefully at this point, the product could be damaged or important data
could be lost.

CAUTION!

Note highlights important information on using the product.

Tip gives information for using the product more efficiently.

Lists tools needed to perform the task.

Indicates that you need to take some notes during the task.

1.4 Trademarks
Vaisalaâ is a registered trademark and HydroClass™, IRIS™ and Total Lightning Processor™

are trademarks of Vaisala Oyj.

Chrome™ is a trademark of Google Inc.

Firefoxâ is a registered trademark of Mozilla Foundation.

Edgeâ is a trademark of Microsoft Corporation in the United States and other countries.

All other product or company names that may be mentioned in this publication are trade
names, trademarks, or registered trademarks of their respective owners.
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2. IRIS Introduction

2.1 IRIS Radar Overview
IRIS Radar provides tools for operating a radar network and distributing radar products.

• Advanced radar signal processing and control features
• Central definition with automatic warnings
• Comprehensive alignment and calibration
• Comprehensive diagnostic and system monitoring
• Local and remote radar control
• Real‑time display for local or networked workstations

2.2 IRIS Users
Table 3 Supported IRIS User Types

User Type Description

Radar operators Define and schedule radar tasks and determine how the radar data is output.

Observers View radar tasks, configurations, and schedules.

Send data through outputs.

View radar products and RAW data.

System managers Install and maintain IRIS software and platforms and manage users. Knowledge of
platform hardware is recommended.

Operator A system user that the software uses to access some configuration files.

2.3 IRIS Tasks
A radar task is a set of operating parameter configurations for the radar antenna,
transmitter, receiver, and signal processing systems. The data acquired during the task are
stored on disk as ingest files, which serve as the data base for radar product generation.

Examples of tasks include:
• Surveillance PPI scan at a single elevation angle.
• Complete volume scan at multiple elevation angles.
• PPI sector scan at either single or multiple elevation angles.
• RHI scan at either single or multiple azimuth angles.

Use the TASK Configuration menu to specify the antenna scanning, as well as other radar
parameters, such as pulse width, PRF, number of samples to average, and the type of data
to process such as Z, V, W, ZDR, RhoHV, or PhiDP).

Use the TASK Scheduler menu to execute tasks. The TASK Scheduler supports hybrid tasks,
made up of multiple sub-tasks.

Chapter 2 – IRIS Introduction
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More information

‣ Configuring Tasks (page 42)
‣ IRIS Data Parameters (page 125)
‣ Task Scheduling Overview (page 65)
‣ Task configurations (page 116)

2.4 License Types
IRIS requires at least one of the following licenses:

• IRIS Radar runs at the radar site, controls measurement, and packs the measured values
to files.

• IRIS Analysis typically runs on a separate computer. IRIS Analysis reads the files created
by IRIS Radar and processes the polar volume measurement to different products, and
sends these to displays or archives.

2.5 IRIS System Set-ups

Set-up Description

IRIS Radar Runs the radar and signal processing hardware, generates ingest files and raw data for other
IRIS sites.

Supports the full product set as well as remote control and monitoring.

IRIS Analysis Receives raw data products from the radar site over the network or from an archive device.

Supports the full product set as well as remote control and monitoring.

IRIS Focus Acts as a radar product generator (RPG) to provide on-demand outputs such as CAPPI or
TOPS. Includes features such as looping, cross-section, track, and alerts.

Displays radar products on standard PC (Windows or Linux) running standard browsers.

2.6 IRIS Hardware

2.6.1 Workstation
IRIS runs on computers with a Linux operating system.

The workstation can run the IRIS processes and menus and functions as an output device for
IRIS products.

2.6.2 Radar signal processor
Radar signal processor (RVP) software triggers radar measurement by producing the trigger
signal for the transmitter using the intermediate frequency digital receiver (IFDR) unit in the
receiver.
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After the IFDR unit has digitized the received echo signal into samples (I and Q data), the
RVP processes the data in the radar server computer using computations such as:

• Converting the received signal amplitude into calibrated radar reflectivity values
• Doppler processing to filter out ground clutter and compute radial velocities
• Polarimetric processing to classify the measured hydrometeors and to apply

attenuation correction.

The end product of the RVP process is a radar ray, where selected radar data from a certain
short time interval is stored as a function of range.

Parameters configure signal processing, such as pulse repetition frequency, range resolution,
and Doppler filter parameters. You can select these either directly when running RVP as a
standalone or through the IRIS software when IRIS controls the RVP process during
automatic weather radar measurements.

2.6.3 Radar control processor

Radar control processor software

RCP software steers the radar antenna in the defined measuring direction to read the
azimuth and elevation angles from the angle encoders. The angle values are combined with
the output of the RVP signal processing to display measured radar data as a function of
azimuth, elevation, and time.

RCP software displays status information, such as the status and faults of radar system units
as well as the controls for switching the transmitter radiation on and off.

Chapter 2 – IRIS Introduction
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2.6.4 IRIS Network Connections

Figure 1 IRIS Network Connections

2.6.5 Color Printer and Output File Formats
An optional color printer provides hardcopies of products, prints tape/DVD disk inventories,
and supports other system maintenance and documentation. Color postscript printers are
supported.
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The output files can be formatted as IRIS Native, TIFF with optimal compression, BMP, GIF,
JPG, Postscript, or Compressed serial link format.

2.6.6 Installation media
A DVD or a USB drive is used for IRIS installation.

Archive/retrieve is supported on DAT tape, DVD+RW drivers, and large disk archives (LDAs)
on a local or remote hard disk.

2.7 IRIS architecture
IRIS is made up of processes that convert radar data to output formats for display, printing,
or storing on tape or disk.

Chapter 2 – IRIS Introduction
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Figure 2 IRIS processes

2.7.1 Ingest Process
The signal processor sends base data to the IRIS Ingest Process.

The Ingest Process controls the signal processor and RCP for the data acquisition. A task is a
set of instructions for performing a scan, such as a single RHI scan or a PPI volume scan at
multiple elevation angles. The antenna scanning, signal processor configuration, PRF, pulse
width, and so on, make up the parameters of the task configuration.
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IRIS executes one task at a time, but up to 8 separately defined tasks can be scheduled to
run at different times, and up to 26 tasks can be linked together to form a single hybrid task.

Running the radar comprises defining the task configuration and the task schedule.

IRIS provides menus for performing these operations and allows you to save the results on
disk so that task configurations and schedules can be recalled easily.

IRIS can store many hours of volume scans of raw ingest data, depending on the size of the
disk that is available.

2.7.2 Real Time Display Output Process
The ingest data from the signal processor are split to the real time display output process
which constructs ray-by-ray packets (for example, 1°) that are broadcast over the network
using the UDP socket approach.

Radar scan data can be viewed on:
• Networked workstations running the IRIS real time display
• Local workstation where the data are collected.

The broadcast approach allows the simultaneous use of multiple-networked real time
displays without burdening the network.

2.7.3 Product Generator Process
Ingest files are the starting point for radar products. They are the input to the product
generator, which creates representations of the raw data as product files.

Like tasks, products are configured and scheduled and can be saved to a disk and recalled
later for product generation.

The product generator takes the ingest file for the task, computes the product, then stores
the result in a product file. Results from one product file can be used to compute another
product.

Table 4 Example: CAPPI Product

Product Configuration Defines.... Product Schedule Defines....

• Height of the CAPPI surface
• Display parameters: maximum range, parameter,

pixel resolution, and default color assignment
• Which task provides the ingest file for computing

the CAPPI product

How often IRIS generates the product:

• Each time the associated task runs
• Only the next time the task runs
• Only for selected ingest files

2.7.4 Product Output Process
Product files can be requested by IRIS users or sent automatically to the following output
devices:

• IRIS Focus
• IRIS Quick Look Windows (QLW).

Chapter 2 – IRIS Introduction
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• Disk files on networked workstations, where the products are available for local display
and manipulation.

• DVDs or Large Disk Arrays for data recording (archiving).
• Printers for hardcopy.

IRIS supports many product file formats.

The Product Output process takes the product file, reformats or compresses it as required
by the device, and transmits it over the appropriate interface. Custom reformatting is
available through IRIS output pipes, which are open source software routines that can be
linked to a network output.

IRIS can record to archive servers or DVD and retrieve any product file. This means that
retrieved products are available for display as if they were generated normally. The RAW
product allows ingest files to be restored so that they are available for future product
generation.

2.7.5 Watchdog Process
To make room for new ingest and product files, a watchdog process automatically deletes
files according to their age.

2.7.6 Network Process
IRIS supports working in network environments. For example, the product generation
process can run on a different computer on the network to free the primary IRIS host to
control the radar (Radar process) and handle user interactions (Product Output process).

You can remotely control and monitor IRIS on another workstation using tools for accessing
all aspects of the radar control.

The software architecture supports adding new output devices and products for new
applications.

2.7.7 Server and Client Structure
IRIS runs in a host/client structure. There is always at least one host running on an IRIS
system, and many clients can connect to it.

This architecture is much more efficient in terms of bandwidth than exporting a window.
This allows the menus to be responsive if the network speed is limited.

Server

The IRIS server runs the processes, the radar and signal processor, product generator and
output processes. It collects data and creates ingest files as defined by tasks and schedules.

Client

The IRIS client runs the menus — the user interface for viewing products and managing the
host. The client menus let users define products and tasks, establish schedules, and monitor
the host's activities.
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The client runs locally on the user's computer and connects to an IRIS server on the network
or on the same computer.
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3. Starting and Stopping IRIS

3.1 Logging into Host Server
Systems configured at the Vaisala factory have the following default usernames and
passwords.

The system administrator can change the passwords using the standard Linux password
support.

Most users log in to IRIS Radar as either observer or radarop. Only use the root
account if you must perform administrative tasks.

Table 5 Default usernames and passwords

Username Password

observer xxxxxx

radarop xxxxxx

root xxxxxxxx

1. To log on to the host, enter your user name and password.

After a short pause, the system displays the operating system prompt.

3.2 Starting IRIS Client
IRIS menus can run from the same or a different system than the host, as long as they are
connected to the host over a network connection.

1. Log in to the client system

2. On the command line, type iris&.

The IRIS menu bar appears.

3. Select Connect > <host name>.

Select either the local host or the remote IRIS host.

4. Select Menus and the name of the menu you want to access.

As you work, you can access the menus list from the menu bar or from within each
menu.

IRIS User Guide M211317EN-K
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3.3 Exiting IRIS Client
1. Select Exit > Exit.
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4. Using IRIS Menus

4.1 IRIS menus overview
IRIS menus provide tools for defining how IRIS collects, processes, and displays radar data.

Multiple users can access the menus. The most recently save configuration is stored.

IRIS does not warn you if other users are editing task configurations or if the
radar is being controlled by other users.
CAUTION!

Access rights define who can view or edit a menu. For example, an observer may view the
TSC Monitor menu to see which tasks are currently scheduled, but cannot modify tasks.

Table 6 Access to IRIS menus

Menu Description

Archive Menu Control the IRIS tape, DVD, or LDA operations, including recording and retrieving.

Display archive logs that list the contents of a device.

Ingest Summary List the ingest files on a disk, manually delete files, or set the Keep flag so files are
not deleted by the Watchdog process.

IRIS Menu Bar Select other menus and exit IRIS.

Messages View logged error and status messages.

Overlay Menu Choose which overlay to use when viewing data from a radar site.

Product Configuration Specify product configuration.

Select the task used for product generation and the type of product.

Product Output Show what products are available on disk and select products for transmission to
workstations.

Operators can transmit products and overlays to a workstation, printer, or tape/
DVD.

Product Scheduler Schedule which products to run.

Projection Menu Configure map projections which are required when compositing multiple radars.

Quick Look Window Provide easy access to IRIS data for forecasting applications.

Radar Status Monitor and control hardware components and IRIS configuration.

Real-Time Display View the PPI or RHI radar scan in real time.

TASK Configuration Configure radar and signal processing tasks, such as a volume scan.

TSC Editor Create task schedules to be executed from the TSC Monitor menu

TSC Monitor Schedule task execution. Schedules may be repetitive (for example, every 15
minutes), or a single execution.
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4.2 IRIS Menu Title

Figure 3 IRIS Menu Title

IRIS menu titles contain the name of the server to which IRIS is connected, the name of the
menu, and the name of a configuration file that has been loaded in the menu.

If you have not loaded any configuration files, the DEFAULT configuration file loads.

4.3 Accessing IRIS menus
1. Select Menus and choose a menu from the list.
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2. Within each menu, select File to perform common operations.

Table 7 File Menu

Menu option Description

Open

Load (Menus with live
data such as Overlay)

Show a list of configuration files you can load in the menu.

Save as Save your configuration under the same name or under a new name that you
specify.

Delete Delete the configuration file that is currently loaded in the menu.

Print Select one of the following options:
• Print > to Printer sends the output to the Postscript or color printer

specified in the Printer Setup menu.
• Print > to File sends the output to a file in your default home directory.

The file name consists of a three-letter abbreviation of the menu name,
the current date and time, and the .xwd file extension.

• Print > Setup lets you configure the printer on your system.

Close Return to the IRIS menu bar.

3. Select Update Now to sync the information when many IRIS menus are running at the
same time.

4. Select Reset Size to reset the menu to its default size.

4.4 Entering information in menus
Table 8 Enter menu information

Mode Description

Text fields Enter the text, such as the name of a configuration file or a numeric value, in the field or
select the button next to the field to show a list of valid values.

Lists Select one or more list items:

• Left-click the mouse over a single entry.
• Click and drag the mouse over a group of entries.
• Press CTRL and left-click the mouse to select a single entry without deselecting previous

entries. Do this to select a group of entries that are not next to each other in the list.
• Press CTRL and click and drag the mouse to selects a group of entries without

deselecting previous selections. Do this to select multiple blocks of entries.

Toggle Buttons Left-click the mouse to toggle these buttons on (the button appears to be pushed in) or off.
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4.5 Viewing the Graphical IRIS Menu

Figure 4 Graphical IRIS Menu Bar

1. To toggle the graphical menu on or off, select Tools > Display IRIS Image.
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5. Managing Servers

5.1 Customizing the Server List

Figure 5 Customize Server List

IRIS client menus run locally on your workstation. You can connect these menus to your local
IRIS server or other servers where IRIS is running.

When you run the IRIS menus for the first time, you must define the list of IRIS servers that
you want to be able to access.

The server that is running on your local workstation, localhost, is listed by default.
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1. To increase or decrease the number of servers allowed in the list, enter a number in the
Servers field.

If the number of servers is larger than the number of known servers, unused entries are
listed as Button Name entries.
If the number of servers is smaller than the number of entries in the list, entries are
removed, beginning with the last server in the list.

2. On the IRIS menu, select Connect > Customize Server.

The top of the server menu contains the list of servers. The bottom of the menu
contains the fields for adding or changing server definitions.

3. Select a list entry.

This places the server information in the fields at the bottom of the menu.

4. Type the server details:

• Alias: server name.
• Host Name: server's node name, that is, the network node name of a server where

IRIS is installed.

5. Select OK to add the server to the list.

The server list is stored on disk so that the entries you make in one session are available
in the next.

6. Select Apply to save your changes.

5.2 Connecting to Servers
To activate IRIS menus, you must be connected to a server running an IRIS host. You can
connect to only one server at a time.

If you are an IRIS observer, you can connect a host and view menus but cannot change
menus that control the radar or network operation.

1. In the menu bar, select Connect and pull down the list of available servers.

The list contains the names of the servers that you added in Customizing the Server List
(page 26).

2. Select a server from the list.

The IRIS menu bar title changes, displaying the class of use (either OPERATOR or
OBSERVER) and the name of the server node.

5.3 Disconnecting Servers
1. Select Connect > Disconnect.
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6. Managing Audio Settings

Figure 6 Audio Setup

1. Select Tools > Audio Setup.

2. Configure speech options in the Speech panel.

a. Select or deselect Enable to enable or disable all speech originating from your local
workstation.

b. Define the sound output settings

• Select Local to output to the sound card in your workstation.
• Select Remote to the specified PC using the specified port number.

For remote output, enter the Hostname of the workstation.
For remote output, enter the Port Number. The recommended value is 30731.

c. Select Test to send the test string on the menu as a spoken output.

d. Use the slider to control audio volume.
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3. Configure sound options in the Sound panel.

a. Under Hardware, if you have a sound card, select Sound Card.

If you do not have a sound card, select Bell.

b. Under Alarm, select Continuous or Timed alarm.

For timed alarm, select the time (in seconds) for how long beep, honk, or other
sound you want to hear.

a. For Alarm File, select the .wav file you want to hear when IRIS gives an alarm
message.

The loudspeaker icon plays a sample to help you choose. The alarm messages are
tagged in the message summary menu with an s (spoken).
The options are available only if you have a sound card.

b. For Msg File, select the .wav file you want to hear when IRIS gives a non-alarm
message.

4. Select Save.
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7. Using the Radar Status Menu

7.1 Running Radar from the Radar Status
Menu

Figure 7 Radar Status Menu

The Radar Status menu provides tools for running, configuring, controlling, and monitoring
an IRIS radar or analysis system.

Because it involves real-time processes, the Radar Status menu is a radarop menu.
Anyone may view the menu.

The DEFAULT configuration is automatically loaded when IRIS first starts. You must
configure it to be either a non-operating state or the desired working state. In most cases,
Vaisala recommends the latter.
On most radars, with DEFAULT mode configured as the desired working state, IRIS runs
the scheduled tasks automatically and there is no need to perform the following steps.

The name assigned to the Radar Status menu defines a complete mode of operation.
To set up a mode of operation, set-up and save the Radar Status menu.
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1. Make sure IRIS has started.

2. Select Menus > Radar Status.

When IRIS starts, the IRIS DEFAULT configuration loads.

3. If you want to use a mode other than DEFAULT, select File > Open and then a
configuration file from the list.

Do not set the DEFAULT IRIS configuration for the Radiate switch to
come up as On or Auto if it could represent a hazard to personnel.
For installations where this could be a problem, create a DEFAULT file which starts
the radar with Radiate and Antenna Servo as Off, so the antenna does not start
scanning automatically when the IRIS command is issued.

CAUTION!

4. Check the status of the devices to make sure all subsystems function normally.

In particular, check that the RCP status is Computer and not Local. If the status is Local,
set the mode switch on the radar console so IRIS can control the system.

5. Verify that the Radar Process is On. Toggle real time display On or Off, as required.

6. Toggle T/R Power and Servo Power on.

7. Set Radiate to Auto or On, as required.

Auto allows IRIS to automatically turn the transmitter off when the system is idle.

8. To check or schedule tasks or products:

a. If tasks are scheduled and one is running, check that the Ingest Process shows the
name of the active task, and the antenna speed and position indicators show that
the antenna is moving.

b. Schedule additional tasks or products, if needed.

7.1.1 Control Section
The Radar Status > Control Section pane includes tools for:

• Viewing active IRIS mode
• Loading and saving IRIS configurations
• Starting and stopping the major IRIS processes
• Starting and stopping the radar transmitter
• Device resets for selected equipment
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Figure 8 Radar Status Menu Control Section

Set the DEFAULT IRIS configuration so Radiate and Servo Power are off if
there is a possible hazard to personnel when IRIS starts.
CAUTION!

TASK Schedule

Determines which task schedule is run. Select the button to show a list of available task
schedules.

Ingest Process

Provides control and status for the software that runs the radar system and creates ingest
files. Toggle this button to start or stop radar operation.

In the Setup utility, you can define whether RCP or signal processing (DSP) is reset when
ingest process starts up. By default resetting both is enabled.

• Resetting RCP is a convenient way to reset after a shutdown. This also causes the RCP
reset output line to toggle, which may be configured to reset other equipment at the
radar site.

• When the signal processor resets, it takes a noise sample before resuming data
collection. This is a convenient way to force a noise sample.

The text area to the right of the toggle button shows the ingest process status.

Table 9 Ingest Process Statuses

Status Description

Running The current task is running normally.

Idle No task is running, but the radar process is ready to run tasks. Either tasks have not been
scheduled, or it is not time for a scheduled task to run.

Stopped The ingest process is off.

Radiate

Controls the transmitter radiate with the following options:
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• Auto — For normal operation. IRIS turns the transmitter radiate on and off
automatically. For example, if there is no task to be run for five minutes or more, IRIS
temporarily turns the radiation off.

• On — The transmitter radiate is on at all times during IRIS operation. This is the
recommended setting for magnetron radars.

• Off — The transmitter radiate is off at all times during IRIS operation. A warning
message is generated if you run a task with Radiate turned off.

Transmitter radiate status is reported as either On or Off. See Antenna and Transmitter
Status (page 36).

Transmitter (T/R) Power

Controls power to the transmitter cabinet. The status is either On or Off. When power is
turned off, the sensors for some of the Antenna/Transmitter status items do not function
properly.

Servo Power

Turns the antenna servo drive power on and off. The status is either On or Off.

Product Schedule

Determines which products are generated. Select the button to show a list of available
product schedules. In most cases, DEFAULT is the only product schedule.

Product Generator

Toggles Product Generator process on and off. The status is shown as Idle, On, or Off.

Reingest

The reingest process takes a RAW product file and makes ingest files, which can be
processed to make products. The reingest process can be activated either:

• Automatically, whenever a RAW product is restored from tape.
• Automatically, whenever a RAW product is received over the network.

The reingest process can be toggled on or off. The status is displayed as Idle, Running, or
Stopped.

NORDRAD

If your system is licensed to receive product output from the Nordic Radar Network System
(NORDRAD), you can turn NORDRAD on and off.

The field shows the status of the receive process as Idle, Running, or Stopped.

Messages

Select to open the Message Summary menu.

The Message field shows the number of messages after IRIS startup.

Site Status

Gets information from Status products that are either received over the network or made
locally.
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These are made automatically at each radar site on a fixed schedule (for example, every 10
minutes) as set in the setup/product utility. See IRIS and RDA Utilities Guide (M211316EN).

The Status product can then be sent automatically over the network through the Product 
Output Menu. For example in a radar network, each radar may send routine status products
to a central maintenance facility.

Select the button next to the field to show a list of all sites and their status.

Output Schedule

Indicates the mode of the product output menu. Select the button to show a list of available
output modes.

For example, you may have 2 parallel network connections to the radar site (main and
backup network) and in DEFAULT mode products are sent through the main network, while
in BACKUP mode they are sent through the backup network.

Product Output

Controls whether products can be output to display devices or tape. This is a convenient
way of stopping all output to all users if a problem develops.

Network Receiver
If your system is configured to receive product output from another IRIS host or workstation,
this field shows the status of the receive process, as Idle, Running, or Stopped.

The field also displays the number of IRIS systems to which you are connected. If the
number is 0, you are not currently connected. The other computer may not be running IRIS
or the connection may be broken. You can toggle this field on and off to attempt to
reestablish a broken connection. Check with your system manager if you are uncertain.

IRIS Focus

If your system is running IRIS Focus server, you must enable the IRIS Focus option.

When enabled, this field shows the status of the server process, as Idle, Running, or
Stopped.

Mode Switch

Select this button to enable automatic reconfiguration. That is, IRIS automatically changes
the configuration in response to a warning product.

Use the Automatic Mode Switch menu to define the warning products to check and the
configurations to load in the event of a warning.

Inputs

IRIS input process can be polling directories looking for arriving files. This is configured from
the Input section on setup. The inputs switch turns the inputs on/off.

7.1.2 Subsystem Status
The Radar Status > Subsystem Status pane displays the status of the subsystem devices
connected to IRIS. The contents vary depending upon the system set-up.
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Figure 9 Radar Status Menu Subsystem Status Section

Use the setup utility to configure the devices listed under Subsystem Status.

Depending on the device, the status is obtained from self-tests invoked when the radar
process starts and from watchdog process that monitor the device during normal
operations.

Status information displayed with the status message NA (not available) indicate that a
device has not been installed.
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Table 10 Radar Subsystem Status Descriptions

Device Type1) Device Status Running Status Additional Information

RCP

(Radar Control
Processor)

OK

Fault (yellow
background)

Error (red background)

N/A If the status is OK,
indicates if RCP is
controlled by:

• IRIS
• Computer - RCP is

controlled by the
computer, but IRIS
does not actively
control it. For example,
if the ingest process is
idle and waiting for
the next task to start.

• Local

If RCP overall status is
Fault or Error:

• Dead Ang (no antenna
angle information
available)

• DEAD

DSP 

(Doppler Signal
Processor)

Idle - DSP is OK but
inactive

Running

Stopped

N/A

<empty>

Windowx 

(Quick Look Window)

OK

N/A - Device is
configured in Setup but is
not initiated.

NoIRIS - Used for TDWR
output.

Idle - device is OK but
inactive

Init - device is initializing

Running

The alias name of the
device as configured in
the Setup utility Output
section.Networkx Node Name

(Network Output)

Archivex

Printerx

1) x indicates the number of the output device as configured in the Setup utility Output section.

7.1.3 Antenna and Transmitter Status
The Radar Status > Antenna and Transmitter Status pane shows the status for the antenna,
transmitter and BITE systems, including antenna position and velocity.
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Figure 10 Radar Status Menu Antenna and Transmitter Status Section

Azimuth and Elevation Position and Velocity

The azimuth and elevation values show the antenna position and velocity (in RPM).

For the velocity, clockwise and upward motion are positive values, while counterclockwise
and downward motion are negative values.

Transmit

Table 11 Transmit Statuses

Status Description

Off The transmitter is off.

Not Ready The transmitter is warming up.

Standby The transmitter is ready to transmit, but has not been set to radiate using the Radiate
button.

Radiate The transmitter is radiating.

Safety Parameters

The safety parameters display the status of safety and monitoring parameters reported by
the built-in test equipment. The report contents depend on the installation.

Table 12 Safety Parameter Report Examples

Safety Parameter Description

Air Flow Shows whether the cooling air flow in the transmitter is Normal or Fault.

Interlock Shows the status of the safety interlock circuit. For example on a high voltage cabinet
door, the status is either Normal (door closed) or Fault (door open).

Magnetron Shows the magnetron current as Normal or Fault.

Waveguide Shows the waveguide pressure as Normal or Fault.
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Safety Parameter Description

BITE Shows OK or Fault for the optional BITE unit.

For information on faults, see the Bitex section in IRIS and RDA Utilities Guide (M211316EN).

Fault Alarms Sent to IRISnet

The red or yellow fault indicator in IRISnet shows the state of the Radar Status Menu on a
host.

A red field in Radar Status menu causes a cross indicator to the IRISnet icon. The cross is red
for critical alarms, and yellow for non-critical alarms.

The Site Status field of Radar Status Menu is not indicated in IRISnet.
Since Site Status shows other sites, it would be confusing if a fault in Site A causes an
IRISnet Red X on site B just because site B was receiving status products from A.
If a local fault causes the site status to go red, that fault is indicated elsewhere in the
Radar Status Menu.

You can set some faults to be critical or non-critical. For example:
• Radar, Product Generator, or Output Processes turned–off (buttons at the top). These

are always critical.
• DSP or RCP communication error (sub-system status fields). These are always critical.
• Antenna/Transmitter Status: BITE (configurable in BITEX to be null, critical or non–

critical)
• Antenna/Transmitter Status: Air Flow, Waveguide, Interlock, Magnetron (configurable in

setup/rcp to be critical or non–critical).

7.2 Mode Switching

7.2.1 Manual Mode Switching

1. To switch modes manually, do one of the following:

• Select File > Change RST and select the new mode.
• Load a new configuration in the Radar Status menu.

7.2.2 RCP Mode Switching
In RCP mode switching, RCP controls the system mode. This mode is only applicable to a
radar system.

Mode switching is normally used for switching between redundant systems due to fault
detection.

When RCP mode switching is enabled in IRIS, socket mode switching and status product
mode switching are unavailable. RCP can choose one of the following:

IRIS User Guide M211317EN-K

38 RESTRICTED



• Force the mode to switch. This disables all other choices, so manual mode switching
and automatic mode switching are disabled.

• Enable the other choices. In RCP mode switching, the Automatic Modes Switching
button is controlled by the RCP.
For more information, see the appendix on dual radar systems in RCP8 User Guide
(M211320EN).

7.2.3 Socket Mode Switching
In socket mode switching, modes are supplied by a socket message. Use this mode to:

• Switch modes based on input from another software system
• Trigger mode switch based on a Bitex status (in this case the input is an IRIS message).

In socket mode switching, RCP can do one of the following:
• Force the mode to switch. This disables all other choices, so manual mode switching

and automatic mode switching are disabled.
• Enable the other choices.

In socket mode switching, the Automatic Mode Switching button is controlled by the
socket.

This mode is only available when RCP mode switching is disabled.

7.2.4 Status Product Mode Switching
Status product mode switching allows a system to slave its configuration to a master system
based on the status products from that master.

Each time a status product arrives from that other system, the mode is forced to match.

This is used as part of a passive IRIS system, or to slave a RPG computer to a RDA computer
in redundant systems.

You can change modes through manual mode switching or automatic mode switching.

7.2.5 Automatic Mode Switching
In automatic mode switching, mode transitions can be controlled by warning products.

This is used to change modes based on weather. Between times, you can change modes
manually.

You can define up to 16 situations in which the IRIS configuration is automatically switched.
For example, you may want to switch configurations automatically when a wind shear is
detected.

Because configurations can also be switched when a warning is absent, you can define the
conditions under which to automatically switch back to a default configuration. A series of
warning products can be chained together, triggering a series of actions, each requiring a
different configuration.
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1. To enable or disable automatic mode switching, select Radar Status > Mode Switch.

Mode Switch is unavailable if RCP mode switching or socket mode switching are
enabled.

7.2.5.1 Defining a Series of Automatic Mode Switches

Figure 11 Automatic Mode Switch Menu

1. Select Radar Status > Mode > Auto Mode.

2. Enter the information in the fields:

Minimum Switch Time— Minutes that must pass before the configuration can switch
again.
Warn Product— Enter the name of a warning product directly into this field, or select a
product from the list of products. When this warning is encountered (or when it is
absent) the IRIS configuration switches automatically.
Alert— Set to Yes if the configuration should switch when the warning is encountered.
Set to No if the configuration should switch when the warning is absent.
New IRIS Config— Name of a configuration directly into the field, or pop up a list of
configurations to choose from. This configuration is loaded in the Radar Status menu
when the warning condition is met.

3. Select Apply to add the definition to the list;

Select Clear to start again.
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4. Repeat Steps 2 - 3 for up to 16 warnings.

5. To discard your definitions, select File > Reload.

This loads the most recently saved definitions.

6. Select File > Save.

7.2.5.2 Changing or Deleting a Definition

1. In the Automatic Mode Switch menu, select a definition from the list.

The warning and configuration names are displayed in the fields above the list.

2. To change the definition, enter a new warning product or configuration name if you
want.

3. To delete a definition, set the Alert field to "- - -" .

4. Select Apply.
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8. Configuring Radar Tasks

8.1 Configuring Tasks
Use the TASK Configuration menu to create or modify radar tasks.

Figure 12 TASK Configuration Menu
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Table 13 TASK Configuration Menu Description

Menu Pane Description

Antenna/Radar Control Sets up radar and antenna operations.

See Antenna and Radar Control (page 44).

Processor Configuration Sets up the output data, ranges and averaging used by the signal
processor.

See Processor configuration (page 48).

Data Correction Determines corrections made from output data.

See Data Corrections (page 54).

Data Quality Thresholding Sets up the threshold levels and criteria for real time data quality control.

See Data quality thresholding (page 57).

1. To create a new task, select Menus > Task Configuration.

2. Enter a task name and description.

a. Select a name that summarizes the task. Task names may contain up to 12
characters, no spaces are allowed. Use an underscore instead of a space.

You can define hybrid tasks with up to 26 subtasks. For hybrid tasks the task
configuration file names for these must end in _A, _B and _C to denote the first,
second, and third sub-tasks.

b. Enter a brief task description (less than 65 characters).

Table 14 Example Task Names

Example Task Description

PPI_VOL A volume scan.

RHI_230 An RHI at azimuth 230.

SURV_500 A 500 km surveillance scan.

PPI_A First subtask of a hybrid task.

3. Configure the task using the options in the menu.

4. To edit the configuration of a task, do one of the following select File > Open.

The TASK Configuration menu opens showing the task configuration for this task.
For unscheduled tasks, more than one copy of a task can be in use at any time.
Note that:
• If a task is scheduled, it cannot be modified.
• Only one user can edit a particular task at a time.

5. Select File > Save As to save the task configuration.

6. Use TASK Scheduler to schedule and execute the task.

See Task Scheduling Overview (page 65).
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More information

‣ IRIS Tasks (page 11)

8.2 Antenna and Radar Control

Figure 13 Antenna/Radar Control Pane

Use the Task Configuration > Antenna/Radar Control pane to set up radar and antenna
operations for controlling tasks and products.

Scan Mode

Use Scan Mode to select the following modes.

Table 15 Scan Modes

Scan Mode Description

PPI Full The antenna scans continuously in azimuth without stopping during the task.

For PPI scans, IRIS holds the elevation constant and scans in azimuth.

PPI Sector The antenna starts and stops at azimuth boundaries that you specify.

Manual You control the antenna while the real time display shows live weather
updates.

Manual scans are used for interactive real time applications, observation of
tornado, or microburst signatures.

RHI The antenna scans in elevation at a specified azimuth.

For RHI scans, IRIS holds the azimuth constant and scans in elevation
between specified limits.

Exec Execute any shell command. See Exec Tasks (page 64).

Azimuth and Elevation for PPI and RHI Scans

For PPI Sector and RHI scans, you must specify start and stop limits for the swept antenna
coordinate, and a list of discrete angles for the unswept coordinate.

There is a duality between the PPI and RHI scans in that the lists and limits that apply in one
case can be carried over to the other case by reversing the roles of azimuth and elevation.
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Elevation for PPI Full and PPI Sector Scans

To set up the antenna elevation limits for a PPI Sector and PPI Full scans, enter the list of
elevation angles to be used on successive sweeps:

1. Select Elevation button to show a window containing up to 40 elevation angles and
make your selections.

2. Select Apply > Exit. (Select Clear to start over.)

When you finish editing, the menu entry shows the number of specified tilt angles and the
minimum and maximum angles.

Azimuth for PPI Full Scans
For PPI Full scans, the Azimuth field shows Full Circle. The antenna scanning is continuous
in azimuth.

Azimuth and Elevation for PPI Sector Scans

When a PPI Sector scan runs, the antenna scans back and forth between the azimuth limits
at a rate that achieves the requested azimuthal resolution between each processed ray. The
first sweep of the scan is performed using the first elevation angle from the elevation list; the
second sweep using the second angle, and so on.

To set up the antenna azimuth limits for a PPI Sector scan, enter the start and stop angles, in
the Azimuth field, type the limits to the nearest whole or 1/10°. The following table shows an
example of how the sector is defined clockwise from the first limit to the second limit.

Azimuth First
Limit

Azimuth Second
Limit

Description

90.0° 270° Scans the southern half of the radar circle.

270.0° 90.0° Scans the northern half of the radar circle.

Azimuth and Elevation for RHI Scans

For RHI scans, the set-up procedure is similar to PPI Sector, except that you:
• Enter the start and stop limits in the Elevation field.
• Enter the angle list in the Azimuth field.

The elevation limits for RHI scans are constrained by the limits specified in the setup utility.
See IRIS and RDA Utilities Guide (M211316EN).

Azimuth and Elevation for Manual Scans

For manual scans, the Elevation and Azimuth fields show NA because the antenna is
controlled interactively.

Resolution

The resolution is the required spacing between successive data rays in the scanned
direction.

You can select a resolution from a menu or type the value in the field.
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Resolution for PPI Full and PPI Sector Scans

For PPIs, specifying 1.0° resolution means that for every degree of azimuth there is a new set
of samples of, for example, the reflectivity at all ranges. The range is limit 0.352 .... 2.000.

During PPI scanning, antenna and signal processing are coordinated so that data are
collected at the specified resolution interval. Sampling is the nearest N*(Resolution) starting
with 0°.

For example, if the resolution is 1.0, rays of data are collected at 0, 1, 2, ... degrees. If the scan
speed is set to Auto, the PPI antenna scan rate is adjusted automatically to scan as rapidly
as possible to achieve the requested resolution.

The Radar Status shows the achieved scan rate.

Resolution for RHI Scans

In RHI scans, the elevation angular velocity used for the scan is not constant. A fixed velocity
results in too much time being spent at high elevation angles where only the initial 20 km
(or so) of the ray contains useful data. Also, too little height resolution would be obtained
for low elevation angles and far ranges. To compensate, the elevation velocity for RHI scans
is a function of the elevation angle itself — the velocity increases as the angle increases.

For RHI scans, IRIS picks and displays the closest Resolution between 0.2, 0.4, 0.6, and 0.8.

The selected resolution represents the desired angular ray spacing at 0° elevation. This
generally corresponds to a small elevation velocity near 0°, but by the time the antenna
reaches its zenith the elevation velocity is approximately 10 times greater. The RHI velocity
algorithm attempts to maintain constant distance spacing along the maximum range and
height boundaries of the scan to produce a properly filled data presentation.

Resolution for Manual Scans

For manual scans, IRIS picks and displays the closest Resolution among 90, 180, 270, and
360, either continuous or non-continuous.

If you plan to use manual scanning, you must pre-configure scans for the situation. Specify
the number of rays of data that you want stored (up to 1024 angles or rays) and how long
IRIS should continue to collect data, as follows:

Value Description

Continuous The manual scan continues indefinitely until it is halted manually in the task
scheduler. New rays overwrite the old ones on disk such that the maximum
number of rays is fixed at the requested number.

In most cases, use this option so the task does not stop in the middle of the
observation.

Non-Continuous The manual scan stops automatically after collecting a defined number of rays.

For more information, see Scheduling and Running Manual Scan Tasks (page 72).
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Scan Speed

Value Description

Auto IRIS automatically calculates the scan speed of the antenna to match the sampling
to the requested resolution.

Recommended for PPI and RHI scans. Type Auto or 0 .

Numerical value 
degrees/sec

Enter the scan speed in degrees per second. Note that 6°/sec is 1 RPM, 12°/sec is 2
RPM, and so on.

When testing a task, observe the actual scan rate in the Radar Status Menu.

If you are in the Auto mode, you can tune the scan rate by changing the fields in the radar
status menu and then retesting. For example, to increase the scan rate in Auto mode, you
can:

• Increase the PRF
• Decrease the number of Samples
• Decrease the scan Resolution

For more information, see the setup/ingest utility in the IRIS and RDA Utilities Guide
(M211316EN).

Pulse Width

Some systems support multiple pulse widths.

Select the pulse width in microseconds (for example 1.0 μsec). IRIS picks the closest
available value.

Most systems support one or more of 0.50, 1.00, 2.00, and 5.00 μsec.

The PRF is automatically reduced to the maximum permissible value if the new choice
exceeds the duty cycle limit of the transmitter.

Polarization

This field is available for dual polarization systems. The following table shows the
polarization options.

Table 16 Polarization Options

Option Description

H, V Fixed H or V polarization.

When the polarization is fixed, you specify which polarization to
use for sampling. Typically, horizontal is selected because of the
slightly greater returned power from meteorological targets.

For a standard radar at fixed horizontal polarization, the field
appears as N/A.

H+V Simultaneous transmit/receive in dual pol.

Alt Alternating, not available on Vaisala radars.
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8.2.1 Ship Velocity Correction
If this feature is enabled in the Setup utility, this enables or disables a radial velocity
correction to account for moving radar platforms.

The velocity correction used in IRIS allows for different types of ship motion sensing:
• Inertial Navigation Unit (INU)
• Gyro System with GPS

See Passive IRIS Overview (page 127).

8.3 Processor configuration

Figure 14 Processor configuration

Use the Task Configuration > Processor Configuration pane to set up output data, ranges,
and averaging used by the signal processor.

Data

Select Data to define the types of data output sent by the signal processor and stored in the
ingest files.

Data shows data appropriate for you system. You can only select data types appropriate for
you task’s configuration. You can also select whether to record in 8-bit or 16-bit format.

The number of parameters you select affects the size of your Ingest and Raw product files.

When you exit the menu, your choices are displayed in the field.

See RVP10 User Guide (M212604EN).

Table 17 Data types

Data type Description

Ah, Av Integral attenuation for horizontal (H) and vertical (V) channels

Azdr Integral attenuation of ZDR (dB) format

CSR Doppler channel clutter-to-signal (CSR) ratio of dBT to -dBZ
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Data type Description

dBT, dBTh, dBTv, DBTr Total power

dBZ Clutter corrected reflectivity

dBZt Uncorrected reflectivity

HCLASS Hydrometeor classification

Estimated hydrometeor type in the precipitation area

KDP Specific differential phase

An indicator of the rate of change of the phase difference between
horizontally and vertically polarized pulses of the radar. A greater horizontal
shift results in a positive KDP value, and a greater vertical shift results in a
negative KDP value. Typical cause for a high KDP area is heavy rain.

LDRH, LDRV Linear depolarization ratio H to V (or V to H)

The ratio of cross-polar to co-polar reflectivity measured in dB

LOG Log receiver signal-to-noise ratio

PHIH, PHIV Horizontal (V) or vertical (V) differential phase

Phase difference for the total round trip between radar and the volume where
the signal is reflected. PHIH is measured between HH and HV channels. PHIV
is measured between VV and VH channels.

PHIDP Differential phase

The phase difference due to propagation between the HH and VV channels of
the radar.

PMI Polarimetric meteo index

R Rate of accumulation of precipitation in units of mm/hour

For snow, this is usually refers to the liquid equivalent.

RHOHV, RHOH, RHOV Correlation coefficient between HH and VV (or HH & HV / VV & VH) channels

Higher (>0.95) values indicate uniform precipitation areas, and lower values
indicate more mixed hydrometeor types, such as melting snow, wet
snowflakes, or airborne debris.

SNR Signal-to-noise ratio

Generic measurement of signal-noise ratio in dB

SQI Signal quality index

A value between 0-1 that measures the signal's Doppler coherency, that is, the
correlation between the signal and its Doppler lag:
• 0 indicates white noise
• 1 is the perfect Doppler point target

T Total reflectivity

Total power returned to the radar in reflectivity units. It typically represents
the horizontal reflectivity without ground clutter correction.

TV, TE Total vertical (HV enhanced) reflectivity

Total reflectivity from the vertical polarization channel (TV) and combination
of the horizontal and vertical channel (TE)
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Data type Description

V Velocity

Average radial velocity (towards or away from the radar) of detected
hydrometeor areas

VC Corrected velocity

Same as velocity V, but corrected for effects of range folding and velocity
folding

V: SHEAR, Vc: SHEAR Velocity and corrected velocity of wind shear

W Spectral width

Variability of Doppler velocity values within the measurement area

XCOR Polar cross-correlation, uncorrected rhohv
Because this value is not noise corrected, this is a direct indicator of the PHIDP
uncertainty.

Z Reflectivity

Usually referred to as dBZ, this is the common data type that measures radar
signal reflectivity, and is used to estimate precipitation intensity from that.

All Z measurements are corrected for ground clutter.

ZV, ZE Vertical (HV enhanced) reflectivity

Total reflectivity from the vertical polarization channel (ZV) and combination
of the horizontal and vertical channel (ZE). Corrected for ground clutter.

ZC Corrected reflectivity

Same as reflectivity Z, but corrected for attenuation and beam blockage
effects

ZDR Differential reflectivity

The ratio of SNR in the horizontal channel to the SNR in the vertical channel.
Positive values indicate more prominent horizontal echoes and negative
values more prominent vertical echoes. Larger hydrometeor sizes are usually
identified by high positive ZDR values.

ZDRC Corrected differential reflectivity

Same as differential reflectivity ZDR, but corrected for attenuation and beam
blockage effects

T&Z are

Choose how T and Z are handled:
• Calibrated radar reflectivity factors

Most common configuration.
• Measured signal-to-noise ratio (SNR)

Used for diagnostic and troubleshooting purposes and for radar antennas with non-
standard beam patterns. Note that when SNR units are selected, the clutter correction
is applied to Z but not to T.

Samples

Specify how many pulses are averaged (from 2 ... 256, continuously selectable) to obtain the
final estimates of the radar parameters for each ray in Samples.
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IRIS requires approximately 40 samples for acceptable averages and reliable clutter
cancellation.

In general, the number of samples should be as large as possible, however, the more
samples there are, the slower the antenna scan speed must be.

Filter Dop
Use the Filter Dop to specify a clutter filter type. Specify an integer between 0 ... 7, where 0
is no filter. Typically filter 1 is the least aggressive and filter 7 is the most aggressive.

Selecting a clutter filter depends on the scan rate, antenna beam width and the operational
objectives. In general, the narrower the filter the better, since a broad clutter filter has a
greater adverse effect on the weather echoes. The narrower filter is also less aggressive.

Most users must experiment with the best combination of clutter filters and thresholds. See
Optimizing Thresholds (page 60).

To determine which filters best reduce the effects of clutter while doing the least damage to
the weather, try different clutter filters on a rainy day and compare Z and T (the corrected
and uncorrected reflectivity) on the real time display.

When optimizing the Doppler filter, do not use the CSR threshold as the Z threshold
criterion.

To determine the appropriate filter, use the Ascope utility to measure the actual width of
clutter Doppler spectra as a function of the scan rate, which can be controlled through the
Antenna utility). For more information, see IRIS and RDA Utilities Guide (M211316EN).

For more information on configuring clutter filters, see RVP10 User Guide (M212604EN).

Start Range

Start Range specifies the required range of the first data bin to the nearest 1/10 km.

Usually this is set to 0.0 so that sampling starts at the closest possible range. However, when
2 tasks are used to define a sampled volume, it is sometimes useful to have:

• One task sample an inner range at a high PRF.
• One task sample an outer range at a low PRF.

Bin Spacing

Bin Spacing specifies the desired range resolution of the data.

Type the value to the nearest meter or choose from a list of values.

IRIS picks and displays the allowable bin spacing that is closest to your choice. This depends
on the processor, with a typical value of 125 meters.

See IRIS and RDA Utilities Guide (M211316EN) and TTY Non-Volatile Setups in RVP10 User
Guide (M212604EN).

Chapter 8 – Configuring Radar Tasks

RESTRICTED 51



Range averaging, input bins, and output bins

Range averaging means that the data obtained at the output bins is obtained by averaging
2 ... 16 input bins.

Table 18 Range averaging choices

Choice Description

None No range averaging. The Input Bins and Output Bins fields are identical.

No range averaging is performed, and single-point sampling is done for each of the
output bins.

2 ... 5 Range averaging over 2 ... 5 bins. For example:

• 2 bins: IRIS doubles the number of input bins by placing new bins halfway between
each output bin, then averages the 2 bins together to obtain each final output bin.

• 3 bins: IRIS creates 3 times as many input bins as output bins. Data at each output
bin is the result of averaging 3 equally spaced input bins.

The total number of input bins is limited by the processor. If you specify a range
average that results in greater than the processor limits, IRIS reduces the maximum
range to be consistent with the limit.

Max Range

Max Range defines the maximum range (km) of data collection.

If fields such as the PRF, Range Averaging, or Bin Spacing change, IRIS attempts to fill in
range bins to the full unambiguous range. If this is successful, Max Range equals the
unambiguous range.

In most cases, Vaisala recommends keeping the Max Range less than Unambiguous Range.

Max Range turns red if it exceeds the Unambiguous Range. A Max Range that exceeds the
unambiguous range is allowed for users using their own major processing mode. It is also
useful to allow the Max Range to exceed the unambiguous range by 1 range bin to make the
Max Range an even value, for example 150 km instead of 149.9 km. In other cases data that
exceeds the unambiguous range is nulled.

When using the dual-PRF technique, if a user requests a maximum range greater than the
Rmax of the High PRF, but less than the Rmax of the Low PRF, the range field turns yellow.
This indicates that the 2D 3x3 speckle filter will be used to interpolate across the radial
boundaries. If a user inserts a maximum range greater than the Rmax of the Low PRF, the
field turns red, indicating that the requested max range is exceeded.

Unambiguous Range

The display-only Unambiguous Range is the maximum range for first trip echoes —
the maximum range from which an echo can be received before the next pulse is issued. It is
affected if the PRF is changed.

Playback

Playback determines the noise floor and calibration level used by the RVP when playing
recorded time series data. The options are:

• RVP current noise floor and calibration level
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• Values recorded in the time series

The Playback value has no effect on the noise floor and calibration level of the RVP during
normal operation.

Vel Unfold

For Doppler systems, velocity unfolding (Vel Unfold) determines whether dual PRF control
and processing are performed.

For more information, see RVP10 User Guide (M212604EN) .

Table 19 Velocity unfolding choices

Choice Description

None Single PRF operation with no velocity unfolding.

3:2 Dual PRF with ratio of 3:2. This provides 2X velocity unfolding as compared to the
unambiguous velocity for the larger PRF.

4:3 Dual PRF with ratio of 4:3. This provides 3X velocity unfolding as compared to the
unambiguous velocity for the larger PRF.

5:4 Dual PRF with ratio of 5:4. This provides 4X velocity unfolding as compared to the
unambiguous velocity for the larger PRF.

High PRF and Low PRF

Specify High PRF and Low PRF by entering a value to the nearest whole Hz, or by choosing
from a list of values.

The computed Low PRF is displayed in the adjacent column (display only).

The maximum and minimum values depend on the duty cycle limit of the transmitter for the
selected pulse width. If you enter a PRF that exceeds of these limits, IRIS inserts the limited
value.

Unambiguous Velocity

The display-only unambiguous velocity (Unamb Vel) changes when you change High PRF or
Velocity Unfold.

Processor Mode

Proc Mode determines the processor mode.

Table 20 Processor mode options

Mode Description

PPP Pulse pair processing.

FFT Fast Fourier transform.

RPHASE Random phase.

DPRT–1 Dual PRT mode 1.

Chapter 8 – Configuring Radar Tasks

RESTRICTED 53



Mode Description

DPRT–2 Dual PRT mode 2.

BATCH Batch Mode Processing.

Phase Code  

Phase Code

The transmission phase of a Magnetron transmitter is always Random.

For Klystron and TWT amplifier transmitters, the transmission phase may be controlled
using a phase shifter. This field allows the signal processor to specify the phase of each
pulse.

• Fixed is the legacy mode for Klystron and TWT amplifier transmitters.
• Random allows a Klystron or TWT amplifier to mimic the pulse phase of a Magnetron,

which is useful for second trip echo cancellation.
• SZ 8/64 is a predetermined phase code algorithm which mitigates range ambiguities

and allows for better recovery of weak first trip spectral moment estimates that have
been contaminated by stronger second trip estimates.

Attenuation Correction

To enable attenuation correction for dual polarization, select DP Attn Cor Z ZDR.

You need a valid dual-polarization license code to use the dual-polarization attenuation
correction function. See RVP10 User Guide (M212604EN).

8.4 Data Corrections

Figure 15 Data Corrections

Clutter Map Z

When no Doppler filtering is available, you can use clutter mapping to remove clutter.
1. Make a volume scan in a weather situation without any precipitation to represent

typical clutter in your images.
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2. Tag this product as Clutter Map in the Ingest Summary menu, and turn it on in the task
configuration.
It modifies the Z data to remove any signal weaker than the clutter scan.
Alternatively, to remove clutter from the RAIN1 products, tag a RAIN1 product as
clutter map.

Target Detect Zc

Target Detect Zc computes Zc with uniform weather removed. Any input signal of more
than 2 range bins in a row is smoothed and then only peaks are passed. The goal is to pick
out targets against a weather background.

Only use Target Detect Zc for target tracking.

Beam Blockage Zc

Because of obstructions to the radar horizon (towers, buildings, mountains) the radar beam
can be partially or totally obstructed.

Use Beam Blockage Zc to use the Ingest process to compute Zc by correcting the measured
Z values for partial beam blockage.

Beam Blockage Zc can make corrections up to 10 dB. Larger corrections (for example,
more than 90% of the beam power lost) are not practical.

To use beam blockage, you must configure the beam_block.conf file in the IRIS
configuration directory (/etc/vaisala/irisrda) .

For example, configure the file for each elevation angle used in the volume scan:
• Azimuth angle span
• Range at which the blockage starts
• Blockage in dB up to 10 dB
• Elevation angle tolerance

For more information on the file format, see the example beam_block.conf file shipped
with your system.

These feature works best when dynamic angle synchronization is used so that the azimuth
rays are collected over the same angle span every time (or example, for 1° resolution, the
angle spans would be 0.5 ...1.5, 1.5 ... 2.5, and so on).

The blockage correction is based on the assumption that part of the beam is blocked, and
part continues on to reflect from weather targets. Thus all signal returns beyond the
blockage have a lower power than the correct value. To correct for this, IRIS adds the
appropriate constant to all range bins beyond the blockage. There is no correction to handle
complete beam blockage. Up to 2 beam blockages are supported in each direction.
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Unfold Vc

Use VVP unfolding to unfold Doppler speeds in individual range bins, when the value is
compared to a reference VVP product.

Unfolding for IRIS-corrected velocity, Vc, is especially important for NDOP (Multiple
Doppler) product. For more information, see IRIS Product and Display Guide (M211319EN).

You must create a reference VVP product with a product name UNFOLD to perform this
correction.

Attenuation Zc

Attenuation Zc computes a Zc by correcting for the intervening attenuation.

In the Ingest setups, set a Z attenuation constant and exponent, maximum Z for correction
and maximum cumulative correction. For each task, decide if you want to use the
attenuation correction.

Values are suggested for X- and C-bands. Vaisala does not recommend the attenuation
option for S-band.

If multiple corrections are turned on for Zc, the order of operations is:
1. Beam blockage
2. Intervening attenuation
3. Target detection

Remove Fallspeed in Vc

Radial winds are assumed to be caused by the horizontal winds only. The fallspeed of the
hydrometeors (of order 1 m/s for snow to 10 m/s for rain) can make a significant contribution
to the radial velocity.

To estimate and remove this effect, the water phase (snow or rain) of hydrometeors must be
known. If you use this correction, add the height of the melting level to the setup
information. This correction is mainly used when making the NDOP product.

See SRI product in the IRIS Product and Display Guide (M211319EN) for information on
setting the melting level dynamically.

Storm Relative Vel Vc

Removes the storm motion from the radial velocities. The source of the storm motion is an
IRIS FCAST product, which you must configure with a product name STORM.
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8.5 Data quality thresholding

Figure 16 Data quality thresholding

The signal processor performs thresholding to ensure clean displays, promote efficient
execution and transmission of the products, and reduce the amount of tape and disk space
required to hold compressed data and product archives.

Table 21 Thresholding concepts

Concept Description

Threshold IRIS edits data in real time to remove range bins with weak signal power, unreliable
estimates of Doppler parameters, or polarimetric parameters that suggest echo is
of undesired origin, for example not precipitation.

Parameters Each threshold parameter has its own user-defined threshold level. See the
following table.

Threshold Criteria The parameter to use as the criterion.

For example, the Z values could be discarded when the log receiver signal is weak.
Likewise, V values could also be discarded when the log receiver signal is weak. In
both cases, LOG is the threshold criterion for thresholding Z and V.

Threshold Levels Acceptable levels for the signal.

Using the same example, the threshold level for the LOG may be set at 1 dB above
noise. In this case, the velocity and reflectivity are discarded if the LOG receiver
power does not meet or exceed 1 dB above noise. This is done on a bin-by-bin
basis.

For each range bin, the values of the threshold parameters are computed and
compared with the user-defined threshold levels. The result is either a "pass" or
"fail" for each threshold parameter.

Table 22 Threshold parameter levels

Parameter Threshold level

LOG Level (dB)1) The receiver signal-to-noise ratio.

The average LOG channel power (dB) at each range bin is compared to the LOG
threshold level (typically 1 dB). A LOG level of 0 dB represents the noise floor.

If the measured LOG power at a bin is greater than the threshold, the range bin is
"passed" for LOG.
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Parameter Threshold level

SQI Threshold
[0,1]1)

Doppler channel signal quality index (SQI).

A measure of the coherence or Doppler power of the linear channel. The SQI is
0 ... 1, where 0 corresponds to a signal that is "white noise" (no coherent power)
and 1 corresponds to a signal that is a perfect point Doppler target (all power is
coherent).

An SQI greater than approximately 0.4 is required to measure mean velocity and
spectrum width.

If the measured SQI at a bin is greater than the threshold, then the range bin is
"passed" for SQI.

CSR Threshold
(dB)1)

Doppler channel clutter-to-signal (CSR) ratio.

The CSR compares the ground clutter power to the meteorological signal power in
the Doppler channel. The CSR is calculated for each range bin and compared to the
user-defined threshold, typically set to 20 ... 40 dB depending on the coherence of
the transmitter/receiver system.

If the measured CSR at a range bin is less than the threshold level, then the bin is
"passed" for CSR.

SIG Level 1) A measure of the power from weather targets, excluding noise.

Refers to the weather signal power. That is, the signal-to-noise ratio corrected for
clutter. This is typically set to about 10 dB, and used to threshold widths. This is
because the spectrum width cannot be measured from a very weak signal.

If the measured SIG at a range bin is greater than the threshold level, then the bin is
"passed" for SIG.

PMI Threshold1) Polarimetric meteo index (PMI), available at polarimetric radars operating in the
mode of H+V transmission.

Describes the consistency of the data with the hypothesis of precipitation (the
default preference). The estimate is obtained from the ratio of the rule strengths of
the HydroClass pre-classifier class Meteo to the maximum rule strengths of the
alternative hypotheses Bio Scatter and Ground Clutter / Anomalous
Propagation.

As default, the ratio is transformed into a score function that lies smoothly
between 0 and 1, where 0 corresponds to a signal that is unlikely Meteo (low
Meteo rule strength) while 1 corresponds to a signal that is likely the preferred
class Meteo.

The value 0.45 is the threshold where the pre-classifier declares the bin
DB_HCLASS data to Meteo, in the default HydroClass configuration.

1) Available in all Doppler processing modes.

Threshold levels and criteria

The threshold criterion controls whether a particular type of data (T, Z, V W, and Dual Pol)
should be accepted for each range bin by defining which thresholds to apply to each of
these output parameters.

For example, the reflectivity is usually set so that the Z values (and T) is accepted if the LOG
test passes. As a further constraint, you can accept the corrected reflectivity values (Z) only
if both the LOG and CSR tests pass. This assures not only that the signal is strong enough for
a good estimate, but that the ground clutter is not so strong that the estimate is unreliable.

To set the threshold levels, position the cursor on the appropriate level field and type the
value or move the slider within the scale until the desired value is displayed in the field.
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To change the threshold criteria, enter a value in the field or select an option for each
parameter from a list of choices.

Figure 17 Threshold criteria parameter list example

All Pass means that any value is accepted, and thresholding values are ignored.
Polarimetric variables are treated identically to Dual Pol.

Defaults

Select Defaults to reset thresholding to the default values.

Point Clutter Filter

Point Clutter is a target that has strong total power in one or two successive range bins but
is bordered on either side in by bins of significantly lower power. Meteorological targets
rarely appear this way, but aircraft and ships do.

The Point Clutter Filter is effective in removing small, strong targets having some velocity
causing standard clutter suppression to not work as well.

The Point Clutter Filter is applied in the signal processor using the autocorrelation data (T0,
R0, R1, and R2) after the Doppler spectrum clutter filtering. A range bin is flagged as
containing clutter if its total power (T0) exceeds that of its neighboring range bins by more
than a specified detection threshold (in dB). The neighboring range bins may be configured
to be up to 3 bins away from the central bin. This is used with small bin resolutions, such as
25 meters, as some point targets appears in more than one successive range bin. When a
range bin is flagged, the averages of the autocorrelation values from its neighbors are
assigned to the flagged range bin. In this way point clutter can effectively be removed from
data, even when contained in valid meteorological data.
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Select PntCtl to toggle on or off the Point Clutter suppression feature of the signal
processor. The number in the toggle selects how far away the neighboring range bin should
be along the radial for the comparison.

The Thresh field defines the detection threshold (0 ... 20 dB).

Speckle Filters

A speckle is a range bin that has valid data but is bordered on either side in range by bins
with invalid data (empty bins). Meteorological targets rarely appear this way, but towers,
aircraft and "lucky noise" do.

IRIS provides buttons for enabling or disabling the 2 D Speckle and 1 D Speckle speckle
filters.

IRIS includes separate 1 D Speckle filters:
• Z - LOG channel parameters (for Z, T and ZDR)
• V - Linear channel parameters (for V and W)

Vaisala recommends toggling off the speckle filters initially and adjusting the number of
samples so that there are only a few speckles on the real time display. After the adjustments,
you can toggle on the speckle filters for a cleaner display.

If increasing the number of samples would make the task too slow, you can also adjust the
LOG or SQI threshold level for Z/V until only few speckles remain.

8.5.1 Optimizing Thresholds
When defining thresholds for your system, you must experiment to obtain the best
combinations for your application.

Table 23 Thresholding Rules and Tradeoffs

Rule Tradeoffs

Use large numbers of samples (>50).

The more samples, the better the estimates of all
parameters.

The antenna must scan more slowly when the number
of samples is larger and a slow scan rate may be
inconsistent with operational objectives.

A scan rate of 1 ... 3 RPM is typical for good
estimation, but the slower the better.

See Defining the Number of Samples (page 62).

Use a high PRF.

Doppler estimates tend to be better when the PRF is
high.

The larger the PRF, the shorter the unambiguous
range.
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Rule Tradeoffs

Do not use a clutter filter that is broader than
necessary to remove the ground clutter.

The required filter width depends on the selected
scan rate.

Use the Ascope utility to observe the width of
Doppler spectra at close range to estimate the
required width of the clutter filter.

To simulate IRIS operation, use the Antenna utility to
scan the antenna while the Ascope runs.

See IRIS and RDA Utilities Guide (M211316EN).

A clutter filter that is too broad can damage weather
information without improving the clutter
cancellation.

To find the right threshold values for your system, check data from different weather
situations (clutter only, rain, snow, convective or widespread precipitation) and verify the
situations from independent sources of weather information. Consider making special
monitoring products such as low elevation PPIs with color scale down to -20 dBZ, and
RAINN products over a long period.

The following table suggests some starting points.

Table 24 Recommended Quality Threshold Starting Points

Parameter Threshold Starting Point

T LOG

Z LOG & CSR

V SQI & CSR

W SIG & SQI & LOG

Dual Pol LOG

LOG LEVEL 0.75

SQI LEVEL 0.4

CSR LEVEL 18.0

SIG LEVEL 5.0

PMI LEVEL 0.45

Speckle filters on

Table 25 Troubleshooting Data Threshold Optimization

If you have this problem... … first try to change this threshold

Mountains Filter Dop bigger or CSR smaller

Underestimation of rain over mountains CSR bigger

Doppler snake (no echo at side wind) Filter Dop smaller

Noise at all elevations LOG bigger
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If you have this problem... … first try to change this threshold

Dots at low elevations Speckle filter on

Second trip echoes SQI bigger

Vanishing strong showers SQI smaller

8.6 Defining the Number of Samples
Defining the number of samples means balancing 2 factors: the more samples you have, the
better the Doppler speed estimate and clutter filters work. However, taking many samples
means you cannot move your antennas quickly.

Maximum Number of Samples

You can calculate the maximum number of samples as follows:

SAMPLES = PRF * RESOLUTION / SCAN RATE

where:
SAMPLES

Number of pulses in per ray

PRF
Number pulses you send per second

RESOLUTION
How long the sector is scanned for a single ray

SCAN RATE
Number of degrees the antenna moves per second

IRIS helps you determine the parameters in this equation, and then determines which
parameter it should adjust in each case.

Number of Samples Per Ray

A ray is a collection of pulses (samples) integrated in a single data output from the signal
processor.

The RVP signal processor provides several parameters to define what samples are included
in a ray. The key parameters that determine the number of samples in a ray are Angle
Syncing, Major Mode, and Dual PRF Velocity Unfolding.

The following table shows what constitutes a ray based on the setting of the 3 parameters.
In terms of this discussion, the operation of RPHASE mode is equivalent to FFT mode

Manual tasks are always done with angle syncing off, regardless of the IRIS setting for
angle syncing.
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Table 26 Ray Components Based on Angle Syncing, Major Mode, and Dual PRF Velocity
Folding

Ray Description

ANGLE SYNCING ON
PPP MODE
SINGLE or DUAL PRF

A ray of data is output by the signal processor every RESOLUTION
degrees of antenna motion.

Each ray consists of the integration of all pulses during the previous
RESOLUTION degree of antenna motion. All radials are RESOLUTION
degrees wide.

The pulses selected for integration are centered on the position (N *
RESOLUTION); where N is the number of this radial. If RESOLUTION =
1.0°, the rays are centered on integer values with ray starting and ending
values on 0.5° boundaries.

The setting of SAMPLES is ignored.

ANGLE SYNCING ON
FFT MODE
SINGLE PRF

A ray of data is output by the signal processor every RESOLUTION
degrees of antenna motion.

Each ray consists of SAMPLES number of pulses. This implies that the
width of each radial is not necessarily equal to RESOLUTION. A ray may
be wider or narrower depending on the setting of SAMPLES.

The pulses selected for integration are centered on the position (N *
RESOLUTION); where N is the number of this radial.

ANGLE SYNCING ON
FFT MODE
DUAL PRF

A ray of data is output by the signal processor every RESOLUTION
degrees of antenna motion.

The low PRF rays consist of SAMPLES number of pulses, unless there are
fewer SAMPLES than pulses available during the previous RESOLUTION
degrees of antenna motion. If there are fewer number of pulses available,
the ray consists of the integration of all pulses during the previous
RESOLUTION degrees of antenna motion.

The number of pulses integrated in the PRF rays consists of SAMPLES
multiplied by the DUAL PRF RATIO. This implies that the width of a ray
may be narrower than RESOLUTION, but never wider.

The pulses selected for integration are centered on the position (N *
RESOLUTION); where N is the number of this radial.

ANGLE SYNCING OFF
PPP MODE
SINGLE or DUAL PRF

A ray of data is output by the signal processor every SAMPLES number
of pulses consisting of the integration of all of these pulses. IRIS reads all
rays.

For manual tasks, all rays are stored.

For non-manual tasks, the rays with the best angular fit are stored every
RESOLUTION degrees of antenna motion. If rays are too infrequent to fit
every slot in the scan, some slots have missing rays. If rays are made too
frequently to fit every slot, the extra rays are discarded.

In the DUAL PRF case, rays made at the low PRF are longer in time (and
usually in angular distance) then the rays made at the high PRF.
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Ray Description

ANGLE SYNCING OFF
FFT MODE
SINGLE PRF

A ray of data is output by the signal processor at the CPU limit of the
signal processor consisting of the integration of SAMPLES number of
pulses.

Rays may be partially overlapping. Thus one ray may share many of the
same samples with the previous ray. This sharing iterates among all rays.

IRIS reads all rays.

For manual tasks, all rays are stored. For non-manual tasks, the rays with
the best angular fit are stored every RESOLUTION degrees of antenna
motion.

If rays are too infrequent to fit every slot in the scan, some slots have
missing rays. If rays are made too frequently to fit every slot, the extra
rays are discarded.

ANGLE SYNCING OFF
FFT MODE
DUAL PRF

A ray of data is output by the signal processor every SAMPLES number
of pulses consisting of the integration of all of these pulses. IRIS reads all
rays.

For manual tasks, all rays are stored. For non–manual tasks, the rays with
the best angular fit are stored every RESOLUTION degrees of antenna
motion.

If rays are too infrequent to fit every slot in the scan, some slots have
missing rays. If rays are made too frequently to fit every slot, the extra
rays are discarded.

Rays made at the low PRF are longer in time (and usually in angular
distance) then the rays made at the high PRF.

8.7 Exec Tasks

Figure 18 Exec Tasks

Use Exec Tasks to execute an arbitrary shell command scheduled by the task scheduler
menu.

The signal processor is released from use before this runs. This allows the command to
include programs which use the signal processor, such as zauto.
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9. Scheduling Radar Tasks

9.1 Task Scheduling Overview
The task scheduler configures the automatic operation of the radar, including which radar
tasks to run and when to run them. It also runs interactive manual tasks and exec tasks for
scheduling maintenance jobs.

The task scheduling menus control real time processes and can be modified by a radarop:
• TSC Monitor menu, which shows what is currently happening.
• TSC Editor menu, which allows editing of task schedules

Task IDs

IRIS assigns a sequential ID number to each task in a schedule.

Members of a hybrid task have the same number, plus an A, B, or C to differentiate them.

Hybrid Tasks

The task configuration can link many individual tasks together to create a hybrid task by
naming the subtasks with names such as any_name_A, any_name_B. If you add the
subtasks to the schedule, IRIS also adds the other subtasks. The entire hybrid task is treated
as one task in the schedule. For example, in the any_name hybrid task, the _A, _B, and _C
at the end of the task name denote the additional parts of the task:

• any_name_A
• any_name_B
• any_name_C

In a more realistic example, a volume scan uses a low PRF to get a large, unambiguous range
at low elevation angles and a high PRF to get a large, unambiguous velocity at high
elevation angles where range folding does not occur. You can link these tasks to scan both
the low and high elevation angles in a single hybrid task.

More information

‣ IRIS Tasks (page 11)

9.2 TSC Editor Menu
The TSC Editor lists tasks that make up the schedule.
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Figure 19 TSC Editor Menu

You cannot delete the DEFAULT configuration, the currently running configuration, or the
configuration currently being edited.

1. Select Menus > TSC Editor.

2. To open a task schedule, select File > Open.

A list of task schedules appears.

3. To set the state of a task, place the cursor over the State field and select one of the
following:

• Scheduled - The task runs according to the schedule.
• Idle - The task is on standby and does not run.

For hybrid Tasks, all are scheduled together so only one state is displayed.

4. Check the scan type being performed by a task (as defined in the task configuration) in
the Scan field.

5. Check the value of the Max Range (as defined in the task configuration) in the Range
field.

6. Check the first recorded data types (as defined in the task configuration) in the Data
field.
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7. To control when a scheduled task runs, select the Start, Stop, or Repeat fields.

IRIS can schedule tasks to run at a specific time, or as soon as possible regardless of the
clock time.
See Scheduling Automatic Tasks (page 70).
• Use the tool above the list to change the times (hours, minutes, or seconds).

The time is based on a 24-hour clock and are either UTC or local based on a the
system set-up.

• Select None to clear the time selection.
None for Repeat time means that it runs continuously without pausing.

For hybrid tasks, the B and C parts are left blank because a hybrid task is treated as a
single task for scheduling purposes.

8. To view the estimated time required to run a task, run the task at least once and select
Menus > TSC Monitor.

This is helpful in creating new schedules. For example, if the run time is 00:05:30, do
not schedule the task should to run more frequently than every 5 1/2 minutes.

9. Set scan priorities and resolve schedule conflicts with the Mandatory and Skip options:

• Set Mandatory to yes to allow the task to interrupt a non-mandatory task when its
scheduled time arrives.

• Set Skip to yes to let the IRIS skip the task if the radar is busy with another task
when its scheduled time arrives. The task can run late by up to 60 seconds before it
is skipped.

For hybrid task, the B and C parts are left blank because a hybrid task is treated as a
single task for scheduling purposes.
For more information on managing task priority, see Scheduling Automatic Tasks
(page 70).

10. For dual IRIS systems that operate 2 different transmitter/receivers through the same
antenna, select Dual Flip

For example, when one of the systems finishes the scan, it gives up control of the radar
to the other system. In this way, the 2 systems, perhaps operating at 2 different
wavelengths, can take turns so that one system runs a task and then the other system
runs a task.
For example, setting the Dual Flip flag to Yes on system A allows system B to run a task
after A has completed its task. If system B does not start a task within 3 seconds, then
system A is free to resume its tasks.

11. When you save the currently running configuration, the change takes effect
immediately.

9.3 TSC Monitor Menu
The TSC Monitor contains a list of the tasks that make up the schedule, with indications of
the currently running mode and tools for starting and stopping tasks.
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Figure 20 TSC Monitor Menu

1. Select Menus > TSC Monitor.

2. To change to a different task schedule, select File > Change TSC.

A list of previously configured task schedules appears. Select an item on the list to
change the TSC mode to that configuration.

3. To start or stop tasks, place the cursor over the Command select a command.

Table 27 Task Start and Stop Commands

Command Description

Go (Schedule) Runs the task according to schedule.

Regularly scheduled tasks are typically used for routine IRIS operations. You can
create, test, save and recall schedules for different modes of operation.

Go (ASAP) Runs the task immediately, depending on the priority of other tasks. Use this for
interactive operation

STOP (When Done) Stops a task as soon as it finishes running.

STOP (Right Now) Stops a task immediately, even if the task is incomplete.

Interrupt/
Reschedule

Stops a task immediately and then reschedules it.
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4. To check the status of a task, check the Command column.

Table 28 Task Status

Status Description

Idle Task has not been activated by the Go command.

Scheduled Task has been activated by the Go command, but it is not the task's turn to run.

Running Task is currently running.

ASAP Task is scheduled to run as soon as possible. This is the status after issuing a Go
Now command

For hybrid tasks, the B and C part show only the message Running when the task is
running. Otherwise, this field is blank.

5. To check how long the task took to run, see Run Time.

9.4 Adding Tasks to a Schedule
You can add up to 8 tasks to a schedule.

When scheduling, hybrid tasks are treated as a single task. When one part of the task is
added into a schedule, all the other parts are also added.

1. Select the line in the schedule that you want to put the new task after.

2. Do one of the following:

• Select Add.
• Right-click the ID or TASK field and select Add.

3. Select a task from the list.

IRIS adds the task to the schedule, filling in the information for the selected task.

9.5 Viewing and Editing Tasks in a
Schedule

1. Select Menus > TSC Editor.

2. Select the task from the list, and select Edit.

3. Make your changes.

4. Save your changes.
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9.6 Removing Tasks from a Schedule
1. Select Menus > TSC Editor.

2. Select the task and select Remove.

If your remove a hybrid task, all its sub-tasks are removed.

9.7 Scheduling Automatic Tasks
When system operation requires that products be generated regularly, you can schedule a
task to run at regular intervals and assign priorities to each task.

1. Set the task start, stop, and repeat times:

• Start specifies the first time after midnight that the task runs.
• Stop specifies the last time after midnight that the task runs.

If a task should run all day, specify None.
• Repeat specifies the interval between successive runs.

2. Adjust the scheduling so that no conflicts occur, that is, so that tasks are not scheduled
to run at the same time.

If, for example, you create new tasks, even well-planned schedules can fall behind,
creating scheduling conflicts that must be resolved.

a. Place the cursor over the task field.

b. Select Mandatory > Yes if the task must run at the scheduled time without
interruption.

c. Select Mandatory > No if the task can be interrupted.

If a task is interrupted, the resulting data is complete up to the time of interruption.

d. When a Mandatory task is running and another task comes up to run, the second
task is placed on hold. When this happens, use Skip to help get the system back on
schedule:

• Select Skip > Yes to skip the late task.
• Select Skip > No to have the scheduled task to run runs as soon as possible after

the completion of the current task. In the case of multiple late tasks, IRIS picks
the latest to run next, starting with any Mandatory tasks.
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3. When prioritizing tasks, consider:

• Mandatory tasks always interrupt non-mandatory tasks.
• Mandatory tasks can never be interrupted.
• If a Mandatory task is late and the Skip flag is set to No, it runs before non-

mandatory tasks.
• If more than one Mandatory task with the Skip flag is set to No is late, the latest task

runs first.
When the go ASAP command runs a task immediately, the priority of the task is used
to resolve conflicts as described above. The Skip flag does not apply because the task
runs only once.

4. If a task runs consistently late, analyze and adjust the overall scheduling.

Table 29 24-hour Clock Daily Scheduling Example

Schedule Task Start Time Stop Time Repeat

Hourly, on the hour, all
day

 00:00:00 None 01:00:00

5 minutes after the hour,
every 15 minutes, all day

 00:05:00 None 00:15:00

Two Identical Tasks with Different IDs and Scheduled at Different Times

First task schedule:

• Every 2 hours on the
half hour from 02:30
to 8:30

• Hourly for the rest of
the day

1 02:30:00 08:30:00 02:00:00

Second task schedule:

• Start at 09:30 to
start hourly runs after
the first task ends at
08:30.

• Stop at 01:30
because that is the
last possible time the
task can run before
the first task restarts
at 2:30.

2 09:30:00 01:30:00 01:00:00
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9.8 Scheduling and Running Manual Scan
Tasks

You can insert manual tasks in the schedule the same way as other scan types, except that
antenna control is not automatic.

For interactive manual scans, use the Real time display and the Antenna utility to have
interactive control and feedback. IRIS does not take a noise sample before running a manual
scan. For more information, see IRIS and RDA Utilities Guide (M211316EN).

1. Add the task to the schedule:

In most cases, use a manual scan task on an ad hoc basis.
To prevent the manual scan task from interfering with regularly scheduled tasks:
• Set Stop to None so the scan can work at any time of day.
• Set Repeat to None.
• Set Mandatory to Non-mandatory, so it does not interfere with mandatory scans

such as a regularly scheduled volume scan.
• Set Skip to Yes so that if it is preempted, it does not run.
• Set State to Idle so it does not start automatically.

For information on configuring a manual scan, see Antenna and Radar Control
(page 44).

2. To run the scan, select one of the following:

• TSC Monitor > Go Schedule
• TSC Monitor > Go ASAP

Go Schedule and Go ASAP delay the start of the task according to the Repeat settings.
If Repeat is set to None, the commands have the same effect.

3. If the TASK configuration is set to Continuous, stop the task with the Halt command.

In most cases, set the task configuration to Continuous, especially for interactive scans
with the real time display and the Antenna utility.
If the task configuration is set to Non-Continuous, the task stops automatically after it
has collected the prescribed number of data rays (up to 720).

9.9 Running A Task
1. In the TSC Monitor menu, select, the task you want to run.
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2. Place the cursor over Command and select either:

• Go (Schedule)
Runs the task according to schedule.
The task status changes from Idle to either Scheduled or Running.

• Go (ASAP)
Runs the task immediately, depending on the priority of other tasks. Use this for
interactive operation
The status changes to ASAP, indicating that the task is scheduled to run as soon as
possible. The task runs once, and then the status changes to Scheduled and is
added to the schedule.

9.10 Stopping a Task
1. In the TSC Monitor menu, select the task you want to stop.

2. Place the cursor over Command and select either:

• STOP (When Done)
Stops a task as soon as it finishes running.

• STOP (Right Now)
Stops a task immediately, even if the task is incomplete.

If the task is not running, that is, its status is Scheduled, the commands behave the
same way.

If you select Stop (Right Now), data may be lost.CAUTION!

9.11 Using Passive IRIS
The task scheduler supports running in either active or passive data acquisition modes. The
Setup utility configuration (setup/ingest/scanning) determines whether your system
functions as:

• Active only
No user configuration required.

• Passive only
No user configuration required.
You must load the task schedule with the tasks corresponding to the active system. All
tasks must be set as Scheduled.

• Active/passive (selectable)
You can select active or passive operation.
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Most systems use active data acquisition where IRIS controls the antenna scanning. In some
installations, an external system controls the antenna and IRIS, in passive mode, acquires the
data by listening to what the radar is doing and synchronizing to the external control.

1. To check if your system uses active or passive data acquisition, select TSC Monitor

The menu bar shows one of the following:
• Active
• Passive
• Active (selectable)

2. If you system is configured to select whether data acquisition is active or passive, select
TSC Editor > Active choose either Active or Passive.

3. If you change the data acquisition mode, select TSC Editor > Save As to take the
changes into effect.

More information

‣ Passive IRIS Overview (page 127)
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10. Configuring IRIS Products

10.1 Configuring Products
IRIS Radar products provide information that can be used directly for weather nowcasting
and forecasting. You configure the products in IRIS Radar.

IRIS products can display radar data in many ways. For example:
• The CAPPI product shows the distribution of a radar parameter, such as reflectivity or

spectrum width, at a constant altitude.
• The TOPS product shows a color contour map of the height of a selected reflectivity

surface.
• The RAIN1 and RAINN products show the accumulation of precipitation over selectable

time periods.
• The WARN product checks other IRIS products to determine if there is significant

weather, such as wind shear greater than a threshold amount.

Each product is associated with a configured task. Tasks collect information from signal
processors and store the data on disk in ingest files.

10.1.1 Configuring RAW products

1. Select Menu > Product Configuration.

2. Select Type > RAW.

3. Select the button next to the task name, and select a task from list.

Vaisala recommends you give a RAW product the same name as its associated task.

4. To copy the product files over a slow network connection, select Make sweep-by-
sweep? > On
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5. To filter the RAW product to only include some of the data types of the original data,
deselect Include All Data.

For example, you might want to send all data to a research customer but skip sending
the dual-pol data to a simple display computer.

Vaisala recommends that you leave Include All Data enabled until a need arises to
limit data types.

If you use a wild card, you cannot merge data from hybrid tasks into one file.

6. Select File > Save as and give a name for the RAW file.

10.1.2 Configuring PPI products
A PPI shows data from one elevation, all azimuths. You can use it at the radar site for quality
control.

1. On the IRIS menu, select Menu > Product Configuration .

2. Select Type > PPI.

3. Select the button next to TASK name, and select a task from the list.

4. Select the button next to Data:Display, and select a parameter to be displayed,
typically Z for reflectivity.

5. Enter Maximum Range (km) and elevation angle which suit the task you have selected.

You can see task information in upper part of the menu.

6. Select File > Save as and give a name for the PPI file.
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10.2 Product Configuration Menu

Most Product Configuration menus have the same general format:
Task Summary

Contains information about the task associated with the product.

Map Projection
Specify geographical map projection, if desired.

Product Parameters
Specifies the data, range, and other product-specific options.

Display Parameters
Select your default color scale, which can be overridden at display time.
In case of HClass data types, select the classification method projected in the
product. This cannot be overridden at display time.

1. Select Menus > Product Configuration.

10.2.1 Associating Products with Tasks
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Each product is associated with a task, which provides the ingest data for the product.

TASK Summary information, taken from the associated task, shows the key task
configuration parameters.

When associating a task with a product, the system must consider matched resolution
sampling and constructing volume scans for a product.

1. Select TASK Name to show a list of tasks.

Note that certain product types require different types of task associations.

Product Type Description

Running a product
from ingest data

Enter a task name, including wildcard characters.

The question mark (?) matches a single character; the asterisk (*) matches any
string of characters.

Volume scan
product from hybrid
tasks

In the task name section:

• Specify the input tasks with an underscore and single letter.
• Specify the sub-task suffix letters in the Sub Task box.

Type a "*" to indicate all subtasks.
• Type individual letters such as ABC, AB, BC, or AC to select which portions of

the hybrid to include.
• Type "–" to indicate a range of letters, for example "A–DF" means ABCD and F.

RAW products Always made from a single task.

You must make a separate RAW product for each sub task.

If you are retrieving RAW data from tape or receiving a RAW product over the
network, there is no task configuration file on your disk. In this case, type the task
name directly in the field, exactly as it appears in the Ingest Summary menu or
the Tape menu.

RHI products Include RHI in RHI task names to distinguish them from PPI scans.

2. To optimize product appearance and system performance, define the matched
resolution sample.

For best results, the range bin spacing and number of bins in the task should match
what is needed for the product. This is called a matched resolution sample. The match
does not need to be exact because IRIS uses interpolation algorithms.
For best performance, match the range bin spacing, number of bins and maximum
range in the task configuration, to the desired pixel resolution, pixel scale and maximum
product range in the product configuration.
For example, if you are making a low resolution product (240 × 240) to a range of
120 km (74.6 mi), and you want a single pixel to represent 1 km (0.6 mi) of data,
configure the task configured with at least 120 range bins spaced 1000 m (3280 ft
10 in) apart.
Note that 170 bins can be displayed to the corners of the product. For a medium
resolution product with 1 km (0.6 mi) bin spacing, the best match is for tasks with 240
to 340 bins spaced 1 km (0.6 mi) apart. Note that IRIS can make products for any range
bin spacing that can be specified in the TASK Configuration menu, for example, 500 m
(1640 ft 5 in) or 250 m (820 ft 3 in) spacings can be used as well.
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3. If needed, construct a volume scan.

Some products require volume scan tasks, either PPI Full or PPI Sector scans taken at
multiple elevation angles. Volume scan products include:
• BEAM
• CAPPI
• MAX
• TOPS
• VIL
• XSECT
• VVP
• WIND

For these products, multiple elevation angles are required in the associated task. There
is a tradeoff between the number of elevation angles, the quality of the product and the
task scan time. More elevation angles produce higher quality products at the expense
of taking more time to complete the volume scan.
A typical volume scan is shown in the following figure. In this example, the height
resolution is 1 km (0.6 mi) at 60 km (37.3 mi) range, for heights less than 10 km (6.2 mi).
A 1° beam is 1 km (0.6 mi) wide at 60 km (37.3 mi), so this scheme matches the antenna
resolution. If close range work is important, you must add higher elevation angles to
cover the upper regions.
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Figure 21 Example of 15-tilt Volume Scan

When constructing a volume scan task configuration, it is a good idea to do a drawing
such as the one in the example, with a 1:1 vertical:horizontal scale so that you get a true
picture of the sampling geometry.

The example is corrected for earth curvature, as are all IRIS products.
Also, because of beam widening effects, the accuracy of all products degrades with
range. For example, the beam width at 120 km (74.6 mi) range is 2 km (1.2 mi) across
for an antenna with a 1° beam. This is a fundamental limitation of radar sampling.

10.2.2 Configuring Map Projections
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You can specify the type of map projection that is used for display. This is useful for
combining data from other sources or for generating displays that are not centered on the
radar.

Composites, for example, must use a projection so that the data from several radars can be
mapped to a single display.

Table 30 Supported Map Projections

Projection Description1)

Azimuthal equidistant (AED)2) Choose this for a standard radar display map where azimuth lines are
straight and angles are not distorted.

This projection has the property that the distance in the map horizontal
direction is the same as the distance in the map vertical direction. This
means that lines of constant azimuth (radar rays) are straight and circles
can be used to represent lines of constant range. Because of this, the
AED projection is particularly convenient for radar applications.

For radar applications, the radar is usually placed in the center of the
map and the radar location serves as the map reference point.

Note that lines of latitude and longitude are not straight in this
projection. (Page 191)

In IRIS Focus this is used to display single radar data.

Mercator2) Choose this for true Mercator projection mapping where latitude and
longitude lines are straight and intersect at right angles.

Additionally, a line of constant bearing from a point is straight so it is
useful for navigation.

Mercator has the advantage that it is a known standard, so it is easier to
combine data from different sources onto a Mercator projection. It has
the disadvantage that at high latitudes, the horizontal and vertical scales
are different (large distortion). (Page 38)

In IRIS Focus this is used to display composite radar data.

Equidistant cylinder Used for the digital terrain maps in IRIS (for example, inserted in the
Overlay utility). (Page 90)

Gauss conformal Same as Universal transverse Mercator except omitting the 0.9996 scale
factor. (Page 48)

Gnomonic All great–circle arcs are straight lines. (Page 164)

Lambert conic Scale is true along 2 standard parallels. (Page 104)

Perspective Often used for satellite images. We assume that the satellite is at
geosynchronous height. (Page 169)

Polar stereographic Useful near the North Pole. This is essentially the AED projection with the
reference point at the North Pole. (Page 154)
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Projection Description1)

Universal transverse Mercator 
(UTM)

A projection just like Mercator with the axis reversed at a selectable
longitude. The horizontal dimension is compressed by a factor of 0.9996.
By convention the reference longitudes should be multiples of 6°.

Used by the military, and is good for regions with long North-South
extent. (Page 48)

1) Page numbers refer to the projection equations from Map Projections – A Working Manual, U.S. Geological Survey
Professional Paper 1395.

2) Available in IRIS Focus

1. To configure a standard radar display centered on the radar:

• For the projection type, select Projection Configuration > Azimuthal Equidistant.
• For the Projection Name, select <NONE>.

Most of the time you do not need to create or use special projection files.
If you want the radar off-center, you must configure a projection file as described
starting from step 3.
If you have already configured and saved a projection, go to step 2.

2. To use a pre-configured projection, select Projection Configuration > Projection Name.

• A list of available projection files on the system is shown.
• In the example, the radar Max Range and Output Pixel Resolution are desensitized

since they are defined by the projection file that is selected.
• Select <NONE> for the Projection Name in which case the radar is defaulted to be

at the center of the screen. Additionally in the case of an AED projection, the radar is
defined to be the map reference point. In this case, the Max Range and Resolution
fields are configurable in the Product Configuration Menu.
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3. To configure your own projection, select Setup > Projection Configuration.

The Projection Configuration Menu opens.

4. Select the Projection to define the projection type.

You must first define the projection. The list of available projection files under File is
given only for the selected projection type.

5. Select File > Open command to give a list of existing Mercator or AED files depending
on the selected projection.

6. Select Reference Point.

• For AED projections: The reference point is the location from which all azimuths
display as straight lines. Usually set to the radar location.

• For Mercator projections: The map cannot cross the line 180° away from this
longitude, so set it near your location. The latitude defines the range scale.

• For Polar Stereographic: The is the longitude line which you wish to have vertical in
the map. Effectively this rotates the map. Again the latitude defines the range scale.

• For UTM: Only a longitude is selected. This is the center meridian of the UTM strip.
By convention these are spaced every 6°, starting at 3°. Use a value near your
longitude.

• For Lambert Conic: Also define 2 standard parallels.

7. Select Save to name your projection.

The name of the open projection file is displayed in the menu title bar (AED_200_KM in
the example).
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8. Fix a corner or center location.

To configure a projection, you must know the latitude and longitude of either the NE or
SW corner or the center of the display.
Select Fix at the location that you know and then input the LAT/LON coordinates.
With Fix selected, you can change other parameters of the projection geometry
without losing you coordinate information.

9. Specify the projection coverage area (region of the projection) in one of 2 ways:

• Specify the latitude and longitude of one of the 2 unfixed points.
• Specify the distance North (Y-Range) and the distance East (X-Range) from the

center.
The projection menu acts as a spread sheet. When you change a parameter, the other
parameters adjust to reflect the change.

The spreadsheet algorithm converges on a correct solution even for strange
projections. One example where it may not converge is for an AED projection where
the Reference Point is several thousand kilometers from the center of the projection
region.
If you encounter a problem with the spreadsheet, check the reference point and
select Default to load some valid numbers.

10. Specify the pixels.

The number of pixels that are used to represent data in the projection is specified for
the X- and Y-directions of the output display.
If you have specified the other aspects of the projection, input the correct number of X-
pixels (horizontal direction). The number of Y-pixels adjust automatically.
If you adjust the number of Y-pixels, then other parameters of the spread sheet change,
such as the LAT/LON of the unfixed points and the Y-Range.

11. Fine-tune the spread sheet.

Since all of the projection geometry parameters are linked through the spread sheet
algorithm, when you change one parameter, other parameters adjust automatically.
This means that you may need to compromise. The spread sheet makes it easy to
experiment with different compromises.
For example, if you want a 480 × 480 pixel Mercator display, both the X- and Y-ranges
cannot in general be made equal (for example, 100 km (62.1 mi)). In this case, the
compromise can be, for example, an X-range of 100 km (62.1 mi) and a Y-range of
99.5 km (61.8 mi) to get a perfect 480 × 480 display.

10.2.3 Product Parameters
In Product Parameters, define the data taken from the task and how to display the data.
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Data : Display

Select Data:Display to show a list of valid display parameter options. The available choices
vary depending on the product type.

This parameter specifies from which data parameter the product is derived. For example, Z,
V, W, ZT, or ZDR. This information comes from the task associated with the product. Some
data parameters can be displayed in more than one way.

Table 31 Data types

Data type Description

Ah, Av Integral attenuation for horizontal (H) and vertical (V) channels

Azdr Integral attenuation of ZDR (dB) format

CSR Doppler channel clutter-to-signal (CSR) ratio of dBT to -dBZ

dBT, dBTh, dBTv, DBTr Total power

dBZ Clutter corrected reflectivity

dBZt Uncorrected reflectivity

HCLASS Hydrometeor classification

Estimated hydrometeor type in the precipitation area

KDP Specific differential phase

An indicator of the rate of change of the phase difference between
horizontally and vertically polarized pulses of the radar. A greater horizontal
shift results in a positive KDP value, and a greater vertical shift results in a
negative KDP value. Typical cause for a high KDP area is heavy rain.

LDRH, LDRV Linear depolarization ratio H to V (or V to H)

The ratio of cross-polar to co-polar reflectivity measured in dB

LOG Log receiver signal-to-noise ratio
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Data type Description

PHIH, PHIV Horizontal (V) or vertical (V) differential phase

Phase difference for the total round trip between radar and the volume where
the signal is reflected. PHIH is measured between HH and HV channels. PHIV
is measured between VV and VH channels.

PHIDP Differential phase

The phase difference due to propagation between the HH and VV channels of
the radar.

PMI Polarimetric meteo index

R Rate of accumulation of precipitation in units of mm/hour

For snow, this is usually refers to the liquid equivalent.

RHOHV, RHOH, RHOV Correlation coefficient between HH and VV (or HH & HV / VV & VH) channels

Higher (>0.95) values indicate uniform precipitation areas, and lower values
indicate more mixed hydrometeor types, such as melting snow, wet
snowflakes, or airborne debris.

SNR Signal-to-noise ratio

Generic measurement of signal-noise ratio in dB

SQI Signal quality index

A value between 0-1 that measures the signal's Doppler coherency, that is, the
correlation between the signal and its Doppler lag:
• 0 indicates white noise
• 1 is the perfect Doppler point target

T Total reflectivity

Total power returned to the radar in reflectivity units. It typically represents
the horizontal reflectivity without ground clutter correction.

TV, TE Total vertical (HV enhanced) reflectivity

Total reflectivity from the vertical polarization channel (TV) and combination
of the horizontal and vertical channel (TE)

V Velocity

Average radial velocity (towards or away from the radar) of detected
hydrometeor areas

VC Corrected velocity

Same as velocity V, but corrected for effects of range folding and velocity
folding

V: SHEAR, Vc: SHEAR Velocity and corrected velocity of wind shear

W Spectral width

Variability of Doppler velocity values within the measurement area

XCOR Polar cross-correlation, uncorrected rhohv
Because this value is not noise corrected, this is a direct indicator of the PHIDP
uncertainty.
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Data type Description

Z Reflectivity

Usually referred to as dBZ, this is the common data type that measures radar
signal reflectivity, and is used to estimate precipitation intensity from that.

All Z measurements are corrected for ground clutter.

ZV, ZE Vertical (HV enhanced) reflectivity

Total reflectivity from the vertical polarization channel (ZV) and combination
of the horizontal and vertical channel (ZE). Corrected for ground clutter.

ZC Corrected reflectivity

Same as reflectivity Z, but corrected for attenuation and beam blockage
effects

ZDR Differential reflectivity

The ratio of SNR in the horizontal channel to the SNR in the vertical channel.
Positive values indicate more prominent horizontal echoes and negative
values more prominent vertical echoes. Larger hydrometeor sizes are usually
identified by high positive ZDR values.

ZDRC Corrected differential reflectivity

Same as differential reflectivity ZDR, but corrected for attenuation and beam
blockage effects

Product Maximum Range

If you select a custom Map Projection Name (other than <NONE>), you cannot configure
this field in the product output menu. This is because the maximum range is determined
by the projection configuration.
See Configuring Map Projections (page 79).

This is the maximum range configured for the product, which must be less than or equal to
the data range. The maximum range is the range in the E-W / N-S direction centered on the
radar. This means that the range to the corners of the resulting display is greater.

Rain Alg

You can choose the algorithm for rainfall estimation from a selection that varies from
traditional Z-R relation R(Z) to  advanced algorithms for rainfall estimation that use dual-
polarization algorithms: R(KDP), R(KDP,ZDR) , R(Z,ZDR), NSSL2005.

The parameters are set in the qpe.con file located at /etc/vaisala/irisrda directory.

Table 32 Algorithms for Rain Alg

Algorithm Description

Z-R relation R(Z) This algorithm defines R-Z using the traditional
definition: Z= AR**B.
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Algorithm Description

R(KDP)

R(KDP,ZDR)

R(Z,ZDR)

These algorithms compute R using the various dual-
polarization parameters.

NSSL2005 This algorithm uses a rain intensity -based classifier,
and different equation for each intensity.

For more information on NSSL2005 QPE, see:
Ryzhkov, A. V.,  et. al. Rainfall Estimation with a
Polarimetric Prototype of WSR-88D. J. Appl Meteor.,
44, 502-515.

XY Smoother

The XY Smoother can significantly improve the appearance of products for presentation
and improve data compression. The smoother performs image processing to average the
color contours and interpolate over small gaps or missing pixels in the final Cartesian image.

Specify the length of the smoother in km.

Smoothing requires substantial CPU resources. The internal limit on the
smoother length is 60 pixels, much longer than you probably want to use.
CAUTION!

To produce many smoothed products in a regular operation, Vaisala suggests the following:
• Use low resolution products together with smoothing.

It is faster to make a low resolution product and smooth it than to make a medium
resolution product and smooth it.
In many cases, the results are nearly identical, so there is no benefit in smoothing high
or medium resolution products.

• Use the minimum smoothing length to get the desired effect. Do not over-smooth and
do not use a length that is larger than you need.
Larger smoothing lengths require more computation.

10.2.4 Display Parameters
The display parameters determine how the product appears.
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Display Units

Most data types are numerical. Display Units shows the range of values and the units for the
product's output values.

For example, the Echo Tops algorithm outputs values in km to the nearest 100 m (328 ft 1 in)
spanning the range of 0 to the maximum data height defined with the setup utility or
25.5 km (15.8 mi), whichever is less.

The following table shows the values that you can assign to the display units.

Table 33 Display Units

Display Parameter Maximum Display Range, Display Units, or the Classifier method

dBZ -32 ... 96 dB mm6/m3

dBZt -32 ... 96 dB mm2/m3

Rain 0 ... 255 mm/hr or 0 to 10.2 inches/hr

Liq 0 ... 1000 mm

Vel -Vu to Vu m/s

Width 0 ... Vu m/s

ZDR -8 ... +8 dB

TOPS 0 ... 25.5 km or height configured in Setup

VIL 0 ... 65.0 mm

WIND Configured in Setup

SHEAR +-25 m/s/km

HClass Meteo, Precip, Cell, Meteo+Precip, and Meteo+Cell
The first Classifiers field lets you to choose which classifier outcomes are
projected in the product.

The selector lists the available classification algorithms and their merged
combinations.

Color Scale, Levels, 1st Level/Step

The color scale relates numerical data values to colors.

The Scale field lets you choose whether to use a uniform scale with a start value and a
constant step, or a custom color scale that has been preconfigured for your system:

• Custom color scales are defined with the Color Setup utility. See IRIS and RDA Utilities
Guide (M211316EN).
Each color scale has a name that has been defined in Color Setup.
Names can reflect scales that are appropriate for different seasons such as Summer or
Winter.
If in doubt, select Default which is usually configured to be a reasonable scale. The
number of scale steps are filled-in automatically since this is also part of the custom
color scale.
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• When you choose a uniform color scale, you pick the number of level steps (2 ... 16).
You must also set the following fields:
• The 1st Level field sets the numerical value used to label the right side of the first

level in the color scale for the product.
• The Step field sets the spacing between the color levels. The numbers in the color

legend in the product are spaced by this value.

The color scale also associates the classification data to the class descriptors (class
identifiers with class legends). Sets of class legends can be customized as Classifier sets in
your system (with the HydroClass Name Editor in the Color Setup utility), to match the
available classifier methods.

The following table shows the units you use for the 1st Level/Step, depending on the display
parameter.

Table 34 Display Parameter Formats

Display Parameter 1st Level/Step Format

dBZ + - XX Whole dBZ

dBZt + - XX Whole dBZ

Rain +XXX.X mm/hr

Liq +XXX.X MM

Vel +- X.X m/s

Width + XX.X m/s

ZDR +- X.X dB

TOPS + XX.X km

VIL + XX.X mm

WIND NA

SHEAR +- XX.X m/s/km

For the mean velocity, selecting a level step of 0 causes the velocity to be displayed for
the entire unambiguous interval between -Vu to +Vu.
Selecting an odd number of levels produces a legend with a band centered on 0 velocity.
Selecting an even number of velocity levels does not produce a legend with a band
centered on 0 velocity, but rather a color break exactly at 0 velocity.

When choosing a uniform color scale, you have more flexibility to choose colors. The
associations of the class identifiers with class legends is fixed by the Color Setup.

The following figure shows 2 examples of the display configuration parameters, one for ZT
and one for velocity, and the resulting color legends that would appear with the product.
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In the case of ZT, the example shows that the bottom of the scale "thresholds" such that
data less than -20 dBZ are not displayed, while the top end "saturates" since the top color
includes all values greater than 50 dBZ. When you select uniform scales, the behavior
(saturation vs thresholding) of the end of the scales cannot be changed. This behavior is
inherited from the custom color scale named Default, which is configured in Color Setup.

In the velocity example, by entering 0 for level step, the display automatically spans the full
Nyquist interval. Note that both ends are set to saturate for velocity.

The format of the color legends, with regard to how the numerical legend labels relate to the
color band boundaries, is configured in the Color Setup utility for each parameter. This
utility offers considerable flexibility for defining how the color legends are constructed for
each data parameter. See IRIS and RDA Utilities Guide (M211316EN) .

Figure 22 Color Legend Format Example

Product Picture Resolution

If you select a custom Map Projection Name (other than <NONE>) you cannot configure
this field in the product output menu. This is because the resolution is determined by the
projection configuration.
See Configuring Map Projections (page 79).
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IRIS can produce product pictures in virtually any resolution, from 16 × 16 to 3100 × 3100
pixels. IRIS products are produced specifically for the display resolution that is requested,
optimizing the match between the display pixels and the actual radar data. This means that
high resolution products are not merely low resolution products with replicated pixels.
Likewise, low resolution products are not produced by degrading a higher resolution
product. When you request a high resolution product, you get the best possible image that
can be generated from the original data. If a low resolution product is requested, the
product is computed efficiently by calculating the product only at the requested resolution.
In addition to efficient generation, low resolution products can be transmitted over a
communications link and displayed more rapidly because they contain fewer pixels.

The Resolution field in the Product Configuration menus show the X-Y number of pixels.
These can be changed by entering different numbers of pixels, or by popping up a menu of
the default low, medium or high picture resolutions. The defaults are shown in the following
table for both PPI (square image region with legends to the right) and RHI formats
(rectangular image region with legends beneath). The defaults are optimized to the
resolution of the standard IRIS display devices.

Table 35 Default Picture Resolutions

Default Resolution
RHI (Rectangular)
Format1)

PPI (Square) Format2)  

 X-Pixels Y-pixels X-Pixels Y-Pixels

Low 240 240 288 136

Medium 480 480 600 290

High 720 720 840 530

XHigh 940 940 1060 750

1) Rectangular image region with an optional legend beneath.
2) Square image region with an optional legend to the right.

Regardless of the product type, IRIS determines the best way to display your product in
either PPI or RHI format. If your image does not exactly match the pixel size of a target
display device, IRIS adjusts it to make a best fit. For example, if you output a low resolution
image to a high or medium resolution printer, IRIS doubles the pixels so that the display fills
the image area. Likewise, IRIS shrinks an image if it has more pixels than can be displayed on
an output display device.

If you want the impact of the large screen, but you do not want to burden IRIS with creating
high resolution products, specify 360 × 360 display resolution. IRIS doubles these numbers
to fit exactly in the large display window.

Likewise, 240 × 240 images are tripled to fit exactly in a large display, or doubled to fit in a
medium display.

For more information on data formats, see IRIS Programming Guide (M211318EN).
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11. Scheduling Products

11.1 Product Scheduler Menu
The Product Scheduler menu tells IRIS when to generate a product for automatic or manual
operation.

Because the product generation affects host computer resources, this menu can be viewed
but not controlled by an IRIS observer.

Figure 23 Product Scheduler

Site column
Shows the site for each scheduled product. A product runs only if data from that site
comes to IRIS, either from the radar, over the network, or from a tape.
If the Display field is set to Master (the Master Schedule), there is only one product
entry, regardless of the number of sites scheduled.
Right-click the mouse to show a menu on the site column listing all sites with a *
symbol next to each site for which the product is scheduled.
Select an entry to add or remove the * tag. This makes the Master Schedule
convenient to use for adding or deleting sites from the schedule.

Product column
Shows the name of the product.

Data column
Shows the data parameter configured for the product.

Task column
Shows the name of the associated task.
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Next-Data-Time
Scheduling operates under the concept of data time, the time when a task starts
collecting data. For an on-time task schedule, the data time corresponds to the time
when a task is scheduled to start.
When you schedule a product, set the Next-Data-Time field for the product generator
to process only associated tasks with data times later than the next data time.

Skip
The Skip time breaks the day into equal intervals of time starting from midnight. A
product is generated, at most, once for each skip time interval. The first occurrence of
data from the associated task is used for each interval.

Request
Schedules a product according to whether the schedule affects All, Next occurrences
of the product. You can also stop the product's schedule.

Status
Shows the current status of each product as Running (product is being generated) or
Wait (product is waiting for either the associated task to run, for its turn to run
pending the completion of other products, or the product is not scheduled to run).
After a product is generated, the status changes from Running to Wait.
When the Master Schedule is displayed, Status shows the status of the site which is
either currently running or ran most recently.

Runs
A counter (000 to 999) showing how many times the product has run since it was
loaded in the menu.
If the number of runs exceeds 999, the counter restarts at 000.
If you stop a product, the counter is not reset. The counter resets if you delete a
product and reload it into the schedule. If you load a new schedule, the counters for all
products are reset.
When the Master Schedule is displayed, the Runs field reflects the total number of
runs for all sites that are scheduled.

11.2 Scheduling Products
1. Select Menu > Product Scheduler.

A list of available product types appears.
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2. In Display, on the top of the menu, specify which sites are displayed.

Value Description

All Sites Show the schedule for all sites.

Master Show the Master Schedule, with one entry for each scheduled product.

If a product is scheduled to run at multiple sites, the entry shows the site that ran
most recently.

Site Group Show the products that are configured for all sites in the group.

The Site Group is a subset of sites that is defined in the Site Group field.

Single Sites Show the products configured for a single site (select the site name). Use this if
your system supports one site.

The adjacent text field shows how many products match the display selection.

3. In Add for, on the top of the menu, specify the sites for which the product is added.

Value Description

All Sites Add the product for all sites.

Site Group Add the product for all sites defined by the Site Group.

Tag with * the members of the site group. If you have a single site system, make
your site the only member of the Site Group.

Single Sites Add the product only for that site. Use this if your system supports one site.

4. To edit the products configured in the product schedule, right-click the Product field
and select one of the following:

Value Description

Add Add a product to the schedule.

The product is generated on an on-going basis when the task collects data, subject
to the Skip time.

Remove Remove the selected product from the list for the site that is displayed.

If the Master Schedule is displayed, then the product is removed for all sites.

Edit Opens the Product Configuration menu for the selected product.
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5. To generate data only from future tasks:

a. Right-click the Request field

b. Select All or Next.

Value Description

All All associated task data collected after the next data time are processed.

The product is generated on an on-going basis when the task collects data,
subject to the Skip time.

Next Only data from the next occurrence of the task, after the next data time, are
processed.

The product is generated only once.

The Skip time is ignored.
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6. If you use All requests, you can set the Skip field so that the product generator does
not process every occurrence of the associated task.

By default, an All request causes data from every task to be processed. The Skip time
breaks the day into equal time intervals starting from midnight.
A product is generated, at most, once for each skip time interval. The first occurrence of
data from the associated task is used for each interval.
For example, a Skip time of 00:15 (15 minutes) means that the product is generated
no more frequently than every 15 minutes, regardless of how often the associated task
runs.
In the following figure, the Skip field for an All request is set so that there are 2
occurrences of the task in each interval. Only the first occurrence is used to generate
the product.

TASK TASK TASK TASK TASK TASK TASK TASK

Time

Product Product Product Product

Skip Time
Interval

The default value of the Skip field is 00:00, indicating no tasks are skipped.
When the Master Schedule is displayed, a change in the Skip Time is applied to all of
the sites.

You must consider the task schedule when specifying the Skip time.

During operation, the Next-Data-Time field changes to show the next possible time
that the product can be generated. This depends on the Skip time and the request (All
or Next) as follows:

Skip and Request Values Description

Next Any Skip Time After completing a Next request, the Next-Data-Time field is reset to
the data time (plus 1 second) of the task that was just processed.

This means that issuing another Next request processes the next
occurrence of the associated task.

The Skip time is ignored.

All Skip Time = 00:00 The product is generated for every occurrence of the associated task.

The Next-Data-Time field is reset to the data time (plus 1 second) of the
task that was just processed (identical to the Next request case).

This is the same as issuing a series of Next requests.
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Skip and Request Values Description

All Skip Time >00:00 The Skip field determines the earliest time that a new product can be
generated.

After completing a product, the Next-Data-Time field is reset to the
beginning time of the next skip time interval.

7. To generate data only from future tasks, right-click the Request field.

Request Field
Options

Description

All All associated task data collected after the next data time are processed.

The product is generated on an on-going basis when the task collects data, subject
to the Skip time.

Next Only data from the next occurrence of the task, after the next data time, are
processed.

The product is generated only once.

The Skip time is ignored.

Stop Stops the selected product's schedule.

When the Master Schedule is displayed, a change in the Request is applied to all of the
sites.

8. To generate products from old data, right-click the Next-Data-Time field.

This allows you to generate products from task data received from another IRIS host or
retrieved from tape.
The following example shows how Next-Data-Time interacts with All and Next request
options.

TASK TASK TASK TASKTASK TASK TASK TASK

Past TASKS Present Future TASKS

Next Data Time

Next Request

All Request

Time

When a product is first loaded into the schedule, or an entire new schedule is loaded,
the Next-Data-Time field defaults to the current time.

a. In the Next-Data-Time column, right-click the time stamp.

b. Select Next > Product > Time buttons to go back in time.

9. Select File > Save and give a name for the product scheduler.
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11.3 Adding a Product to Schedule
1. Select the header or product for the type of product you want to enter.

2. Position the cursor over the Product field and select Add.

IRIS displays a list of products of that type.

3. Select a product.

The product is added to the schedule.

11.4 Removing a Product from Schedule
1. Select the product you want to remove.

2. Place the cursor over the Product field and select Remove.

You can remove products only. IRIS does not remove product headers from the
schedule.

11.5 Editing Product Configuration
1. Select the product you want to edit.

2. Position the mouse cursor over the Product field and choose Edit.

IRIS opens the Product Configuration menu with the selected product loaded into it.

3. Edit the product as needed.

4. Select File > Save.

5. Exit the Product Configuration menu.

IRIS returns you to the updated Product Scheduler menu.

11.6 Stopping Product Generation
1. Select the product you want to stop.

2. Position the mouse over the Product field and choose Stop.

If the product is waiting to be generated, the Stop request unschedules the product
from the All or Next states.
If the product is being generated when you make the Stop request, no product output
file is produced.
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11.7 Tips for Running Radar Products
Optimize System Performance

You can configure an almost unlimited number of products in IRIS. The system manager
must carefully plan the product mix and performance capabilities for your installation.

Table 36 System Performance Considerations for Generating Radar Products

Consideration Description

CPU capabilities You can improve performance by off-loading product output processes to a different
machine. Consider generating products on a separate IRIS Analysis system.

Product mix Avoid wasting computer resources by making products that no one will look at.

For example, people do not usually look at 12 CAPPI products. A mix of CAPPI, VIL, and
TOPS may be more appropriate.

Output devices Consider the trade-off between output devices and product mix.

If you are driving many remote nodes, you can generate fewer products.

High resolution
displays

Do not create if not required. Medium and low resolution products run more quickly. Prefer
low resolution products for serial line remote displays because the update rates are faster.

High resolution
sampling

Do not use in your task configurations if not required. If you want to use high resolution
sampling (in azimuth and range), do not sample at ranges greater than you need for your
application.

Custom
products

If users want to request many custom products, consider purchasing a separate workstation
for running display software. This means you can to obtain RAW data from the IRIS host and
process products on the separate workstation.

Immediate Products

Most IRIS products are volume scan products that require a series of PPI products.

Immediate products can run before a volume scan is complete because they are based on a
single sweep of data. Use immediate products for applications where rapid feedback is
required. For example, PPI, RHI, or SHEAR.

Making Products from Retrieved Data and Keep Flags

When RAW product files are restored from a tape, they are automatically reingested to
reconstruct the ingest files required for product generation.

Because the data from tape are old, they are first on the list to be deleted by the system
Watchdog process. To avoid this, do the following in the Ingest Summary menu:

• Before retrieving files from a tape, delete some unneeded ingest files.
• After the files are restored, tag the reingested files with Keep flags so they are not

deleted when real time files come in.

For information on space reserved for ingest files, see Setup in IRIS and RDA Utilities Guide
(M211316EN).
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12. Managing IRIS Radar
Passwords

12.1 Changing the observer Password

You must be a root user to change the observer password.

1. Open a terminal window and switch to root user by typing:

su - <root password>

2. To change the observer password:

a. Type the command:

passwd observer

b. Type the new password and press ENTER.

c. When prompted, type the new password again and press ENTER.

If the new password is considered to be too weak, you will get a message about a
bad password.
Note that weak passwords are accepted by the system.

3. Close the terminal screen and logout.

12.2 Changing the radarop Password

You must be a root user to change the radarop password.

IRIS User Guide M211317EN-K

100 RESTRICTED



1. Open a terminal window and switch to root user by typing:

su - <root password>

2. To change the radarop password:

a. Type the command:

passwd radarop

b. Type the new password and press ENTER.

c. When prompted, type the new password again and press ENTER.

If the new password is considered to be too weak, you will get a message about a
bad password.
Note that weak passwords are accepted by the system.

3. Close the terminal screen and logout.

12.3 Changing the root Password

You must be a root user to change the root password.

1. Open a terminal window and switch to root user by typing:

su - <root password>
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2. To change the root password:

a. Type the command:

passwd

b. Type the new password and press ENTER.

c. When prompted, type the new password again and press ENTER.

If the new password is considered to be too weak, you will get a message about a bad
password.
Note that weak passwords are accepted by the system.

3. Close the terminal screen and logout.
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13. IRIS Radar System
Administration

13.1 Starting, Stopping, and Restarting
IRIS Software

IRIS starts automatically on boot-up. If necessary, you can start, stop, or restart IRIS
manually using the following commands

Check that power is applied to the radar and all IRIS devices.

When IRIS starts up, it tries to execute default operating tasks.
If there is a danger to personnel from radiation, set your radar console switch in the
Local position so that IRIS cannot take control.
You can also configure a mode named DEFAULT that does not start the radar antenna
and transmitter. See Running Radar from the Radar Status Menu (page 30).

CAUTION!

1. Login as radarop.

2. To start IRIS manually, in the operating system prompt, type:

sudo service iris start 

The IRIS startup process starts.

3. To stop IRIS manually, in the operating system prompt, type:

sudo service iris stop

4. To restart IRIS manually, in the operating system prompt, type:

sudo service iris restart

When start-up is complete, the operating system prompt reappears, and IRIS is ready to use.

If you have trouble with your system, run:

sudo journalctl -u iris.service
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13.2 Rebooting the IRIS Host
The host server usually runs 24 hours a day. If it is turned off, or if there is a power failure,
the system manger or an operator designed by the system manager must boot the system.

Most systems, and unattended systems, are configured to reboot automatically when the
power is turned on. This can take several minutes to complete. If you expect your system to
reboot automatically, but it does not, check the BIOS configuration.

1. To reboot the local machine, login as radarop or observer.

To reboot a remote machine, you must be logged in as root.

2. To reboot the server safely, type:

reboot

3. Press ENTER.

13.3 Shutting Down IRIS Host from the
Operating System

Typically, IRIS is stopped only for maintenance reasons, such as before halting or rebooting
the server.

1. Login as radarop.

2. In a terminal window, type: iris&
The IRIS Menu opens.

3. Connect to localhost, or to a configured radar hostname.
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4. To avoid interrupting the current radar measurement and creating an incomplete data
file, finish the current measurement:

a. On the Task Scheduler menu, select STOP (When Done) for all tasks.

b. Wait until the tasks are finished and the Ingest Process status in the radar status
screen changes to Idle.

5. Open the radar status screen by selecting Menus > Radar Status from the upper menu
bar.

6. On the radar status screen, select Ingest Process to change the status field to Stopped.

7. Set Radiate to Off/Off.

8. Close the IRIS Menu bar.

9. In the operating system prompt, type:

qiris
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10. If necessary, shutdown the server from the command line, by typing:

poweroff

IRIS goes through a shutdown procedure to leave the radar and antenna in a safe, non-
operating state. IRIS clients are disconnected.

13.4 Stopping IRIS processes
IRIS starts automatically on boot-up. If necessary, you can start, stop, or restart IRIS
manually using the following commands

1. Login as radarop.

2. To stop IRIS, type:

qiris

3. To stop RCP8, type:

sudo service rcp8 stop 

4. To stop RVP, type:

sudo service rvp10 stop

5. To stop the antenna library, type:

qant

6. To check if any processes are left hanging, use the ps_iris command.

See ps_iris command (page 107).

13.5 Starting IRIS processes
IRIS starts automatically on boot-up. If necessary, you can start, stop, or restart IRIS
manually using the following commands

1. Login as radarop.
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2. To start RCP8, type:

sudo service rcp8 start

3. To start RVP, type:

sudo service rvp10 start

13.6 ps_iris command
Use the ps_iris command to list currently active IRIS, antenna, and utility processes,
including information about their owner UID, PID, time start time, and total CPU time.

To stop a process, use the PID as an argument to the kill command.

For example:

Detached Processes:
   USER     GROUP PID  PPID  NI PRI %CPU TIME %MEM    VSZ COMMAND
   operator users 3353   1   0  19  0.0  0:02  0.0 168216 server IRIS_SERVER
   operator users 3355   1   4  15  0.0  0:00  0.0 142236 sserver IRIS_SSERVER
   operator users 3399   1  -8  27  0.0  0:49  0.0 136788 ingfio IRIS_INGFIO
   operator users 3407   1   4  15  0.0  0:00  0.0 136768 network IRIS_NETWORK
   operator users 3411   1   8  11  0.4  7:17  0.0 143124 product IRIS_PRODUCT
   operator users 3413   1   8  11  0.0  0:00  0.0 157800 reingest 
IRIS_REINGEST
   operator users 3415   1   4  15  0.0  0:00  0.1 180620 output IRIS_OUTPUT001
   operator users 3418   1   4  15  0.0  0:01  0.0 156556 output IRIS_OUTPUT002
   operator users 3420   1   0  19  0.0  0:02  0.0 136776 input IRIS_INPUT01
   operator users 3423   1   0  19  0.0  0:09  0.0 138996 watchdog 
IRIS_WATCHDOG
   operator users 23970  1  -8  27  0.0  0:08  0.0 142164 ingest IRIS_INGEST

Antenna Processes:
   USER     GROUP  PID  PPID  NI PRI %CPU   TIME %MEM    VSZ COMMAND
   operator users  1756   1    0   19  0.0  0:04  0.0 115676 ant_logd ANT_LOGD
   operator users  1789   1   -15  34  0.0  0:51  0.0 115684 ant_rcvd ANT_RCVD
   operator users  1793  1789 -15  34  0.0  1:10  0.0 115684 ant_rcvd ANT_RCVD
   operator users  1823   1   -15  34  0.0  1:08  0.0 115680 ant_xmtd ANT_XMTD
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Stand-alone Utilities:
   USER     GROUP      PID  PPID  NI PRI %CPU   TIME %MEM    VSZ COMMAND
   radarop  radarop  23933 23923   0  19  0.0   0:00  0.0 116244 audio 
iris_audio 
   operator users     4321  4319   4  15  0.0   0:00  0.0  12636 clntRecv 
CLNT_RECV_WINDOW -pipe 8 
   radarop  radarop  23923  4163   0  19  0.0   0:04  0.0 189464 iris 
   radarop  radarop  23934 23923   0  19  0.0   0:00  0.0 116236 iris_clnt_rcv 
7 1073741826 
   operator users     3330     1   0  19  4.6  67:30  0.0 699324 /rcp8 -
console /dev/null 
   operator users     2021     1   0  19  9.4 138:57  0.4 796880 /rvp10 -
daemon 
   operator users     2297  2021   -  50 12.0 176:43  0.3 275560 rvp10proc 
RVP10_PROC-0 
   operator users     2347  2021   -  50 11.8 172:44  0.3 275556 rvp10proc 
RVP10_PROC-1
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14. Troubleshooting

14.1 Checking event logs
Table 37 IRIS, RCP8, and RVP event logs

Command Description

# systemctl - u iris IRIS startup messages.

less /var/log/irisrda/IRIS_ERROR.LOG IRIS errors and messages.

# systemctl -u rcp8 RCP logs

less /var/log/irisrda/rvp10.log RVP logs

14.2 Error Handling
When running IRIS, you may encounter errors, for example, mistakes that you make, such as
trying to enter an IRIS menu before connecting to a server, or errors in the IRIS software.

When possible, IRIS tells you how to fix user errors. If you encounter software errors are
more difficult to fix, contact Vaisala for assistance. Provide as much background information
as possible.

When an error occurs, IRIS takes the following actions:
• Displays a pop-up message indicating the cause of the error and possible fixes.
• Adds the message to the Message List, including information about the cause of the

error.
Include this information if you report the error to Vaisala. The list spans IRIS sessions.
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14.3 Viewing the Message List

Figure 24 Message List Menu

Table 38 Message List Sections

Section Description

Message Summary Information about the cause of the error, such as the signal that was generated and
the code module that handled the error.

Message List List of messages in chronological order with no duplicates.

1. On the IRIS menu bar, select Menus > Message Summary.

Alternatively, select Radar Status. In the Control section, select Messages.

The fields in the message summary area are blank.
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2. To display summary information about a message, select the message in the list in the
lower pane.

IRIS fills in the summary information.

Field Description

Index Every message is assigned a number in the order in which it occurred.

For repeating messages, the Index field shows the number of the latest occurrence of
this message.

Repeats Shows the number of times the message has occurred.

Time Shows the time of the most recent occurrence of the message.

Date The date and time of the most recent occurrence of the message.

Message Contains the message text.—the same text that is displayed in the Message menu.

Signal Every error generates a signal, or error condition code.

The Signal field shows the name of the generated signal. This information is useful if
you report a software error to Vaisala.

Process Shows the name of the code module that trapped and processed the error. This
information is useful if you report a software error to Vaisala.

14.4 Reacting to IRIS Messages

Figure 25 IRIS Message

1. Select OK to dismiss the IRIS Message and continue with IRIS operations.
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14.5 Authorizing remote X–Windows on
your node

1. To enaböe IRIS systems running on other nodes to send output to your screen, enter
the command:

$ xhost  +<host>

Where <host> is the remote hostname, or IP address.

2. Check that this works as you intend.

3. Add the appropriate command at the end of one of the following files:

• To authorize the windows as soon an anyone logs in: /etc/profile.d/
sigmet.sh

• To support just one user authorizing the windows: home
directory .bash_profile

14.6 Correcting File Ownership and
Protection

Sometimes, when starting or program or trying to access calibration files, users cannot
access some files or receive an error message saying they do not have privileges to do an
operation.

This is because the file ownership and protection settings are incorrect.

Do not change the file protection manually. Always use instiris –setown to fix the
protection of your files.

1. To correct the file ownership and protection, type:

# instiris –setown

The script goes through the /etc/vaisala directory tree, changing the ownership of
the files to operator and setting the protection as follows:
• Directories—rwxrwxr–x
• All files, except executable files—rwrw–r--
• Executable files—rwsrwsr–x
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14.7 Replacing failed OS RAID disks
RAID1 is automatically configured on the server. However, in some cases, you may need to
remove, recover, and add new devices to RAID.

In most cases, this requires removing the failing disk and installing a new one.

While you can do this while powered up, if the system allows you to power down, do so.

1. To check the status of the RAID1 disk, type:

cat /proc/mdstat

When RAID1 is working correctly, the terminal prints, for example:

Personalities : [raid1]

md126 : active raid1 sda[1] sdb[0]

      125032448 blocks super external:/md127/0 [2/2] [UU]

md127 : inactive sdb[1](S) sda[0](S)

      4520 blocks super external:imsm

• [UU] indicates that both disks are operational.
• If there is a problem with one of the disks, the [UU] string is [_U] or [U_].

2. Check if disk sda or sdb has failed.

3. To remove the disk from RAID configuration, type:

Take care when removing the failing disk.
Remove only the disk identified as failing. In the following example, it is sdb.

mdadm --manage /dev/md/imsm0 --remove /dev/sdb

The terminal prints:

mdadm: hot removed /dev/sdb from /dev/md/imsm0
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4. Power down computer, replace the failing disk, and reboot

5. To create the partition on the replacement disk, type:

sfdisk -d /dev/sda | sfdisk /dev/sdb

6. To verify the partition, type:

fdisk –l

7. To add a new disk to the raid array, type:

mdadm --manage /dev/md/imsm0 --add /dev/sdb

8. To check the recovery process, type:

cat /proc/mdstat

The terminal prints:

[root@wes-install ~]# cat /proc/mdstat

Personalities : [raid1]

md126 : active raid1 sdb[2] sda[1]

      125032448 blocks super external:/md127/0 [2/2] [UU]

md127 : inactive sdb[1](S) sda[0](S)

      4520 blocks super external:imsm

 unused devices: <none>

14.8 Making Quick Look Windows (QLW)
appear

For any problem that prevents the window from starting, IRIS prints:
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OUTPUT, Error in open_display call.

The Radar Status menu also indicates Error and Exit next to the window process.

If you cannot identify the problem from the error message:

1. Check that the workstation is turned on and the network is up and running.

2. Login as radarop.

3. Open the Radar Status menu and toggle the Product Output process off/on.

4. In the command prompt of the workstation where the window should appear, check
the user rights by typing:

xhost+

5. Restart IRIS on your workstation by typing:

sudo service iris restart

This command restarts all IRIS processes.CAUTION!

IRIS tests each process and restarts any that have stopped.

6. If the IRIS Quick Look Window (QLW) does not appear after typing siris in a terminal
window:

a. Log in as root.

b. In the first line of the /etc/hosts file, add the host name to the first line of the file:

127.0.0.1 <host-name> local host... 
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Appendix A. Task
Configuration Examples

A.1 Task configurations
You can customize and add to the default task configurations.

Note the following guidelines when creating or modifying tasks:
1. As it is not possible to get the best velocity and reflectivity data at the same time,

default tasks are divided as follows:
• Long-range surveillance with coarse spatial resolution for detecting weak echoes

(SURVEILLANCE task).
• Medium-range polarimetric volume with good spatial resolution for high quality

reflectivity and polarimetric data (VOL_A and VOL_B tasks).
• Short-range volume with good spatial resolution for high quality velocity data

(WIND task).
2. To maximize signal processing data quality, all tasks use 2-byte data in the radar server

computer.
By default, all RAW products are truncated into a 1-byte form for transmission. If the
bandwidth allows, use 2-byte data in RAW products.

3. After installing and calibrating the radar system or if you change the default task
processing parameters, you must adjust the quality threshold values.
For example, if you increase the number of samples, enter a slightly decreased LOG
value to improve measurement sensitivity.

4. The tasks use Doppler filter number 4, which is a Gaussian adaptive (GMAP) filter with a
0.4 m/s width.
Depending on the clutter conditions, test a weaker filter (number 3 or smaller) or a
stronger filter (number 5 or greater) to find the optimal filter for your radar site. All the
tasks use a CSR threshold of 40 dB.
Depending on the clutter conditions, you can test a stronger value (less than 40 dB).
Before finalizing the setting, measure with real weather to verify that the weather
echoes near zero velocity do not vanish (Doppler snake).

5. To benefit from the enhanced sensitivity of the polarimetric signal processing, use the
Ze data moment to generate echo products.

More information

‣ IRIS Tasks (page 11)

A.1.1 SURVEILLANCE
The SURVEILLANCE task is optimized for long-distance detection of precipitation echo. It
uses the longest available pulse width of the weather radar system.
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Dual-polarization systems use the enhanced reflectivity Ze along with a large number of
processed samples to significantly improve the sensitivity when compared with single
polarization systems. Samples are collected from a large contributing area using a wider
azimuthal spacing of the radar rays (2°) and a range averaging over several consecutive
range bins.

The default configuration has a maximum range of 450 km. Use it in warm climates. In
cooler climates, lower the maximum range to, for example, 350 km in summer or 250 km in
winter. Shorter ranges allow for higher pulse repetition frequencies (within the range) and
more pulses can be configured within the constant run time.

The LOG threshold is optimized for tropical conditions with a clear margin of noise
uncertainty, even in conditions of extreme rain. In cooler climates, with a calibrated radar,
the LOG threshold can be as low as 1.2 dB.

The following figure shows the task configuration details for a dual polarization system. Blue
circles indicate items with different values in single polarization systems.
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Figure 26 SURVEILLANCE task configuration: dual-polarization

Azimuth resolution 1.00°
Polarization Horiz
Samples 35
DP Attn Cor Z ZDR disabled
Range Avg/Smt 2
Proc mode FFT
Measured data moments T, Z, Vel, Width, SQI

A.1.2 VOL_A
The VOL_A task is the lower part of the hybrid volume scan VOL_A and VOL_B. It is
optimized for precipitation observations and measurements within a range of 250 km. Use a
single pulse repetition frequency mode for the maximum quality of Z and dual polarization
moments.

Dual polarization systems use the enhanced reflectivity Ze to improve sensitivity. The Z data
fields are quality-controlled for maximum rejection of non-meteorological echo. The Z data
presents the true fields of precipitation. The combined observations of KDP and Z are used
in quantitative rainfall estimates.
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In difficult conditions with moving clutter, sea clutter, and interference, you can raise the PMI
threshold to as high as 0.55. Try a higher SQI value with some loss of precipitation in the
melting layer and in strong convection.

The following figure shows the configuration details of the task for a dual polarization
system. Blue circles indicate items with different values in single polarization systems.

Figure 27 VOL_A task configuration - dual polarization

Polarization Horiz
DP Attn Cor Z ZDR disabled
Proc mode FFT
Measured data moments T, Z, Vel, Width, SQI

A.1.3 VOL_B
The VOL_B task fills the higher elevations of the hybrid volume providing observations of
standard and dual polarization moments for volume products, such as CAPPI.
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The task uses high pulse repetition frequency and delivers high quality radial winds in the
range of +/- 16 m/s. Due to a high pulse repetition frequency, high elevations, and the
modest ranges in use, narrow precipitation spectra are possible. The quality of standard and
dual- polarization moments is good. The hybrid volume data of VOL_B offer inputs for a
variety of meteorological products.

At higher elevation angles:
• The system is less likely to detect second trip echoes or non-meteorological targets and

thus, SQI and PMI thresholding is not used for Z data fields by default, unlike in VOL_A.
• Enhanced reflectivity Ze is not selected like for short measurement ranges of high

elevations as it does not bring significant sensitivity improvements.

The following figure shows the configuration details of the task for a dual polarization
system. Blue circles indicate items with different values in single polarization systems.

Figure 28 VOL_B task configuration - dual polarization

Polarization Horiz
DP Attn Cor Z ZDR disabled
Proc mode FFT
Measured data moments T, Z, Vel, Width, SQI
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A.1.4 WIND
The WIND task is a short distance volume scan providing wind observations for products
such as VVP and WIND.

The task uses the FFT major mode in H-only. A robust dual pulse repetition frequency
provides unambiguous winds of up to +/- 50 m/s, up to a range of 78 km. The quality
settings are those of a classic Doppler.

A higher dual pulse repetition frequency ratio (4:3, 5:4) can increase the unambiguous
velocity regime and/or the maximum range. However, using higher dual PRF ratios as well as
longer ranges decreases the quality of velocity data.

Figure 29 WIND task configuration

A.1.5 SUNCAL and ZDRCAL tasks
Detailed configurations of the SUNCAL and ZDRCAL tasks are in the /etc/vaisala/
irisrda/suncal.conf and zdrcal.conf files.

Appendix A – Task Configuration Examples

RESTRICTED 121



Figure 30 SUNCAL and ZDRCAL task configurations

SUNCAL

For the SUNCAL task, adjust the start, stop, and repeat time for each site so that the task is
executed three times a day: shortly after sunrise, at noon, and just before sunset.

ZDRCAL

ZDRCAL task is only for dual polarization systems.

A.2 Product configurations and scheduler

A.2.1 RAW products
The radar system produces RAW products on the radar server computer and sends them to
the central site for product generation.

To reduce communication bandwidth, by default data is truncated to1- byte, 8-bit resolution
from the original 2-byte, 16-bit resolution.

If the communication bandwidth allows, use 16 bit resolution to improve data quality for
post-processing:

1. On the product configuration menu, select Type > RAW.

By default, the option is Forced 8-bit Format, which truncates the content.
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2. Select Preserve Format to preserve 16-bit resolution.

3. Select File > Save As > OK.

A.2.2 Melting height products
In dual polarization systems, a melting height product, VOL, is configured and scheduled by
default.

This product uses tasks VOL_A and VOL_B to compute the height of the melting layer.

Figure 31 Melting height product configuration
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A.2.3 Product Scheduler
If you need other products at the radar site, add them to the Product Scheduler. This
applies to both radar site and central site data production.

Input task(s) Products

Surveillance Weather reflectivity surveillance.

VOL_A and VOL_B Reflectivity-related end user products, such as rain or storm detection or hydrological
measurements.1)

WIND Wind-related products.

For example, V, VVP, WIND, and SHEAR.

1) In dual-polarization systems, use the R (Z, KDP) algorithm for QPE products, such as rainfall rate or accumulation.

Figure 32 Default Product Scheduler
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Appendix B. IRIS Data
Parameters
Table 39 IRIS Data Parameters

Abbreviation Definition

dBT
T

Uncorrected reflectivity.

dBZ
Z

Clutter-corrected reflectivity.

dBZ c
Zc

Reflectivity with corrections for attenuation, occultation, and so on.

Vel
V

Mean radial velocity.

Vc Radial velocity corrected for folding.

Width
W

Doppler spectrum width.

Rain
R

Rainfall rate.

Liq Rainfall depth.

Tops Echo Top height.

VIL Vertically integrated liquid.

Wind Wind speed and direction.

Shear Wind shear.

SQI Signal quality index for Doppler coherency [0 ... 1].

Table 40 IRIS Data Parameters for Dual Polarization Systems

Abbreviation Definition

ZDR Differential reflectivity.

PhiDP Correlation differential phase between HH and VV channels.

KDP Specific differential phase (degress/km) between HH and VV channels. Based on derivative
of PhiDP.

RhoHV Correlation magnitude between HH and VV channels.

LDRH
LDRV

Linear depolarization ratio for H (or V) transmit cross-/co-polar.
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Abbreviation Definition

RhoH
RhoV

Correlation magnitude between H and V receive for H (or V) transmit

PhiH
PhiV

Correlation phase between H and V receive for H (or V) transmit
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Appendix C. Passive IRIS
Features

C.1 Passive IRIS Overview
For most installations, IRIS actively controls the radar and antenna through the RVP
processor and the RCP.

For some installations, the radar and antenna are controlled by an external RCP and IRIS is
connected to the radar by the signal processor. In this case, the external control system
performs the scanning and IRIS listens to the signal processor in passive mode.

In passive mode, the radar tasks in IRIS are configured to match the scanning performed by
the external control system and IRIS synchronizes to the external scanning. That is, IRIS
deduces which TASK should be running, starts the TASK, and acquires the TASK data from
the signal processor.

Passive IRIS requires that antenna angle information be supplied to the RVP.

Use Cases For Passive IRIS
• If IRIS is installed in parallel with an existing data acquisition system. The existing

system does its own thing and IRIS follows.
• If 2 radars at different frequencies (and correspondingly 2 IRIS's) share the same

antenna. In this case, one of the IRIS systems can operate in active mode and the other
operate in passive mode to allow simultaneous data collection from both radars.
Another application is when using time series playback.

More information

‣ Using Passive IRIS (page 73)

C.2 Task Configuration, Scheduling, and
Synchronization

Passive IRIS must determine what the active system is doing and then follow along acquiring
when data. The TASK Configuration and TSC Monitor menus must be configured for this to
work.

Task Configuration

For each task run by the active system, you must configure a corresponding task to run on
the passive system. For example, if the active system runs a volume scan, you must
configure a corresponding volume scan in the passive system with the same elevation
angles.
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If the radar trigger is generated externally, you must configure the correct PRF. Note that
dual PRF is not supported by passive IRIS when an external trigger is used. If the RVP
generates the trigger, you can configure any allowed trigger including dual PRF.

For other signal processing, you can configure any processing option. While passive IRIS
must scan the same as the active system, it can use different processing.

Task Scheduler

You must configure the TASK Scheduler with the same tasks that are run by the active
system:

• The tasks must be in the same order as they are run on the active system unless you are
using Status–Slaving.

• If your system can run in active or passive mode, set the Active/Passive menu selection
at the top of the Task Scheduler to Passive.

Task Scheduler Synchronization (Passive type)

The following table shows how passive IRIS can synchronizes the task that it is running to
the active control system.

Using the TSC Editor, you must configure the TSC Monitor with the same tasks that are run
by the active system.

Table 41 Task Schedule Methods

Method Description Supported Scans

Multi-Tasking Passive IRIS tries to run the first task in the schedule. It waits until
the PRF and the starting angle match the task configuration and
then starts acquiring data for the task. Passive IRIS then waits for
the PRF and angle for the 2nd task in the Scheduler and so on. If at
any time it notices that the PRF and elevation angle are a better
match for the start of a different task, then it interrupts to switch
tasks.

You may need to adjust the angle tolerances in Setup/ingest to tune
the task so that it runs properly. For example, if the angles of the
task are close together, the angle tolerance should be smaller than
the angle spacing. Also, the antenna may not achieve the desired
elevation angle, in which case it is better to modify the task in
passive IRIS to match the actual rather than the nominal elevation
angles.

Only continuous
PPI scans

Single–Tasking IRIS allows only one task to be scheduled in the task scheduler.

IRIS waits until the PRF and the starting angles match the task
configuration and then starts acquiring data for the task.

All scans including
RHIs.

Status–Slaving This case requires that a Status product be sent to the passive
system.

If the active system is another IRIS, the Status product on the active
system is generated automatically whenever a task is starts and
contains the name of the task that is currently running. When the
passive system receives this, it starts (or continues running) the
same task.

The Status product must be configured to be output automatically
over the network to the passive system.

All scans including
RHIs.
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Method Description Supported Scans

TS–Playback Used when trying to synchronize to old time series being played
back via the tsarchive utility. Support is required by tsarchive and
by the RVP processor.

This is a variation of the Multi-Tasking mode.

We assume that a single volume scan is being played back. This
volume scan may be approximated in IRIS using a single task,
multiple tasks, or a hybrid task.

IRIS aggressively tries to remain synchronized to the sweeps of the
original data. If a sweep ends before the full 360° is complete, IRIS
immediately switches to the next to prevent losses at the start. If the
sweep is filled before the data is complete, IRIS continues to read
rays from the RVP. This is important to make sure that the next
sweep does not start with the last few rays of the previous sweep.

Only continuous
PPI scans
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Glossary

$IRIS_ROOT
Entry point of the IRIS/RDA install tree

AGC
Automatic Gain Control. The gain of the linear channel video signals is adjusted based
on an estimate of the next signal level. For example using the average power of the
last few pulses at that range.

associated task
The task associated with generating a product. For example, a PPI product requires an
associated task that uses the PPI scan mode (Full or Sector).

BEAM product
Cartesian product similar to the Cross Section perpendicular to the radar which
displays data at a fixed range (or averaged over a range interval) on an azimuth vs.
elevation grid. This is useful for testing the antenna beam pattern when used with a
reference transmitter.

bin
A single sample of weather data detected at a known direction, altitude, and distance
from the radar site. The radial size of a bin increases with distance, so bins further from
the radar site cover a larger area than nearby bins.

bright band
Altitude range over which the falling snow is partially melted, but not completely
changed into rain. Wet snow and wet ice has a higher reflectivity than either dry snow
or rain, so it forms a band of stronger returns. The top of this band is called the Melting
Level or 0°C height.

CAPPI product
Constant Altitude Plan Position Indicator. A CAPPI is a horizontal slice through the
atmosphere at a given height. The positioning and orientation of the cross section is
arbitrary.

composite
Composites combine data (for example, a group of CAPPI, VIL, PPI, or TOPS
products) from many radars in one image.

differential reflectivity (ZDR)
Ratio between the horizontal reflectivity and the vertical reflectivity (dBZh - dBZv).
ZDR depends on the asymmetry of the shape, orientation, and falling behavior of the
particles. Positive values indicate more prominent horizontal echoes (such as from
large raindrops), and negative values indicate more prominent vertical echoes (such
as from hail and graupel).

Doppler spectrum width
The standard deviation of the Doppler spectrum in m/s. The spectrum width is a
measure of the shear and turbulence in the radar pulse volume at a given range. See
also Doppler velocity spectrum.
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Doppler velocity spectrum
The spectrum of the power returned as a function of the Doppler velocity (towards or
away from the radar). The mean of the Doppler velocity spectrum is the mean velocity
computed by the signal processor. The standard deviation of the Doppler spectrum is
the spectrum width (in m/s).

FFT
An RVP signal processing mode based on Fast Fourier Transform. See also PPP.

hybrid task
A group of up to 3 tasks with the same scan type which are scheduled together and
used together to make products. This allows flexibility of volume scanning schemes.

ingest file
A disk file of raw polar coordinate data that is collected during the execution of a task.
Ingest files are used for subsequent product generation. See also RAW product.

IRIS
Interactive Radar Information System. A suite of software tools for configuring,
calibrating, and operating a complete weather radar system.

Kdp
Specific Differential Phase Shift. The range derivative of the differential phase (PhiDP)
expressed in degrees per km. It is nearly linearly proportional to the rainfall rate.

manual scan
IRIS task scan mode in which data is recorded while the antenna is controlled
manually or via a separate program. Feedback is provided by the real time display.

MAX product
Shows the horizontal projection and the E-W and N-S vertical projections (in display
side panels) of the maximum reflectivity in a user defined layer.

Melting Layer
Melting layer or ML (height). Altitude at which falling snow starts to melt. This forms
the top of the Bright Band. Also called the 0°C height.

MLHGT
Melting Level Height Detection

NDOP product
Dual-Doppler velocity product. Combines the velocity measurements from 2 or more
radars to get the wind direction and speed.

NSSL
National Severe Storms Laboratory, Oklahoma, USA

PhiDP
Differential Propagational Phase Shift. The phase difference between the HH and VV
(co-polarized) channels of a polarization radar. It is calculated by taking the argument
of the covariance of these two channels. The differential phase increases with range
more rapidly in regions of heavy rain.
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PhiH or PHIV
The average phase difference between the co- and cross-polar channels for a dual
channel polarization radar operating in fixed or switching mode. The H and V notation
indicates the transmit polarization.

PPI Full
IRIS scan geometry during which the antenna scans continuously in PPI mode without
stopping between elevation angles.

PPI product
Plan Position Indicator. This is the classic radar scan geometry where the elevation
angle is held constant and the antenna is scanned in azimuth. The resulting display is a
two-dimensional image (looking down) at a constant elevation angle.

PPI Sector
IRIS scan geometry where the radar scans in PPI mode between two azimuths.

PPP
Poly-Pulse Pair. An RVP signal processing mode based on pulse pair correlations. See
also FFT

PRF
See pulse repetition frequency (PRF).

protected areas
Regions around the radar (such as runway locations) for which special alerts are
required based on detected radar data.

PRT
Pulse Repetition Time

pulse
A short burst transmission signal sent by the radar, used to measure the weather
activity in atmosphere. The reflection measurements from a pulse are sorted into bins.

pulse repetition frequency (PRF)
Number of pulses transmitted per second. When measuring PRF, a pulse contains
transmit, receive, and dead time phases. PRF affects range folding and velocity folding
detection. In Vaisala IRIS products, PRF limits the area displayed in radar images and
the maximum measurable wind speed.

radar product
Radar products are raw signal data from a radar receiver processed to provide
information about current weather conditions. Radar products are calculated from
ingest files that are collected during the execution of radar tasks. Products may be
data, pictures, or text. For example, PPI and RHI.

rainfall rate (R)
The rate of the accumulation of precipitation (mm/hour). For snow, this usually refers
to the liquid equivalent.
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range folding
Detection of the 2nd trip echoes, which are radar signal echoes from outside the radar
maximum range. Range folding causes them to be incorrectly displayed within the
radar measurement area. Also called range aliasing.

RAW product
Spherical coordinate data product obtained directly from the raw ingest data. The
data are stored in compressed format so they can be recorded on tape or sent to a
workstation for further processing.

real time display
Image created for each scan of the radar as well as the software process that creates
these images.

reflectivity (Z)
ZH - horizontal, ZV - vertical, ZHV - horizontal and vertical.

Property of the target that describes how much of the energy is reflected from the target.
Radars are calibrated to directly give the reflectivity from the received backscattered
energy. Unit for the reflectivity is mm6/m3. The logarithmic value is in dBZ. Also called
reflectivity factor.

RHI product
Range Height Indicator. A radar scan geometry in which the azimuth is held constant
and the antenna is scanned in elevation. The resulting picture is a two-dimensional
vertical slice through the atmosphere.

RhoH and RhoV
The magnitude of the correlation between the co-and cross-polarized channels in a
dual channel receiver polarization radar operating in fixed or alternating H and V
transmit mode.

RhoHV
Correlation Coefficient. The magnitude of the correlation between the HH and VV
channels of a dual polarization radar operating in STAR mode or switching mode in
the range [0,1]. Rain values are typically > 0.98. Wet tumbling hail has smaller values.
This value is useful in helping to identify the particle type.

RVP10
Vaisala Digital Receiver and Signal Processor RVP10. A product suite consisting of
Vaisala Intermediate Frequency Digital Receiver IFDR10 and Vaisala Signal Processor
RVP10SRV.

SHEAR product
Used to identify microburst, gust fronts, cold fronts, and atmospheric waves. SHEAR
calculates the radial wind shear in the radial direction and is sensitive to atmospheric
convergence and divergence.

signal processor
A programmable device for digitizing and processing video signals from the radar
receiver.
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Signal Quality Index (SQI)
The autocorrelation of the received signal at lag 1 divided by lag zero. This is a number
in the range [0,1] where 1 is the perfect Doppler point target and 0 is white noise.
Typically used for thresholding velocity and width at a level of ~0.3...0.4.

SLINE product
Short for "Shearline". Used to identify a front and fitting a line to it. It looks for
elongated regions of high shear and connects them to make a line.

spectrum width (W)
Standard deviation of the Doppler spectrum displayed in m/s. Large width values
indicate high turbulence and/or shear in the pulse volume. It is difficult to measure the
spectrum width when the spectrum width is more than 1/3 of the total Nyquist interval
because of uncertainty in the estimator for broad spectra.

STAR mode
Simultaneous Transmit And Receive. The operational mode of a dual polarization
radar where the radar transmits simultaneously horizontally and vertically.

task
A set of instructions to the radar and signal processing systems including, but not
limited to, the scan type (PPI or RHI), PRF, pulse width, signal processing data types,
time and range averaging criteria. For example, a PPI volume scan at multiple
elevation angles or an RHI at a single azimuth. Also called radar task.

TOPS product
PPI format display of the height of a selectable dBZ echo contour.

TRACK product
Interactive tracking product made. After the operator tags echo features, IRIS inserts
points in a track and extends the track to show the forecast echo motion for a
selectable time.

Vc
Velocity (V) corrected by IRIS for the effects of folding. Note that dual PRF velocity
unfolding performed by the processor is stored as V rather than Vc. Vc is used
primarily for dual Doppler wind field computation which requires unfolded velocities.

velocity (v)
average radial velocity towards or away from the radar of detected hydrometeors in a
measurement volume. Determined by phase measurements from a large number of
successive pulses. The value is reflectivity-weighted. In the calculation, it is assumed
that raindrops and other particles are advected with the wind and have no own
motion except their falling velocity.

velocity folding
Erroneous readings due to particles in the measurement area exceeding the maximum
velocity detection threshold of the radar system. The measured velocity "wraps
around" to the other end of the scale, resulting in discontinuous readings. Also called
velocity aliasing.
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VIL product
Vertically Integrated Liquid. Allows the operator to specify a layer in the atmosphere
and integrates the total liquid contained within the layer. The point estimates of the
liquid are based on a user-defined Z-W relationship.

VVP product
The velocity volume product calculates the vertical profile of the mean wind speed,
direction, divergence and deformation. The algorithm assumes a linearly varying wind
field and performs a least squares fit over a large volume surrounding the radar.

WARN product
Checks other products to determine if significant weather is present. The operator can
define the warning criteria and thresholds. The locations (centroids) of weather
features are also calculated.

WIND product
Uses the velocity volume algorithm to calculate a 2-D horizontal profile of the
horizontal wind speed and direction. The algorithm assumes zero vertical velocity and
a fixed wind field over a sub-region of the area covered by the radar.

XSECT product
A vertical slice through a volume scan. The product is similar to RHI except that it is
constructed from PPI data collected at multiple elevation angles.
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Technical support

Contact Vaisala technical support at helpdesk@vaisala.com. Provide at least the following
supporting information as applicable:

• Product name, model, and serial number
• Software/Firmware version
• Name and location of the installation site
• Name and contact information of a technical person who can provide further

information on the problem

For more information, see www.vaisala.com/support.

Warranty
For standard warranty terms and conditions, see www.vaisala.com/warranty.

Please observe that any such warranty may not be valid in case of damage due to normal wear and tear,
exceptional operating conditions, negligent handling or installation, or unauthorized modifications. Please
see the applicable supply contract or Conditions of Sale for details of the warranty for each product.

Recycling

Recycle all applicable material according to local regulations.
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